IP Telephony - VCX
Showing results for 
Search instead for 
Did you mean: 

VCX Secondary - IP Messaging Not Working

Occasional Visitor

VCX Secondary - IP Messaging Not Working

In July of 2012, we had our VCX Secondary server lockup during a backup. We powered it down by holding in the Power Button. This is something we have had to do before. After this, it would not turn back on (just said Uncompressing Kernel) forever). At that time, we did not have any service contract on the unit, so we just continued using the Primary system only while investigating our options.


This past week we able to "fix" the issue (failed HDD) by using DDrescue and replacing some critical files with copies from our primary server. The secondary now boots with no errors and starts all the VCX services. Currently it is on a test network as I'm a little hesitant to connect it to the real phone network until I gain a little more information about it.


First Question - In our test setup with only the secondary server and a few phones, the server boots, all extensions and mailboxes are present in the web administration, phones can register, but I cannot make any internal calls or check voicemail (I don' t have a spare Gateway so I can't test  external calling). It just says "Temporarily Unavailable" on the phone with a busy signal. I need to fix this first, I'd think. I'm not sure how to go about this. I thought it has something to do with the server not seeing the Primary server on boot, or perhaps the server isn't completely fixed and still has some issues. I'm not seeing any errors so I thought it might be a licensing issue.


Second - how exactly does the replication work? Is it strictly one-way Primary to Secondary? Is there any tombstone dates like AD servers (i.e.. won't sync automatically if secondary has been offline more than 120 days). Since my secondary hasn't synced in so long I don't want to risk affecting my working Primary in any way.


Third - Is there any other precautions or anything else I should think about before plugging this unit back into my production phone network?


Any ideas or help would be greatly appreciated. I'm just becoming familiar with this system (can you tell?) so even pointing me in the right direction would really help me. Thanks!


Software Version 8.0.4e running on IBM x3250 M2's. Setup is Primary/Secondary All-in-One Replicating Pair

Occasional Visitor

Re: VCX Secondary - Not passing calls



After a little more testing I found that internal calling does infact work just fine. I'm imagining external calls should work as well now that I know the call processor is functioning. I just had an error in my logic while I was testing.


What I did find is IP Messaging is still not working. I can login to the Administrative Site and see all of the mailboxes, but I cannot leave messages or check messages no matter which way I try to access voicemail. I did check to see that the voicemail services are running (ran: su - app, then ps -fu app and check for processes of app, cw_ipums, and email). That seems good, so I'm still not sure why voicemail isn't working. I'm thinking it's a configuration issue and it's entirely possible IP Messaging was never quite setup right on this secondary server to work.


So far, I've checked that the IP addresses under Advanced Mailbox settings > Primary Call Processor and Secondary Call processor are set correctly for all the mailboxes.


I'm open for any ideas or things to try and make this work. Without IP Messaging, it seems I won't have any Auto Attendants for my companies main number.

Occasional Visitor

Re: VCX Secondary - IP Messaging not working

After some packet captures I can clearly see that the Secondary server (which my phone is registered to) is attempting to send off the calls that need to go to voicemail to the primary server. Since I have the secondary on a network by itself, it obviously cannot reach the primary, so it gives up and ends the call with either "Temporarily Unavailable" in the case of an unanswered call  or a "408:Request Timeout" in the case of me trying to check my own voicemail.


So, even though the services are running and the voicemail boxes are present, the system still won't "fail-over" and use itself as the IP Messaging server. Clearly in a real failure scenario, this wouldn't be benificial.


Any thoughts or ideas that might help, please let me hear them. Thanks!

Trusted Contributor

Re: VCX Secondary - IP Messaging not working

That is how it is designed to work.  THe Primary and secondary work as a team sharing all resources.  Until you get it back onto the network with the primary I wouldn't make changes to the configuration to make it work on your test network.

It is not usually a good idea to hard power-off the system.  That is how you get corrupted databases.

The Uncompressing Kernel message is normal.  In a factory installed environment, the console is the serial port and not the KVM.  Try connecting a PC to the serial port and you should be able to log in or watch the system start up or shut down.  If you want it to work on the KVM, use the vcx-set-console command and then reboot.

When you are ready to bring it back online, you must ensure that Oracle Replication is dropped on both machines.  Use the /opt/3com/VCX/vcxdata/bin/dropReplication --continue_on_error command to do that on BOTH machines. If you ever need to drop replication again once the secondary is back, leave off the switch so that the drop can happen in the normal way.

Backup the schema on the primary and restore it to the secondary.  Then setup replication again.  You must be logged in as the CWORKS user to do this.  Be VERY patient when setting up replication.  Don't assume that nothing is happening when it goes Quiesced.  If all is well, it will eventuall change to normal.  You can see this with the checkReplication script from the same directory as above.