Ignite-UX

Bootpd Doesnot start in 11iv2 (itanium) ignite server !

 
Makesh Annamalai
Frequent Advisor

Bootpd Doesnot start in 11iv2 (itanium) ignite server !

Dear All,

Please Help to resolve this issue below..Points assured !

I had a ignite server to install the OS for the vparclients. But suddeny it stopped working. So i have checked the bootpd is running but its not running at all.
So tried to start with /usr/sbin/inetd -c..Even then no result so finally started manually by issuing #./etc/bootpd -s -d 3 ..The bootpd started but still the vparclient cud not do the pxe boot.

pls find the screens below

# ps -ef|grep -i bootp
root 4265 3888 0 13:58:03 pts/1 0:00 grep -i bootp

Manually started bootp

# ps -ef|grep -i bootp
root 4289 3888 0 13:58:45 pts/1 0:00 grep -i bootp
root 4281 1 0 13:58:39 ? 0:00 ./bootpd -s -d 2

Vparclient Error :-

Select Desired LAN: 01

Client MAC Address: 00 17 A4 76 0A 0F .....-

PXE-E16: Valid PXE offer not received.
Initializing IO Devices ...
LBA Cell 00 (12/13): Occupied PCI 66MHz
Scan PCI:
Rope Slot Seg Bus Dev Fun Card
====================================================================
12 03 0x00 0xc6 0x01 0x00 Ethernet (0x1645,0x14e4)
LBA Cell 00 (01): Occupied PCI 66MHz
Scan PCI:
Rope Slot Seg Bus Dev Fun Card
====================================================================
01 08 0x00 0x1c 0x01 0x00 Fibre Channel (0x1029,0x103c)
Complete




8 REPLIES 8
Jeeshan
Honored Contributor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

Hi

Check the followings

1. /etc/services that bootpc, bootps and tftp is enabled
2. uncomment bootps and tftpd and restart the services using inetd -c

3. check proper entry in /etc/bootptab
a warrior never quits
YAQUB_1
Respected Contributor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

Hi Annamalai,

See the below thread:-

http://forums11.itrc.hp.com/service/forums/questionanswer.do?admit=109447626+1207648127306+28353475&threadId=1177520

Hope it will help for U.

Thanks--Yaqub
HP Support!!!
Makesh Annamalai
Frequent Advisor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

Hi,

I have followed what was said ..But still the bootpd doesnt start :-(

# ps -ef|grep inetd
root 4651 1 0 15:55:42 ? 0:00 /usr/sbin/inetd
root 4657 3888 0 15:56:09 pts/1 0:00 grep inetd
# kill 4651
#
#
# /sbin/init.d/inetd start
Internet Services started
#
# ps -ef|grep bootp
root 4665 3888 0 15:56:31 pts/1 0:00 grep bootp
Jeeshan
Honored Contributor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

did you really uncomment the line specified in /etc/inetd.conf file?
a warrior never quits
Makesh Annamalai
Frequent Advisor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

/etc/inetd.conf

tftp dgram udp wait root /usr/lbin/tftpd tftpd\
/opt/ignite\
/var/opt/ignite
bootps dgram udp wait root /usr/lbin/bootpd bootpd -d 3


I never diabled it. It was really running fine for 2 years. suddenly i'm facing problem. Even i tried creating new ignite server ..

/etc/services

bootps 67/udp # Bootstrap Protocol Server
bootpc 68/udp # Bootstrap Protocol Client
Scot Bean
Honored Contributor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

On the server:
- check /etc/inetd.conf for 'bootps' lines
- then, 'inetd -c' will restart anything not running
- check /var/adm/syslog/syslog for any 'bootpd' errors

On the client:
Could be many reasons why the client cannot find a boot source:
1) another interferring bootp server
2) /etc/bootptab misconfigured on server
3) client is two far away, cannot span subnets
Bob Ingersoll
Valued Contributor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

Ensure that /var/adm/inetd.sec, if present, contains an entry for bootps:

bootps allow
Makesh Annamalai
Frequent Advisor

Re: Bootpd Doesnot start in 11iv2 (itanium) ignite server !

Dear All,

Thanks for all your effort. It was the problem in the network. There was security been implemented by network team which was blocking the Broadcast. So they have opened the port from Ignite server. Now bootp is running in ignite server. The Vpar is installed with OS.

Thanks all Again