Ignite-UX
cancel
Showing results for 
Search instead for 
Did you mean: 

Disabling dead gateway detection during Ignite image recovery

 

Disabling dead gateway detection during Ignite image recovery

Situation:
*) We're installing a golden image to a brand new system.
*) Our Ignite server is on another subnet as the new system.
*) NFS timeouts occur after a while

Problem:
The new system boots from the Ignite server and performs NFS mounts without problem, but after a few minutes NFS timeouts are reported. Depending on how quick we were with the Ignite GUI it happens when we're still in the Ignite menu, or when we're already installing files.

Question:
We suspect that "dead gateway detection" is the source of the problem (The ip_ire_gw_probe setting in /etc/rc.config.d/nddconf). This detection should be turned off for our network, but how do I check the current ip_ire_gw_probe setting of the Ignite boot kernel?
And can I change it?
The instl_adm command does not seem to offer what I want.

Grtz,

Peter
12 REPLIES 12
F Verschuren
Esteemed Contributor

Re: Disabling dead gateway detection during Ignite image recovery

I think it is not allowed to restore
if your Ignite server is on another subnet as the new system,
can you change one system so you can do the restore over one subnet?


see alsow:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1131630
Tim Nelson
Honored Contributor

Re: Disabling dead gateway detection during Ignite image recovery

Peter,

Is you assumption of the dead_gateway_detect issue based on that you are sure that your router will not respond to ICMP ? I would also guess that you have disabled the gateway_detect on every other server using this default router.

I only ask as you may not find a way to set this during ignite boot and wanted to ensure you were barking up the correct tree.

Other options if the above is true.
1) set the router to allow icmp
2) create a boot tape

I typically only ran into the gateway_probe issue when configuring a system on a DMZ, which typicall FW rules will not allow ICMP.

Sometimes security inhibits abitlity :)

Re: Disabling dead gateway detection during Ignite image recovery

Tim,

I'm sorry, I should have supplied more info.

Yes, our gateways don't respond to ICMP requests, so disabling "dead gateway detection" is a necessity.

What I also failed to mention was that we now temporarily installed an Ignite server in the new system's subnet. Installation of the golden image went fine using this temporary server.

We already had attempted to use two other Ignite servers, but they all were in other subnets. Usage of those Ignite servers produced the same NFS problems.

Considdering all those facts, I'm pretty sure that "dead gateway detection" is the source of the problem.


Tim Nelson
Honored Contributor

Re: Disabling dead gateway detection during Ignite image recovery

The only place that I know of that effects the intial settings for an ignite boot is the settings defined / modified via instl_adm

You may be able to put the ndd command in there ( see the man page for how ). It is worth a shot.

Patrick Preuss
Trusted Contributor

Re: Disabling dead gateway detection during Ignite image recovery

Hi Peter,
is it a kind of Policy why your Default Gatewas / Routers don't answer to icmp or do they answer on non Standby Addresses?

Regards Patrick
Goodbye Douglas! Whereever you are now, keep your towel and don't panic.

Re: Disabling dead gateway detection during Ignite image recovery

Tim,
I already explored the man pages of instl_adm.

Patrick,
Yes, it is a security policy overhere why we don't let our gateways respond to ICMP requests.

Grtz,

Peter
yulianto piyut
Valued Contributor

Re: Disabling dead gateway detection during Ignite image recovery

hi peter,

have you try to use boot helper system? if your ignite server in another subnet of your new server that will be you install, you should use boot helper and make sure that the version of ignite software have the same version with ignite server. point the installation to ignite server (instl_adm -t ingite_server_ip), Specify the temporary ip address at boot helper that client can use to boot. Edit etc/opt/ignite/instl_boottab.

-yut-

Re: Disabling dead gateway detection during Ignite image recovery

Hi Bantul,

Booting is not the problem.
It's just that we loose the NFS connection some time after we've booted.

Grtz,

Peter
IT_2007
Honored Contributor

Re: Disabling dead gateway detection during Ignite image recovery

Ignite server won't work under different subnets unless you open ICMP ports. This is clearly defined in Ignite doc.

You better to have Ignite server on same subnet and easy to recover/re-install client.