Ignite-UX

Force an Ignite-UX Client's LAN connection to Full 100-FDX, NoNegotiate

 
SOLVED
Go to solution
Alzhy
Honored Contributor

Force an Ignite-UX Client's LAN connection to Full 100-FDX, NoNegotiate

Is this at all possible?
My first Ignition was fine.. on a re-Ignitiion of same server, it is now running very slow.. Is there a way to force the client's LAN card to certain properties -- ie. 100FDX,manual?
Hakuna Matata.
3 REPLIES 3
Steven E. Protter
Exalted Contributor
Solution

Re: Force an Ignite-UX Client's LAN connection to Full 100-FDX, NoNegotiate

absolutely possible

and quite easy.

instl_adm -d > ignite.file

Edit the file

It should look like this:
# NOTE: Manual additions between the lines containing "instl_adm defaults"
# and "end instl_adm defaults" will not be preserved.
server="10.1.11.60"
netmask[]="255.255.0.0"
init _hp_lanadmin_args="-X 100FD"
_hp_nfs_mount_opts="-odebug"
# end instl_adm defaults.


Its the init _hp_lanadmin_args you want to get right. Those are the ones you want. Make sure the network switch is also set to 100 BaseT Full Duplex explicit.

now

instl_adm -f ignite.file

now instl_adm -d

You should see the figures you want.

Done.

Not hard at all.

SEP


Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Alzhy
Honored Contributor

Re: Force an Ignite-UX Client's LAN connection to Full 100-FDX, NoNegotiate

Thanks Steve..

I'm new with HP-UX and Ignite for that matter.. so far all I have done is by the book and have been able to setup an Ignite Server with either the core HP-UX11i or a Golden Image as the available installable OS during ignitions.

Thanks for the lead... I did actually find similar posts...

Hakuna Matata.
rick jones
Honored Contributor

Re: Force an Ignite-UX Client's LAN connection to Full 100-FDX, NoNegotiate

Do make sure that there is actually a duplex mismatch before you start hardcoding things. Look at the lanadmin -g mibstats output and make sure it said that it was auto in the interface description, and then that there are either FCS errors if it is in full-duplex, or late collisions if it is in half-duplex. And then make sure that the other side of the link does not match the duplex setting on the host.
there is no rest for the wicked yet the virtuous have no pillows