Ignite-UX

Ignite C.7.11.444 on 11.23 & 11.31

 
Sean McConkey_5
Advisor

Ignite C.7.11.444 on 11.23 & 11.31

I've built a new ignite server on a RP7400 running 11.23.

I removed the Ignite that came with the release and installed C.7.11.444. with support for 11.11 11.23 & 11.31

So far all I've done is create one depot using the 2 Install DVD's for 11.31.

# /opt/ignite/bin/make_config -s /var/opt/ignite/depots/Rel_B.11.31/core -c /var/opt/ignite/data/Rel_B.11.31/core_cfg

Then created the configs

opt/ignite/bin/manage_index -a -f /var/opt/ignite/data/Rel_B.11.31/core_cfg -c "B.11.31"

Updated the index

/opt/ignite/bin/manage_index -e -c "B.11.31"

Then I've updated /etc/bootptab for some Itanium boxes and edited /etc/dhcptab.

ignite-defaults:\
ht=ethernet:\
hn:\
bf=/opt/ignite/boot/nbp.efi:\
bs=61
System-IPF:\
tc=ignite-defaults:\
ha=00d009000000:\
ip=172.17.3.250:\
sm=255.255.0.0:\
gw=172.17.3.250:\
ds=172.17.3.250

hp60:\
tc=ignite-defaults:\
ha=00110A420B94:\
ip=172.17.30.60:
hp61:\
tc=ignite-defaults:\
ha=000E7FEDD256:\
ip=172.17.30.61:
hp69:\
tc=ignite-defaults:\
ha=001A4B066B76:\
ip=172.17.30.69:

dhcp_device_group:\
class-name=HP_IGNITE_UX_0:\
class-id="Ignite-UX_zoidberg":\
addr-pool-start-address=172.17.3.200:\
addr-pool-last-address=172.17.3.249:\
lease-time=7200:\
lease-policy=accept-new-clients:\
allow-bootp-clients=FALSE:\
hn:\
gw=172.17.3.250:\
subnet-mask=255.255.0.0

Checked Ignite using instl_adm

is_net_info_temporary=true
dhcp_class_id="Ignite-UX_zoidberg -G"
# instl_adm defaults:
# NOTE: Manual additions between the lines containing "instl_adm defaults"
# and "end instl_adm defaults" will not be preserved.
server="172.17.3.250"
netmask[]="255.255.0.0"
dhcp_class_id[]="Ignite-UX_zoidberg -G"
route_gateway[0]="172.17.3.250"
route_destination[0]="default"
# end instl_adm defaults.

Also added a dbprofile on the Itanium boxes.

So all is looking good as far as I can tell, however when I do an ignite boot on either an Itanium or a PA box both get stuck in the same place. It maybe that I'm missing the obvious but I've checked everything I can think of.

Below is output from the Itanium

Shell> lanboot select -dn ignite
01 Acpi(HWP0002,PNP0A03,100)/Pci(2|0)/Mac(001A4B066B76)
02 Acpi(HWP0002,PNP0A03,100)/Pci(2|1)/Mac(001A4B066B77)
03 Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Pci(6|0)/Mac(001560DEC814)
04 Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Pci(6|1)/Mac(001560DEC815)
05 Acpi(HWP0002,PNP0A03,300)/Pci(1|0)/Pci(6|0)/Mac(0014C29CA73C)
06 Acpi(HWP0002,PNP0A03,600)/Pci(1|0)/Pci(6|0)/Mac(00110A42DEC0)
07 Acpi(HWP0002,PNP0A03,600)/Pci(1|0)/Pci(6|1)/Mac(00110A42DEC1)
08 Acpi(HWP0002,PNP0A03,700)/Pci(1|0)/Pci(6|0)/Mac(0014C29C97A5)
Select Desired LAN: 01
Selected Acpi(HWP0002,PNP0A03,100)/Pci(2|0)/Mac(001A4B066B76)


Client MAC Address: 00 1A 4B 06 6B 76
Client IP Address: 172.17.30.69
Subnet Mask: 255.255.0.0
BOOTP Server IP Address: 172.17.3.250
DHCP Server IP Address: 0.0.0.0
Boot file name: /opt/ignite/boot/nbp.efi

Retrieving File Size.
Retrieving File (TFTP).
@(#) HP-UX IA64 Network Bootstrap Program Revision 1.1
Downloading HPUX bootloader
Starting HPUX bootloader
Obtaining size of fpswa.efi (328192 bytes)
Downloading file fpswa.efi (328192 bytes)

(C) Copyright 1999-2009 Hewlett-Packard Development Company, L.P.
All rights reserved

HP-UX Boot Loader for IPF -- Revision 2.039

Booting from Lan
Obtaining size of AUTO (224 bytes)
Downloading file AUTO (224 bytes)
Obtaining size of AUTO (224 bytes)
Downloading file AUTO (224 bytes)



Obtaining size of AUTO (224 bytes)
Downloading file AUTO (224 bytes)
1. target OS is B.11.23 IA
2. target OS is B.11.31 IA
3. Exit Boot Loader

Choose an operating system to install that your hardware supports:2

Obtaining size of AUTO (224 bytes)
Downloading file AUTO (224 bytes)
Obtaining size of Rel_B.11.31/IINSTALL (55690560 bytes)
Downloading file Rel_B.11.31/IINSTALL (55690560 bytes)
> System Memory = 32737 MB
loading section 0
.............................................................................................................. (complete)
loading section 1
.................... (complete)
Error: read only -1 bytes of 2496 of ELF section table
Could not get section table of ELF object
Error loading symbol table
Obtaining size of Rel_B.11.31/IINSTALLFS (61341696 bytes)
Downloading file Rel_B.11.31/IINSTALLFS (61341696 bytes)
loading ram disk file (Rel_B.11.31/IINSTALLFS).
.....................................................................................................................
(complete)
Launching Rel_B.11.31/IINSTALL
SIZE: Text:56051K + Data:10003K + BSS:29725K = Total:95780K

Here is the PA output

Main Menu: Enter command or menu > bo lan install
Interact with IPL (Y, N, or Cancel)?> n

Booting...
Boot IO Dependent Code (IODC) revision 4


HARD Booted.

ISL Revision A.00.44 Mar 12, 2003

ISL booting hpux KernelPrompt "Choose an operating system to install that your hardware supports:" 120 1



1. target OS is B.11.11
2. target OS is B.11.23 PA
3. target OS is B.11.31 PA
4. Exit

Choose an operating system to install that your hardware supports:3


Boot
: lan(0/1/2/0;0)/boot/Rel_B.11.31/WINSTALL
23838720 + 5535080 + 8050968 start 0x24a4e8

As you can see they both get to the same point and hang there. I know there is a ELF error showing in the Itanium but not sure of this is related.

Any help would be appreciated. TIA.

-
5 REPLIES 5
Torsten.
Acclaimed Contributor

Re: Ignite C.7.11.444 on 11.23 & 11.31

You are trying to install 11.31 on this RP7400?

Forget it, it doesn't work.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Alex Glennie
Honored Contributor

Re: Ignite C.7.11.444 on 11.23 & 11.31

for future reference ..

I'd start trouble-shooting similar issues (supported) by running a bootquery on the ignite server : response should be fairly instant.
Torsten.
Acclaimed Contributor

Re: Ignite C.7.11.444 on 11.23 & 11.31

In other words: 11.31 is not supported on this server; in this case "not supported" means "not working".

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Sean McConkey_5
Advisor

Re: Ignite C.7.11.444 on 11.23 & 11.31

No sorry if that was mis-leading. The RP7400 is running 11.23 and Ignite C.7.11.444 I've then created a 11.31 depot.

This should work as I'm trying to Ignite Itanium boxes that DO support 11.31.
-
Shane Seymour
Frequent Advisor

Re: Ignite C.7.11.444 on 11.23 & 11.31

Remove the -r blksize option from tftpd in /etc/inetd.conf (then run inetd -c and then kill any tftpd daemons still running) if you've got it set.

If that changes the error look at the switches connecting the booting system to the Ignite server and make sure no switches will drop IP fragments that have the DF bit set (e.g. "no hardware ip verify fragment" on cisco catalyst switches).

As a last resort if the iLO/OA suppors vMedia created a minimal boot image - boot from that and then switch to the network.