Ignite-UX

Ignite-UX client not getting DHCP address

 
Paulo A G Fessel
Trusted Contributor

Ignite-UX client not getting DHCP address

I've installed Ignite-UX software B3.5.89 and I'm able to install system whenever I supply a hostname and an IP address. Problem is that I'm not able to install system with addresses being provided by a DHCP server.

I've used both HP-UX's DHCP server and now I'm using Red Hat's. In RH's DHCP server I see that the server is getting the request for an IP address and sending the answer; OTOH, A500 seems not to get the IP address and keeps asking for the host information.

HP-UX's installation screen doesn't say too much about this; the only thing it says is that DHCP client ended with code 5.

Here's the log at the DHCP server:

Listening on LPF/eth1/00:d0:b7:e7:d8:25/172.30.10.112
Sending on LPF/eth1/00:d0:b7:e7:d8:25/172.30.10.112
Listening on LPF/eth0/00:d0:b7:e3:e6:d5/172.16.3.32
Sending on LPF/eth0/00:d0:b7:e3:e6:d5/172.16.3.32
Sending on Socket/fallback/fallback-net
DHCPDISCOVER from 00:30:6e:06:65:cc via eth0
DHCPOFFER on 172.16.3.54 to 00:30:6e:06:65:cc via eth0
DHCPDISCOVER from 00:30:6e:06:65:cc via eth0
DHCPOFFER on 172.16.3.54 to 00:30:6e:06:65:cc via eth0
DHCPDISCOVER from 00:30:6e:06:65:cc via eth0
DHCPOFFER on 172.16.3.54 to 00:30:6e:06:65:cc via eth0
DHCPDISCOVER from 00:30:6e:06:65:cc via eth0
DHCPOFFER on 172.16.3.54 to 00:30:6e:06:65:cc via eth0
DHCPDISCOVER from 00:30:6e:06:65:cc via eth0
DHCPOFFER on 172.16.3.54 to 00:30:6e:06:65:cc via eth0
DHCPDISCOVER from 00:30:6e:06:65:cc via eth0
DHCPOFFER on 172.16.3.54 to 00:30:6e:06:65:cc via eth0

And the A500 doesn't get any IP address.

Any ideas?

TIA,
Paulo Fessel
L'employé propose, le boss dispose.
2 REPLIES 2
Uday_S_Ankolekar
Honored Contributor

Re: Ignite-UX client not getting DHCP address

Paulo A G Fessel
Trusted Contributor

Re: Ignite-UX client not getting DHCP address

Hello folks.

Probably I haven't made myself clear.

I'm able to boot HP-UX in the Ignite-UX client. My problem was that I wasn't able to get an IP address for installation after I've got into HP-UX's installation prompt.

Anyway, I've changed the following parameter for DHCP server:

[X] Automatic Allocation to Bootp Clients

This option wasn't enabled and by doing so the Ignite-UX client is able to get a DHCP address - but only from interactive installation screen. If I use in INSTALLFS the parameters

control_from_server=true
run_ui=false

the client system still gets no IP address. I only get an IP address if I run the interactive installation.

Any thoughts?

Paulo Fessel
L'employé propose, le boss dispose.