Ignite UX

 
SOLVED
Go to solution
maggie Coffey
Occasional Contributor

Ignite UX

Has any one seen these errros when setting up an Ignite server

./make_net_recovery -s exeter
* Creating NFS mount directories for configuration files.
ERROR: Could not open log file. Logging will be displayed to stdout

======= 04/23/01 15:45:51 EDT Started ./make_net_recovery. (Mon Apr 23
15:45:51 EDT 2001)
@(#) Ignite-UX Revision A.3.2.45
@(#) net_recovery (opt) $Revision: 10.515 $

* Testing pax for needed patch
* Passed pax tests.
ERROR: copy_file: Cannot open "/var/opt/ignite/recovery/client_mnt/0x00108335
4FB1/recovery/latest/archive_content": Permission denied (errno = 13)
NOTE: Detected entries in the defaults file at
/var/opt/ignite/recovery/client_mnt/0x001083354FB1/recovery/defaults.

* Checking Versions of Recovery Tools
WARNING: Could not open default log file: /var/opt/ignite/recovery/client_mnt/0
x001083354FB1/recovery/2001-04-23,15:45/recovery.log: Permission
denied (errno = 13)
ERROR: Specified file '/var/opt/ignite/recovery/client_mnt/0x001083354FB1/rec
overy/latest/archive_content' does not exist: Permission denied (errno
= 13)
ERROR: The list_expander command failed. This could be due to a problem with
the file: "/var/opt/ignite/recovery/client_mnt/0x001083354FB1/recovery
/latest/archive_content" - see messages above.

======= 04/23/01 15:45:54 EDT make_net_recovery completed unsuccessfully
7 REPLIES 7
Bill McNAMARA_1
Honored Contributor

Re: Ignite UX

you want to make sure the file exists, is owned by bin:bin and want created with a mkdir -p option.

You also need to make sure the /etc/exports allows the server in question to read....

Later,
Bill
It works for me (tm)
maggie Coffey
Occasional Contributor

Re: Ignite UX

Ignite-us was installed from a download from HP's web site. It was installed per the README and install instructions from docs.hp.com

The make_net_recovery is the program that is supposed to be creating these files and directories. They are not being created with bin as the owner. But as follows
drwxrwxrwx 3 4294967294 nogroup 1024 Apr 23 14:57 0x001083957B45.

There must be something that I am missing here. I am doing all of this as root and the acl's are coming up as above.

/etc/exports is set wide open
for read write and execute on the /var and /opt directories.

There seems to me that way the directories are structured is flawed.
I had to create links in a couple spots to get parts of this to work.

Any suggestions?

Thanks
Maggie Coffey

CHRIS ANORUO
Honored Contributor

Re: Ignite UX

Have you checked you /etc/exports file. The user group of nobody is coming from an NFS related file.
When We Seek To Discover The Best In Others, We Somehow Bring Out The Best In Ourselves.
maggie Coffey
Occasional Contributor

Re: Ignite UX

Here is the setting from the
/etc/exports file per the instructions.

/var -anon=2,access=exeter


marc seguin
Regular Advisor
Solution

Re: Ignite UX

command from client : ./make_net_recovery -s exeter
So "exeter" is your Ignite server, isn't it ?

So on exeter, the /etc/exports file should contain :
/var -anon-2,access=
with different from exeter !!!!!!
Bill McNAMARA_1
Honored Contributor

Re: Ignite UX

I think Marks got it,
Your ignite server is exeter, which would explain the file not found problem.

you should issue a chown -R bin:bin on the client directory in any case.... make sure that the pax patch is installed or you may have trouble with your ACLs...

Later,
Bill
It works for me (tm)
maggie Coffey
Occasional Contributor

Re: Ignite UX

That was it Mark

Thanks to All