Ignite error

 
SOLVED
Go to solution
John Ferrara
Frequent Advisor

Ignite error

I receive the following error when creating an Ignite tape:

* Creating Control Configuration.
* Creating Archive File List
ERROR: list_expander returned an error.
ERROR: Failed to get the archive size and the list of files which will be in
archive.

======= 01/21/03 15:40:39 CST make_tape_recovery completed unsuccessfully


I'm on a K210 10.20 A Ignite v.A.3.7.95

John
It was working fine when I left....what did you do?
8 REPLIES 8
Pramod_4
Trusted Contributor

Re: Ignite error

Check Whether you have any files in '/" directory with control charactors (Invisible) in it.


Pramod
Manju Kampli
Trusted Contributor

Re: Ignite error

Do you have the patch PHSS_26498 installed after PHCO_26453.. this patch has warnings and will create circular symbolic links in the /usr/lib/nls/msg/zh_TW.big5 message catalog directory. The presence of these circular links can cause problems with backup programs

Please follow the instructions in the patch warings to fix it and try the ignite backup.


- To address this situation please follow the following
procedure:
1. Confirm both PHSS_26498 and PHCO_26453 are installed:
swlist -l patch PHSS_26498 PHCO_26453
if both patches are not reported as installed, then no
action is required at this time. However, action will
be required if both patches are installed in the future.
If both patches are reported as installed, continue with
step #2.
2. Get into the proper directory:
cd /usr/lib/nls/msg/zh_TW.big5
3. Confirm the presence of the symbolic links:
find . -type l | xargs ls -l
If this several lines similar to the following are
displayed, continue with step #4. Otherwise, skip to
step #6.
lrwxr-xr-x 1 root sys 36 Aug 30 09:07 ./hpterm.cat ->
/usr/lib/nls/msg/zh_TW.big5/hpterm.cat
4. Remove the symbolic links:
find . -type l | xargs rm
5. Restore the backup copies from the save area for
PHSS_26498:
cp -p /var/adm/sw/save/PHSS_26498/X11-TCH-B-MSG/usr/lib/ nls/msg/zh_HK.hkbig5/* .
6. Correct the IPD (Installed Product Database) so that
swverify(1M) does not report errors for fileset
X11.X11-TCH-B-MSG and patch fileset
PHSS_26498.X11-TCH-B-MSG:
1. Create the swmodify "Path" file (e.g.
/tmp/fileselections) containing:
/usr/lib/nls/msg/zh_HK.hkbig5/hpterm.cat
/usr/lib/nls/msg/zh_HK.hkbig5/recserv.cat
/usr/lib/nls/msg/zh_HK.hkbig5/resize.cat
/usr/lib/nls/msg/zh_HK.hkbig5/xclock.cat
/usr/lib/nls/msg/zh_HK.hkbig5/xinit.cat
/usr/lib/nls/msg/zh_HK.hkbig5/xload.cat
/usr/lib/nls/msg/zh_HK.hkbig5/xpr.cat
/usr/lib/nls/msg/zh_HK.hkbig5/xrdb.cat
/usr/lib/nls/msg/zh_HK.hkbig5/xwd.cat
2. Update the IPD for both filesets. Observe that a
swmodify(1M) command must be issued for each of the
filesets to be modified:
swmodify -v -P /tmp/fileselections X11.X11-TCH-B-MSG
swmodify -v -P /tmp/fileselections PHSS_26498.X11-TCH-B-MSG


Hope the above helps,
Manju
Never stop "LEARNING"
T G Manikandan
Honored Contributor
Solution

Re: Ignite error

I am not sure what command options you are using for creating the tape.

Are you using proper -x options.

Revert with the command.

Also post the output of

var/opt/ignite/recovery/latest/recovery.log
John Ferrara
Frequent Advisor

Re: Ignite error

Pramod - No there were no invisible characters in "/"

Manju - No those patches are not installed

T G - Upon review of the ignite log file I discovered that there is an additional entry at the end that was not displayed on the screen:
WARNING:'/usr/lib/X11/app-defaults/Autocal.DA1' is part of a circular link.
ERROR: Circular link error encountered. Aborting.

I don't know why these lines were not displayed on screen during the session. Thanks for the help.

John
It was working fine when I left....what did you do?
John Ferrara
Frequent Advisor

Re: Ignite error

I do have another problem w/ Ignite on a different server:

======= 01/16/03 17:53:29 GMT Started ./make_tape_recovery. (Thu Jan 16
17:53:29 GMT 2003)
@(#) Ignite-UX Revision A.3.7.95
@(#) net_recovery (opt) $Revision: 10.575.1.1 $


* Testing pax for needed patch
* Passed pax tests.
* Checking Versions of Ignite-UX filesets
* Creating System Configuration.
* /opt/ignite/bin/save_config -f
/var/opt/ignite/recovery/2003-01-16,17:53/system_cfg vg00
save_config: error - vg00 not in the volume/disk group
ERROR: /opt/ignite/bin/save_config failed


======= 01/16/03 17:53:51 GMT make_tape_recovery completed unsuccessfully

Any thoughts???

John
It was working fine when I left....what did you do?
John Dvorchak
Honored Contributor

Re: Ignite error

I have seen the second problem you note a couple of years ago. As I remember it you have a corrupted /etc/mnttab file. Save it to a backup file like mv /etc/mnttab /etc/mnttab.sav and issue the mount -a command. This will rebuild it for you. Once you confirm that all is ok with the mnttab file you can remove the saved version.

You should probably do a search on the ITRC forums for mnttab to see if my memory has failed or not.
If it has wheels or a skirt, you can't afford it.
John Ferrara
Frequent Advisor

Re: Ignite error

John,

I tried your suggestion foe mnttab. It had no effect.

John
It was working fine when I left....what did you do?
John Ferrara
Frequent Advisor

Re: Ignite error

I found another message that tried lvlnboot -R /dev/vg00. However, this did not work either.

John
It was working fine when I left....what did you do?