BladeSystem Forums have moved here
To make BladeSystem information easier to find, we have moved the BladeSystem forums here, to Servers and Operating Systems.
Showing results for 
Search instead for 
Do you mean 

Ignite mounting issue.

Super Advisor

Ignite mounting issue.

Hi Experts,

 

We have a ignite setup & in ignite server we have FS exported to all ignite clients in exports tab.

 

Now we need to restrict it to mount on particluar host only.

 

Ignite server :

 

showmount -e

/ignite/arch01/gedkep01                  (everyone)
/ignite/arch01/uxd15                     uxd15,uxd15
/ignite/arch01/uxp24                     (everyone)

 

 # ls -ld /ignite/arch01/uxd15
drwxr-xr-x   2 bin        bin             96 Jul 19 11:25 /ignite/arch01/uxd15

 

Ignite client :

 

showmount -e

no exported file systems for uxd15

 

uxd15:/ # showmount -a
uxd15:/ # mkdir /test-ignite
uxd15:/ # mount 41.84.6.10:/ignite/arch01/uxd15  /test-ignite
Permission denied
uxd15:/ #

previously it will show applied for (everyone) == but now we need to restrict as per hostname wise,

so we added only uxd15 servers hostname in exports file in ignite server & try to mount it over the ingintie client but it says permission denied.

 

/Fizan

7 REPLIES
Acclaimed Contributor

Re: Ignite mounting issue.

What HP-UX version are you on?  What does our exports file look like?

You may need the FQDN for your exports.

Honored Contributor

Re: Ignite mounting issue.

Also check uxd15 has the corerct IP set on ignite.
Valued Contributor

Re: Ignite mounting issue.

On the ignite server create and share the archive directory for the client you want to backup


# mkdir -p /var/opt/ignite/recovery/archives/host1
# chown bin:bin /var/opt/ignite/recovery/archives/hostname
# vi /etc/exports
Add the following entries
/var/opt/ignite/clients -anon=2
/var/opt/ignite/recovery/archives/host1 -anon=2,access=host1

 

# exportfs -av

 

For HP-UX 11.31 only

# vi /etc/dfs/dfstab
share -F nfs -o ro /opt/ignite/data
share -F nfs -o ro /var/opt/ignite/data
share -F nfs -o anon=2 /var/opt/ignite/clients
share -F nfs -o anon=2 /var/opt/ignite/scripts

share -F nfs -o sec=sys,anon=2,rw=host1 /var/opt/ignite/recovery/archives/host1

 

Add Ignite clinet entry to /etc/hosts in the Ignite server
# vi /etc/hosts
10.x.x.x host1

 

Add Ignite server entry to /etc/hosts in the client
10.x.x.x igniteserver

 

Excute the following command from Ignite Client for taking network backup

# /opt/ignite/bin/make_net_recovery -Av -s igniteserver

Valued Contributor

Re: Ignite mounting issue.

sorry for wrong directory name in my above post it should be as follows

 

# chown bin:bin /var/opt/ignite/recovery/archives/host1

Super Advisor

Re: Ignite mounting issue.

Hi Arunabh,

 

The way as recommended dosent work, i put the entry in exports file in ignite server & tried not able to mount says

permission denied, but if i put the (everyone) option its working well.

Valued Contributor

Re: Ignite mounting issue.

Can you please share /etc/exports file.

 

# cat /etc/exports

Highlighted
Acclaimed Contributor

Re: Ignite mounting issue.

>Can you please share /etc/exports file.

 

And also /etc/xtab (/etc/dfs/sharetab on 11.31) for the current exported filesystems.