Ignite recovery with VLAN

 

Ignite recovery with VLAN

Hello to all.
Has someone experience in recovering a client via network with vlans configured in the server.

I am trying to do that, but I get tftp error, although the server has the tftp service well configured at /etc/inetd.conf.

Sorry for my faulty english.
7 REPLIES 7
Patrick Wallek
Honored Contributor

Re: Ignite recovery with VLAN

If your Ignite Server and the client you are trying to recover are not on the same subnet, then you will have problems.

In order for Ignite to work across subnets, you need a boot help on the subnet that the system you are trying to recover is on.

Have a look at the "Using a boot helper system" in the following manual:
http://docs.hp.com/hpux/onlinedocs/B2355-90767/B2355-90767.html

Re: Ignite recovery with VLAN

Thanks.
I already knew that. The servers are in the same segment, but the problem appeared after configuring VLANs.

I also have the added problem that the server I am trying to recover is a virtual partition. I haven't found any documentation about using a boot-helper with vpars.

Brian M Rawlings
Honored Contributor

Re: Ignite recovery with VLAN

Hi. VLANs configured in the server? Or in the network between the server and the ignite host?

You may be hitting a problem with protocols that don't pass beyond their own subnet, because they are broadcast-based, and broadcasts aren't routed. The bootp protocol comes to mind, I'm not sure it is used by HP hosts trying to boot over the network.

I recall that, with Solaris, there had to be a jumpstart server on every subnet where clients might need to use jumpstart. Ignite may have this issue, or not, maybe somebody knows for sure.

Regards, --bmr
We must indeed all hang together, or, most assuredly, we shall all hang separately. (Benjamin Franklin)
Brian M Rawlings
Honored Contributor

Re: Ignite recovery with VLAN

Thanks, Patrick. I didn't see your post when I replied earlier. --bmr
We must indeed all hang together, or, most assuredly, we shall all hang separately. (Benjamin Franklin)

Re: Ignite recovery with VLAN

Brian, you are right. Vlan is configured on the network.
I didn't explain very well becasue I am novice about vlans.
I think bootps is only necessary if using DHCP.
In fact I have tried to recover with and without bootps configured, but unsuccessfully.

Re: Ignite recovery with VLAN

Is there any documentation available about recovering vpars with a boot-helper?

Thanks in advance
robert_86
New Member

Re: Ignite recovery with VLAN

Hi Xavier,

I am curious about the same topic. From your description you started having issues after configuring vlans. Are you using port based vlans or ip-based?

If it is IP-based I would assume that the tagging will be lost during an ignite boot. You would probably have to setup the default port vlan to be the same as the ignite/boot helper server (?).

Has anyone seen a whitepaper or other doc on vlans and ignite?

thanks,
Rob