Ignite-UX

Re: Install hpux through Ignite UX fail

 
yokus
Advisor

Install hpux through Ignite UX fail

hi,all;
I am a newguy toward the ignite.
I want to install a HPUX host through the ignite.
BUT i try many times and fail,i put the log following.
I dont; know which point i should check to solve this problem.
can yours help me?
#cd /var/opt/ignite/clients/0x7A978007FCDF
# more install.log

======= 11/06/07 22:15:30 EST HP-UX Installation Initialization. (Tue Nov 06
22:15:30 EST 2007)
@(#)Ignite-UX Revision C.7.2.94
@(#)ignite/launch (opt) $Revision: 10.615 $ $Date: 2007/03/02 21:27:54
$

* Configuring RAM filesystems...
* Scanning system for IO devices...
NOTE: Boot device is: 0/0/0/0
NOTE: Primary path not currently set to an existing disk device.

WARNING: The configuration information calls for a non-interactive
installation.

Press within 10 seconds to cancel batch-mode installation:
Really cancel non-interactive install and start the
user-interface? ([y]/n): *
Response was: y

* Setting keyboard language.
* Bringing up Network (lan0)
add net default: gateway 10.77.77.93
* NFS mounting clients directory.
* Using client directory: /var/opt/ignite/clients/0x7A978007FCDF
* Checking configuration for consistency...
* Running pre_config_cmd: "loadfile setboot "
* Running pre_config_cmd: "loadfile -l /opt/ignite/data/rom.ia64.tgz
wget bootcntl "
* Running pre_config_cmd: "./bootcntl debug "
ISVRPORT Not Found - Using 3466
DEBUG: MAC Address: 0x7A978007FCDF
DEBUG: HTTP server: 10.77.77.3:3466
DEBUG: setboot ended with status=0
DEBUG: Boot info before request:
Primary boot path:
Alternate boot path: 0
Auto boot: On
Auto search: Off

Continue: No=reboot
Operation: UNINITIALIZED

DEBUG: req="http://10.77.77.3:3466/proc/roms/ignite/resolve?macAddr=0x7A978007FCDF&priBoot
=&altBoot=0&autoBoot=1&autoSearch=0"
DEBUG: wget command line is http://10.77.77.3:3466/proc/roms/ignite/resolve?macAddr=0x7A97
8007FCDF&priBoot=&altBoot=0&autoBoot=1&autoSearch=0
DEBUG: response="install=0
"
DEBUG: bootinfocb; k="install", v="0"
DEBUG: Boot info after request:
Primary boot path:
Alternate boot path: 0
Auto boot: On
Auto search: Off

Continue: No=reboot
Operation: BOOT DISK

setboot: "" is not a proper bootpath
DEBUG: setboot ended with status=256
bootcntl: going to reboot from disk ...
bootcntl: going to reboot from disk...
Shutdown at 22:17 (in 0 minutes) reboot: redirecting error messages to /dev/console

^G^GSystem shutdown time has arrived^G^G
3 REPLIES 3
whiteknight
Honored Contributor

Re: Install hpux through Ignite UX fail

Yokus,

Your bootpath is not set properly. You need to check

Example:-
# setboot
Primary bootpath : 0/2/0/0.8.0
Alternate bootpath : 0/0/2/0.1.0

Autoboot is ON (enabled)
Autosearch is OFF (disabled)

When an ioscan is run on the hardware path reported by setboot, no
output is generated:

# ioscan -fnkH 0/2/0/0.8.0

to set the bootpath
setboot -p

my 2 cents

WK
Problem never ends, you must know how to fix it
Sameer_Nirmal
Honored Contributor

Re: Install hpux through Ignite UX fail

Did you get the user interface when you type "y" at "Really cancel non-interactive install and start the
user-interface? ([y]/n): " ?

If yes, did you select the root disk in there?

The ignite is failing because the root disk is not selected.
Al Miller_1
Valued Contributor

Re: Install hpux through Ignite UX fail

This logfile output:

* Running pre_config_cmd: "loadfile setboot "
* Running pre_config_cmd: "loadfile -l /opt/ignite/data/rom.ia64.tgz
wget bootcntl "
* Running pre_config_cmd: "./bootcntl debug "
ISVRPORT Not Found - Using 3466
DEBUG: MAC Address: 0x7A978007FCDF
DEBUG: HTTP server: 10.77.77.3:3466
DEBUG: setboot ended with status=0

and much of what follows indicates that your install configuration has been modified to load the setboot command and run a program called bootcntl. This is done via setting the "pre_config_cmd" in your config, and is not something that is done by default by Ignite-UX. What does this bootcntl command do? It appears that it may be setting the default boot path incorrectly.