Ignite-UX

Kernel tunables "timezone" and "uname_eoverflow" being ignored

 
jack challen_1
Advisor

Kernel tunables "timezone" and "uname_eoverflow" being ignored

I'm trying to automate as much of our 11.31 HP-UX builds as possible, including kernel tunables. I've got some settings in a .cfg file, and while most are propagating through, the settings "timezone" and "uname_eoverflow" aren't. Either they're being ignored or they're getting overwritten. Here's an excerpt of the .cfg file:

===
mod_kernel += "tunable shmseg 512"
mod_kernel += "tunable timezone 0"
mod_kernel += "tunable uname_eoverflow 0"
mod_kernel += "tunable vps_ceiling 64"
===

All the other values in that file are taken, but when I check with kctune, timezone and uname_eoverflow are incorrect (420 and 1 respectively).

Any ideas why?

I've tried setting "timezone=GMT0BST" in my config.local, and applying 'env_vars += "TZ=GMT0BST"' in my installfs, but to no avail.
1 REPLY 1
jack challen_1
Advisor

Re: Kernel tunables "timezone" and "uname_eoverflow" being ignored

After a bit of playing around, I tried adding

===
set_kernel += "tunable timezone 0"
set_kernel += "tunable uname_eoverflow 0"
===

I'm aware of the difference between the two options, but I can't quite work out why this is required for these two tunables.

Oh well.