Re: LAN boot rx2660

 
Tim Nelson
Honored Contributor

Re: LAN boot rx2660

The timeout messages are cool.. I get them all the time during loads.

I am not sure if this is still an issue in the current version. But..

I had to move my ignite server to an Itanium host due to some tftp payload/transfer size issue on PA-RISC.

I do know for sure that once I moved to IA I have no issues Igniting my mixed environment.
11.11, 11.23 (PA-IA), and 11.31

Dusty Mjoen
Advisor

Re: LAN boot rx2660

I wish I had another Itanium server to check the theory. Oh well, back to the drawing board. I certainly appreciate the help you all have given!
Tim Nelson
Honored Contributor

Re: LAN boot rx2660

Might be worth a call to HP. They were very helpful when I ran into this.

If not then you are back to the Ignite Admin Guide with the chapter labled "boot helpers"

Either a CD or another system that is on both nets.

Tim Nelson
Honored Contributor

Re: LAN boot rx2660

I found a reference similar to this issue. Talks about a current tftp patch for the PA-RISC. PHNE_32825 .. If you do not have this or newer it may fix your problem.

This also assumes you have all the other stuff configured correctly.

http://www.docs.hp.com/en/IUX/faq.html#1-16

section 1-17

1-17 Why is the network boot of my Itanium-based system slow?
A: To reduce the amount of time it takes to perform a network boot, you should use an Ignite-UX server that is running a tftp daemon (tftpd) that supports the "tsize" option.

When the firmware on an Itanium-based system is downloading a file (i.e. booting), it first attempts to determine the size (in bytes) of the file. If the tftp daemon (tftpd) on the server does not support the "tsize" option, the client downloads the file using the following steps:
Download the entire file (not storing the data), counting the bytes
Allocate a buffer which is the exact size of the file
Download the entire file (again) into the allocated buffer.
The B.11.11 patch that enables the "tsize" feature is PHNE_32825, which was posted on 20-Mar-2006.

NOTE: HPVM requires this patch if you are installing a virtual machine from an Ignite-UX server running B.11.11. Not having this patch installed on the server will cause the network boot to fail because of a firmware defect. No tftpd patch is required for B.11.23 onwards as the tftpd daemon supports the "tsize" option from first release.

Top
Steven E. Protter
Exalted Contributor

Re: LAN boot rx2660

Shalom,

PXE and Itanium have been known to interfere with each other.

I've been forced to do Ignite work on networks without PXE servers on them.

You may need to shut down or isolate PXE servers to get the Ignite stuff to work right.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
cobra_1
Occasional Contributor

Re: LAN boot rx2660

During Ignite installing of 11iv3/rx2620, I had same error message as:

Retrieving File Size..
PXE-E23: Client received TFTP error from server.
PXE-E98: Code: 1h File not found
Exit status code: Invalid Parameter

And I solved this problem by checking the tftp entry in
/etc/inetd.conf and /etc/passwd files.
The tftpd should know /opt/ignite path.

/etc/inetd.conf:
tftp dgram udp wait root /usr/lbin/tftpd tftpd\
-l\
/opt/ignite\
/var/opt/ignite

/etc/passwd:
tftp:*:106:105:Trivial FTP user:/home/tftp:/usr/bin/false

Hopefully it be helpful.
cobra
Dusty Mjoen
Advisor

Re: LAN boot rx2660

Thanks for everyones help. My problem was that the /opt/ignite/boot/nbp.efi file did not exist. A reinstall of Ignite fixed that problem.
Dusty Mjoen
Advisor

Re: LAN boot rx2660

See above post.