Ignite-UX

NFS mount failing during ignition

 
Lance McGrath
Occasional Advisor

NFS mount failing during ignition

All -

I'm attempting to build an ignite environment and have come across an error when mounting the exports from the Ignite server. I was able to mount the directories in question using the "/usr/sbin/mount" command. However, ignite uses a different mount with the -oro option. When I run the same command from an existing server, it also fails, making me think that there is something wrong with my exports. Here is the error message:

/sbin/fs/nfs/mount -oro 10.250.93.138:/var/opt/ignite/archives/Rel_B.11.00 /mnt/test
nfs mount: get_fh: 10.250.93.138:: RPC: Program not registered
nfs mount: get_fh: 10.250.93.138:: RPC: Program not registered
nfs mount: retry: retrying(1) for: /mnt/test after 5 seconds
nfs mount: retry: giving up on: /mnt/test


And the exports file from the server follows:

/var/opt/ignite/clients -anon=2
/var/opt/ignite/archives/Rel_B.11.00 -ro,anon=2
/ignite -ro,anon=2

If you could provide me any insight I'd appreciate it!

Thanks,
Lance
5 REPLIES 5
Scot Bean
Honored Contributor

Re: NFS mount failing during ignition

Is the NFS server running?

Try /sbin/init.d/nfs.server start
Lance McGrath
Occasional Advisor

Re: NFS mount failing during ignition

Yes. I was able to mount it from another machine using /usr/sbin/mount.

Thanks,
Lance
nick_202
Occasional Contributor

Re: NFS mount failing during ignition

Hi,

I had faced a simillar problem.
are the 2 machines on different network? is there a firewall between the 2 machines? you will have to ensure that all the nfs ports (2049, 111, and the rpc.statd and rpc.mountd ports) are allowed between the 2 machines. u can find out the portnumbers using the rpcinfo -p
once this is done try to manually mount (temporarily, just for testing) any FS form server onto the host in question and see if nfs mount is sucessful (u can unmount the fs now). then try running the command again
Lance McGrath
Occasional Advisor

Re: NFS mount failing during ignition

They are on different subnets; however, there is no firewall between them, simply a router. Unfortunately, I still haven't figured this out.
Todd McDaniel_1
Honored Contributor

Re: NFS mount failing during ignition

I have seen that error when the /usr/sbin/rpc.mountd isnt running...

Once I start it, everything is fine.

You may need to restart rpc daemons...
Unix, the other white meat.