NFS mount failure

 
SOLVED
Go to solution
Ryan Hurst
Frequent Advisor

NFS mount failure

I get an error when this command runs during a restore:
Note: Retrying: "/sbin/fs/nfs/mount -oro 150.1.10.90:/A1/swill /tmp.ign_configure/archive_nfs"
Permission denied

Where the 150...90 is my ignite server address, swill is the hostname of the client (and it's archive directory on the server). The A1 directory corresponds to a disk on a jamaica drive tower. I do not have this issue if the archive is stored on the internal disk. I made sure that the A1 directory and the swill directory both have full (777) permissions, there is an entry for the directory in the /etc/exports file and has been re-exported. I don't know what else to look at to make this thing happy.
14 REPLIES 14
Stefan Farrelly
Honored Contributor

Re: NFS mount failure

Check the permissions on the underlying A1 directory when it is unmounted. The permissions you see when it is mounted may NOT be the same as those when it is unmounted. It may be set to non-777 when you unmount it. If so then change it and mount it again.
Im from Palmerston North, New Zealand, but somehow ended up in London...
Ramkumar Devanathan
Honored Contributor

Re: NFS mount failure

hi,

check this -
# showmount -e 150.1.10.90

this should tell you if there is an exported share on 15..90 over which you have access rights.

- ramd.
HPE Software Rocks!
Ryan Hurst
Frequent Advisor

Re: NFS mount failure

Ramkumar:
I did that command. It showed /A1/swill, as well as some other archive dirs.

Stephan:
I didn't use mount, I configured the disks in SAM, and therefore they don't show up in mnttab and I can't umount them. Maybe I should undo them in SAM and use mount, since they are technically hotswappable/removeable?
Bill McNAMARA_1
Honored Contributor

Re: NFS mount failure

check you /etc/exports on your ignite server.

You need the -anon=2 option.

for the archive directories/directory

Later,
Bill
It works for me (tm)
Ryan Hurst
Frequent Advisor

Re: NFS mount failure

Bill:
Thanks, I did that already though.
Bill McNAMARA_1
Honored Contributor

Re: NFS mount failure

ps -ef | grep -i nfs

on the ignite server.
Make sure it's running.

--

$ cat /etc/exports
#
#
/A1 -anon=2

$ exportfs -av

--
in inetd.conf should have:
tftp dgram udp wait root /usr/lbin/tftpd tftpd /opt/ignite /var/opt/ignite
.
.
.
instl_boots dgram udp wait root /opt/ignite/lbin/instl_bootd instl_bootd
~
~

nfsstat for info on NFSd status.

Later,
Bill.


It works for me (tm)
Ryan Hurst
Frequent Advisor

Re: NFS mount failure

The output from ps -ef | grep -i nfs:

root 704 0 0 Apr 11 ? 0:00 nfskd
root 6807 6039 0 08:41:47 pts/ta 0:00 grep -i nfs
root 1540 1 0 Apr 11 ? 0:02 /usr/sbin/nfsd 4
root 1544 1540 0 Apr 11 ? 0:02 /usr/sbin/nfsd 4
root 1546 1540 0 Apr 11 ? 0:02 /usr/sbin/nfsd 4
root 1547 1540 0 Apr 11 ? 0:02 /usr/sbin/nfsd 4


cat /etc/exports shows this:

/var/opt/ignite/clients -anon=2
/var/opt/ignite/recovery/archives/jen -anon=2,access=jen
/var/opt/ignite/recovery/archives/igtest -anon=2,access=igtest
/storage/archives/jen -anon=2,access=jen
/A1/swill -anon=2,access=swill

These have all been exported using exportfs -av.
Does A1 also have to be entered in /etc/exports as well as the actual subdirectory used to store the archive?


The relevant lines from /etc/inetd.conf, exactly as they apear in that file (except the elipses):

tftp dgram udp wait root /usr/lbin/tftpd tftpd /opt/ignite /var/opt/ignite
...
...
...
instl_boots dgram udp wait root /opt/ignite/lbin/instl_bootd instl_bootd
Ryan Hurst
Frequent Advisor

Re: NFS mount failure

Sorry, that last part didn't come out right. The /opt/ignite\ and /va/opt/ignite show up on seperate lines below the tftp line. I'm resonably sure that this isn't a word wrap issue with vi, as I expanded the window to max width to make sure. For whatever reason when I ftp'd, copied, and pasted the lines onto my reply window they all got put on the same line.

Is thsi normal behavior, or could it be causing the problem?
Michael Steele_2
Honored Contributor

Re: NFS mount failure

Look for control chars:

cat /etc/inetd.conf | col -b > /tmp/file_inetd

Note the byte count and diff the two.
Support Fatherhood - Stop Family Law