Ignite-UX

WARNING: Target is a remote filesystem

 
Mark Robins
Occasional Advisor

WARNING: Target is a remote filesystem

Hi

Since upgrading to Ignite C.6.3.324 (on HP-UX 11.11) an existing Ignite job has changed from completing with a return code or 0 to a return code of 2. I believe the reason is the following warning message in the recovery.log:

WARNING: The target ('/oracle/utility/filename') is a remote filesystem. You may not be able to recover it if the remote server is down.

The actual mountpoint on looks like this:

bdf /oracle/utility
server:/oranfs/utility 10000 5000 5000 50% /oracle/utility

I know that /oracle/utility is an NFS directory, and have tried to exclude it (using -x /oracle/utility), but I still get the warning. I also tried -x /oranfs/utility but that then said "WARNING: File '/oracle/utility' in archive_content list not found"

Any ideas how I can suppress the warning to get a return code 0 ?
8 REPLIES 8
Pete Randall
Outstanding Contributor

Re: WARNING: Target is a remote filesystem

Mark,

The syntax to exclude is "-x exclude=file|dir". If you are using the syntax as you wrote it, it won't work.


Pete

Pete
Mark Robins
Occasional Advisor

Re: WARNING: Target is a remote filesystem

Sorry, the full command I am using is:

/opt/ignite/bin/make_tape_recovery -Iv -Ps -a /dev/dlt1n -t "IGNITE:server Fri Sep 29 10:19:46 BST 2006" -x inc_entire=vg00 -x exclude=/var/adm/crash -x exclude=/var/opt/perf/datafiles -x exclude=/tmp -x exclude=/data/ctrl -x exclude=/oracle/8.1.7 -x exclude=/oracle/8.1.7 .4 -x exclude=/oracle/10.2.0 -x exclude=/oracle/9.2 -x exclude=/batch -x exclude=/oracle/utility
IT_2007
Honored Contributor

Re: WARNING: Target is a remote filesystem

Include -A option in the command like

make_tape_recovery -A ..... and so on.
Mark Robins
Occasional Advisor

Re: WARNING: Target is a remote filesystem

Thanks, I have tried adding the -A option, the command is now:

/opt/ignite/bin/make_tape_recovery -A -Iv -Ps -a /dev/dlt1n -t "IGNITE:server Fri Sep 29 14:38:19 BST 2006" -x inc_entire=vg00 - exclude=/var/adm/crash -x exclude=/var/opt/perf/datafiles -x exclude=/tmp -x exclude=/data/ctrl -x exclude=/oracle/8.1.7 -x exclude=/oracle/8.1.7.4 -x exclude=/oracle/10.2.0 -x exclude=/oracle /9.2 -x exclude=/batch â x exclude=/oracle/utility

But I still get this error in stdout:

WARNING: list_expander returned a warning; please check the recovery.log file for details.

Then looking in recovery log:

/var/opt/ignite/recovery/2006-09-29,14:38 # more recovery.log

⠦⠦

* Creating Archive File List

WARNING: The target ('/oracle/utility/csv2xls') is a remote filesystem. You may not be able to recover it if the remote server is down.

WARNING: list_expander returned a warning; please check the recovery.log file for details.


We were on B.4.4.30 of Ignite before and didn't get this ?
IT_2007
Honored Contributor

Re: WARNING: Target is a remote filesystem

can you run list_expander manually and see if you see any errors or not.
Mark Robins
Occasional Advisor

Re: WARNING: Target is a remote filesystem

Unfortunatley I get the same error from list_expander...

wlux02 /opt/ignite/lbinpa # ./list_expander >/tmp/file
WARNING: The target '/oracle/utility/csv2xls') is a remote filesystem. You may not be able to recover it if the remote server is down.

wlux02 /opt/ignite/lbinpa # grep oracle\/utility /tmp/file

oracle/utility

wlux02 /opt/ignite/lbinpa #

So just the directory is listed, not any files within it.
Mark Robins
Occasional Advisor

Re: WARNING: Target is a remote filesystem

It's OK thanks. I appear to have resolved it. There was something strange about file /oracle/utility/csv2xls.

A "ls -b" showed there were no strange characters in the filename, but I moved it to /tmp and list_expander worked. Moved the file back and list expander failed again. I have now renamed the file csv2xls.old and list expander works.

Thanks for your time.
Mark Robins
Occasional Advisor

Re: WARNING: Target is a remote filesystem

Renamed the file called 'csv2xls', which although on an excluded (NFS) directory, seemed to be causing the problem.