Ignite-UX

failed to use "boot lan" on client to start install by ignite.

 
SOLVED
Go to solution
li_p327
Occasional Advisor

failed to use "boot lan" on client to start install by ignite.

I installed an ignite server, then changed its hostname name. Then I can not start install process by using "boot lan.x.x.x.x. install".
It seems that the ignite server still have info of original name. When I type "swacl -l root", it will display "WARNING: An attempt to get the network host entry for "ignite3" failed" (ignite3 is original name).
Does anyone met such problem. Thanks.
10 REPLIES 10
Torsten.
Acclaimed Contributor

Re: failed to use "boot lan" on client to start install by ignite.

How did you change the hostname? Did you use "set_parms"? If you try to resolve the name with "nslookup" - does this work?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
li_p327
Occasional Advisor

Re: failed to use "boot lan" on client to start install by ignite.

I modified name by edit config file before. I just use set_parms to set hostname, and swacl show correct messages. Then I reboot the ignite server, then test boot lan on the client, still failed with follow msg:

Main Menu: Enter command or menu > bo lan.x.x.x.x install
Interact with IPL (Y, N, or Cancel)?> n

Booting...
Failed to initialize with ENTRY_INIT Status = -7


0 0 0 0
0 0 0 0
0 0 0 0
0 0 0 0
b 0 0 0
0 0 0 0
0 0 0 0
0 0 0 0
.... FAILED.
Scot Bean
Honored Contributor

Re: failed to use "boot lan" on client to start install by ignite.

Why change the hostname after install?

Did you also change the IP address, or just the hostname?

Files to check for the old hostname:
/etc/hosts
/etc/rc.config.d/netconf
/etc/dhcpclient.data
li_p327
Occasional Advisor

Re: failed to use "boot lan" on client to start install by ignite.

I installed the ignite server with old name, but need change to new name as dns confilict. There are no old name info in
/etc/hosts
/etc/rc.config.d/netconf
/etc/dhcpclient.data.


I can boot client by run "bootsys -w hostname" on server sucessfully. But failed when boot on client with "boot lan.x.x.x.x install" cmd.
George Genov
Frequent Advisor

Re: failed to use "boot lan" on client to start install by ignite.

Hi,

In the syslog file on the Ignite server there should be some messages.
Check to see if there are errors or warnings.

BR

George
li_p327
Occasional Advisor

Re: failed to use "boot lan" on client to start install by ignite.

I increased debug level of bootp and instl_bootd, but did not find useful info.
George Genov
Frequent Advisor

Re: failed to use "boot lan" on client to start install by ignite.

There is a command bootpquery with which you can try if your bootp server responds to bootp requests:

bootpquery -i -s
li_p327
Occasional Advisor

Re: failed to use "boot lan" on client to start install by ignite.

It returns:
bootpquery: Bootp servers not responding!
But I tried on an working ignite server, still same output.
George Genov
Frequent Advisor
Solution

Re: failed to use "boot lan" on client to start install by ignite.

I suppose that the ignite server and the client a PA-RISC server?

If it is so check if there is in the bootpd conf file /etc/opt/ignite/instl_boottab correct entry for the client MAC address and there is corresponding IP address which is not met in your network (you can not ping it).

You can not boot a client with an IP which is already assigned .