ignite & make_tape_recovery

 
Jeff Hagstrom
Regular Advisor

ignite & make_tape_recovery

Do I have to load and start a server to use the make_tape_recovery from ignite 10.20? Can I untar ignite1020.tar and just use the make_tape_recovery? Are there any patches associated with ignite? because my boss tried to install ignite before and was not able to get it to work.
4 REPLIES 4
Patrick Wallek
Honored Contributor

Re: ignite & make_tape_recovery

Steps to get ignite-ux working:

Download the latest version for your OS - for 10.20 - A.3.3.116

Install Ignite via swinstall - You do NOT have to un-tar the tar file. Swinstall can install ignite just fine from the tar file. If you invoke swinstall without any arguments it will prompt you for a source depot. In this field put in the directory and filename of the ignite download (like /tmp/ignite1020.A.3.3.116.tar).

Once ignite is installed do the make_tape_recovery command. Ignite is loaded in /opt/ignite so the command I would use is:

/opt/ignite/bin/make_tape_recovery -a /dev/rmt/0mn -I -v -x inc_entire=vg00

James R. Ferguson
Acclaimed Contributor

Re: ignite & make_tape_recovery

Hi Jeff:

'make_tape_recovery' is just a part of the Ignite product. Go to the URL below, and download the "A" version of Ignite (for 10.20).

http://www.software.hp.com/products/IUX/index.html

You install Ignite with 'swinstall' just like any other SD product.

There are no patches with Ignite. When a new release comes out (about every 3-months), simply download and execute 'swinstall' again. For successive installations of Ignite, you should toggle the "reinstall" options of 'swinstall' [-x reinstall=true -x reinstall_files=true].

...JRF...
Rob Smith
Respected Contributor

Re: ignite & make_tape_recovery

Hi, Just to add to what was written above, you must have the most recent pax patch for whatever rev you are runnning installed for ignite to function correctly.

Rob

HP-UX 11 ==>PHCO_20416

HP-UX 10.20 ==>PHCO_20388

Learn the rules so you can break them properly.
James R. Ferguson
Acclaimed Contributor

Re: ignite & make_tape_recovery

Hi Jeff (again):

Rob makes a good point. 'pax' is similar to 'tar' and is used by make_tape_recovery. While the 'pax' patch is *not* strictly part of the Ignite software, a version of pax that supports sparse file handling, long directory names, and certain cases of hard-links is required by Ignite.

The current Ignite versions (>= 3.2) verify that the pax patch level is sufficient for proper execution.

Thus, when you download Ignite, verify that you have a current pax patch too, and if not, download it too.

...JRF...