Re: ignite boot

 
mr.cool
New Member

ignite boot

i had setup a machine with all the standard patches and software set i needed for a set of machines, and i wanted to use the same machine as the ignite server for rest of the boxes (all machines including the ignite server are blade bl60p).

i created a golden image for this machine using
make_sys_image -d /opt/ignite/data/Rel_B.11.23 -s local -r B.11.23

this is what my ignite server has now.

# pwd
/opt/ignite/boot
# ll
total 2528
-r--r--r-- 1 bin bin 26 May 6 2006 AUTO
dr-xr-xr-x 2 bin bin 8192 Dec 5 14:42 Rel_B.11.00
dr-xr-xr-x 2 bin bin 8192 Dec 5 14:43 Rel_B.11.11
dr-xr-xr-x 2 bin bin 8192 Dec 5 14:45 Rel_B.11.23
-r-xr-xr-x 1 bin bin 57 May 6 2006 auto_globals
-r--r--r-- 1 bin bin 332800 Dec 5 14:50 boot_lif
-r--r--r-- 1 bin bin 328192 Mar 26 2004 fpswa.efi
-rw-r--r-- 1 root sys 299 Dec 5 14:50 fs_cfg.def
-r--r--r-- 1 bin bin 541306 Dec 1 2005 hpux.efi
-r--r--r-- 1 bin bin 24576 Mar 26 2004 nbp.efi
#


# pwd
/opt/ignite/data/Rel_B.11.23
#
# ll
total 207040
-r-xr-xr-x 1 bin bin 12338404 May 6 2006 INSTCMDS
-r-xr-xr-x 1 bin bin 24582314 May 6 2006 INSTCMDSIA
-r-xr-xr-x 1 bin bin 272831 May 6 2006 RECCMDS
-r-xr-xr-x 1 bin bin 467812 May 6 2006 RECCMDSIA
-r--r--r-- 1 bin bin 24667545 May 6 2006 SYSCMDS
-r--r--r-- 1 bin bin 43610467 May 6 2006 SYSCMDSIA
-r--r--r-- 1 bin bin 23558 May 6 2006 config
-r--r--r-- 1 bin bin 1122 May 6 2006 hw_patches_cfg

Now when i am trying to install the image from ignite server from the clients (which apparently has no OS) using dbprofile am getting the appended error.

Shell> lanboot -dn avi
Client MAC Address: 00 16 35 5E 64 70
Client IP Address: 82.148.100.111
Subnet Mask: 255.255.255.192
BOOTP Server IP Address: 82.148.100.110
DHCP Server IP Address: 0.0.0.0
Boot file name: /opt/ignite/boot/nbp.efi

Retrieving File Size
PXE-E18: Timeout. Server did not respond.
Exit status code: Invalid Parameter

any help will be much appreciated.
8 REPLIES 8
Ivan Krastev
Honored Contributor

Re: ignite boot

Add entry in /etc/opt/ignite/instl_boottab:


82.148.100.111:0x0016355E6470::reserve


regards,
ivan
mr.cool
New Member

Re: ignite boot

included the entry like you mentioned but without success. I am getting the same error.

Ivan Krastev
Honored Contributor

Re: ignite boot

Is that rx5670 server ? Can you give more details : server type, firmware version.


ivan
mr.cool
New Member

Re: ignite boot

servers are BL60p (itanium blade servers). unlike other blade servers, it doesnt support a virtual-cd. you can install the os using an usb-dvdrom or ignite server. so I have setup the first server, thats my ignite server using the external dvd-rom and want to install the same images on rest of the boxes.
Tom Brown
Advisor

Re: ignite boot

Two questions:

(1) Do your blades have any spare NICs? I think they come with four each, standard.

(2) Are you trying to boot over a network segment that has a Microsoft DHCP (or the equivalent) server?

This was our case, and the DHCP server eats the PXE traffic, so the Ignite server never gets the boot request. We used a crossover cable between a spare NIC on the Ignite server and a spare NIC on the blade you want to boot to, and configuring a private LAN over that crossover cable using /etc/hosts on the Ignite server.

Set up the instl_boottab entry on the Ignite server for the spare NIC on the blade, assigning a unique address on the private LAN (you could even use a hub). There is no point in configuring DHCP on the ignite server, just use instl_bootp.

As you have already discovered, dbprofile does not work for some reason, even over the private LAN. Just forget about dbprofile and use lanboot select and select the NIC where you have the private LAN configured. The ignite server will get the PXE requests directly, and allow you to boot up right away.
It is better to be rich and healthy than poor and sick.
mr.cool
New Member

Re: ignite boot

Hi Tom,

Yes, these servers has come with 4 NICs and my ignite server is none other than one of the blade in the same complex.

Like you said, I will try it using "lanboot select" and let you know

And here is the sysrev details:
[mp001560cc5806] MP:CM> sysrev


SYSREV

Current firmware revisions

MP FW : H.03.21
BMC FW : 04.08
EFI FW : 05.41
System FW : 01.70




[mp001560cc5806] MP:CM>

Quin Hammes_1
Occasional Advisor

Re: ignite boot

I am having the same issue. I think part of the problem is that twice now we are getting blades shipped to us without an OS.

What is the deal with that? I tried every suggestion from many posts (dbprofile, instl_bootd, bootd, etc..) to get this working and nothing has worked. This whole thing of having to have a ignite server to install blades is silly. i dont know why HP designed the C7000 without a DVD. What if you are installing this in a production environment, that you have to have a DHCP server on the same subnet and you dont have a ignite server on that subnet? Of course also why do they seem to not be shipping the blades with OSes? Just imagine if HP sold a C7000 enclosure to a customer who doesnt already have HPUX? good luck getting that to work.

Enough of my rant.

Mr Cool,
Where you ever able to resolve this issue? Is your ignite server in the same enclosure as the server you are trying to install?
Jeromejay
Advisor

Re: ignite boot

"I think part of the problem is that twice now we are getting blades shipped to us without an OS"
=> even though HP recommands setting an ignite server ...etc, our favorite way of installing a new blade is by using the iLO:

just launch the iLO, find your way to the virtual mount stuff.
Then, insert the DVD into the DVD drive of your own computer, and boot from there.

It actually works fine this way