Ignite-UX

Re: make_net_recovery: Pb with NFS

 
SOLVED
Go to solution
Romaric Guilloud
Regular Advisor

make_net_recovery: Pb with NFS

When launching a:
$make_net_recovery -v -s -x inc_entire=vg00
I get the following error:

* Creating NFS mount directories for configuration files.
nfs mount: getaddr_nfs: : NFS service not responding(retry delay=5s)
nfs mount: retry: retrying(1) for: /var/opt/ignite/recovery/client_mnt after 5 seconds
nfs mount: retry: giving up on: /var/opt/ignite/recovery/client_mnt
ERROR: Could not NFS mount directory /var/opt/ignite/clients on . The
exports file on should contain the entry
"/var/opt/ignite/clients -anon=2". Ensure that /var/opt/ignite/clients
has been exported using the "exportfs -av" command.
ERROR: Failed mounting directory /var/opt/ignite/recovery/client_mnt:/Error 0
(errno = 0)
ERROR: Failed to creaet NFS mount directories for configuration files.

My /etc/exports file is well populated on the NFS server side and the NFS client running also...

Any hint?
Thanks in advance.
Sincerely,

Romaric.
"And remember: There are no stupid questions; there are only stupid people." (To Homer Simpson, in "The Simpsons".)
10 REPLIES 10
James R. Ferguson
Acclaimed Contributor

Re: make_net_recovery: Pb with NFS

Hi:

If you are relying on DNS then this may be your problem. Make an appropriate '/etc/hosts' entry on your NFS server.

Regards!

...JRF...
Helen French
Honored Contributor

Re: make_net_recovery: Pb with NFS

From ITRC TKB #UIUXKBRC00009768:

"There could be a few things that might produce an error like this, but it is
usually a DNS issue. Verify that nslookup can resolve the hostname and IP
address forward and backward. Another thing to try would be to add the hostname
of the client to the /etc/hosts file on the server.

Other things that can cause similar problems are the permissions and ownership
of /var/opt/ignite and all of the directories under them. The group and owner
is typically bin and the permissions are atleast read and execute for everyone."
Life is a promise, fulfill it!
Sridhar Bhaskarla
Honored Contributor

Re: make_net_recovery: Pb with NFS

Hi Romaric,

Add these two entries to /etc/exports of your NFS server.

/var/opt/ignite/clients -anon=2
/var/opt/ignite/recovery/archives/your_client -anon=2,access=your_client

Make sure you have enough spacei n /var/opt/ignite/recovery/archives.

Do an "exportfs -au and exportfs -a".

Try make_net_recovery again.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Steven E. Protter
Exalted Contributor

Re: make_net_recovery: Pb with NFS

Places to look:

1) NFS patches. Always a good thing to be currwent on.
2) Network setup.

lanadmin -x lan#

replace # with the actual number of the lan card from lanscan or ifconfig.

Make sure you have correct speed and duplex.

If you are running through a Cisco switch with a 100 BaseT card, have the Cisco admin set the port on all HP-9000 boxes using 100 BaseT cards to 100 BaseT Full duplex explicit. Do not use auto negotiate.

Boot your HP box and re-run the lanadmin command.

If you show inconsistency or just want to be safe, hardcode your NIC speeds into the file /etc/rc.config.d/hpbtlanconf

I'm attaching mine as an example.

3) On the Ignite server, make sure your instl_adm -T command shows the correct LAN settings.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Romaric Guilloud
Regular Advisor

Re: make_net_recovery: Pb with NFS

Thank you guys for the try, but I've gone thru all this pretty much before logging this call into the forum:
-Resolving the name is OK,
-permissions were bin:bin already on /var/opt/ignite/recovery,
-/etc/exports is properly populated on the NFS server side,
-NFS patches are PHNE_23248 on the client side + PHKL_24253, PHNE_23574, PHNE_24035 on the server side,
-My lanics all run in 100 Full-Duplex.

Still instl_adm -d reports that the server is "127.0.0.1".
Is it normal to have the loopback address here?

Any help is greatly welcome and will be awarded for sure :-)

Thanks in advance.

Romaric.


"And remember: There are no stupid questions; there are only stupid people." (To Homer Simpson, in "The Simpsons".)
James R. Ferguson
Acclaimed Contributor

Re: make_net_recovery: Pb with NFS

Hi (again):

I have encountered cases with NFS where name resolution via DNS worked insofar as 'nslookup' and 'ping' and yet I could not mount directories on the client successfully. The fix was to place entries in local 'etc/hosts' files.

Regards!

...JRF...
Romaric Guilloud
Regular Advisor

Re: make_net_recovery: Pb with NFS

Thanks James but they are as well:
nsswitch.conf goes file first, dns second for hosts resolution!

I still don't get it...

Romaric.
"And remember: There are no stupid questions; there are only stupid people." (To Homer Simpson, in "The Simpsons".)
Sridhar Bhaskarla
Honored Contributor

Re: make_net_recovery: Pb with NFS

Hi Romaric,

Do some debugging here.

Try mounting IUSSERVER:/var/opt/ignite/recovery/your_client onto a temporary directory on your_client and see if it works.

The above entry /var/opt/ignite/recovery/your_client should be exported on your IUX server.

If you do it from the IUX server, it will create your_client directory under /var/opt/ignite/recovery and export it. But if you run make_net_recovery from the client itself, you will need to create this directory and export if I am not mistaken.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Jean-Guy GROSSE
Advisor
Solution

Re: make_net_recovery: Pb with NFS

Hello ROmaric,

Sometimes the NFS server is totaly broken.
Try to stop nfs server and nfs client and restart. It's stupid but sometimes ....

Jgg.