Re: make_tape_recovery error

Go to solution
Stephen Keane
Honored Contributor

make_tape_recovery error

HP-UX 11.11 on a B1000.
Ignite version B.3.3.116
The machine has one disk in one volume group, so the Ignite backup is actually a full backup as well. The tape device is a HP C1533A

I Ran ...

# make_tape_recovery -A -v -a /dev/rmt/1mn

The last few lines of the output are as follows ...

* Preparing to create system archive

* Archiving contents of XXXXX via tar image to local device /dev/rmt/1mn
awk: Cannot divide by zero.
The input line number is 21815
The source line number is 2.

* Creation of system archive complete

* Cleaning up old configuration file directories

====== 05/17/05 12:00:49 BST make_tape_recovery completed successfully!

So my questions are

(1) Why does it say it completed succesfully, when it also reported an error message?

(2) What does the error message mean, i.e. how can I tell what is causing the problem?

Upon examining the pax archive after the LIF on the tape, I discovered that a lot of /var files have not been backed up. So much for 'completed successfully!'

I have run make_tape_recovery before on this machine and it has worked fine up until now. I regressed to this version of Ignite because the later version didn't create a bootable image that would actually boot, so don't tell me to install the latest version of Ignite!

Robert-Jan Goossens
Honored Contributor

Re: make_tape_recovery error

Hi Stephen,

Check if you can open next doc.

Best regards,
Pete Randall
Outstanding Contributor

Re: make_tape_recovery error


A couple of thoughts. First, that version of Ignite is quite old. The current version is C.6.1x. I would download and install that from here:

Second, to get a complete backup, I would use the following syntax:

make_tape_recovery -a /dev/rmt/1mn -I -v -x inc_entire=vg00

Unless you specify the "-x inc_entire" option, Ignite just backs up a selected list of essential files.


Stephen Keane
Honored Contributor

Re: make_tape_recovery error

I thought that the -A flag meant the entire root VG was included.

That certainly explains (2), but not why HP can't get their basic error handling right.

Yes I know it's an old version of Ignite, but as I said, the later version I tried created a bootable image that wouldn't boot. I believe that latter problem was due to an IDE patch that had been installed, which wrecked kernels from then on, thus making any new kernel unbootable, so maybe (now that I've uninstalled the rogue patch - thanks HP!) I'll upgrade the Ignite version.