Ignite-UX

make_tape_recovery not aloow use 1mn

 
SOLVED
Go to solution
Wayne Yu_1
Frequent Advisor

make_tape_recovery not aloow use 1mn

I want to use tape drive at /dev/rmt/1m to do make_tape_recovery, this is what I got:

# make_tape_recovery -A -x inc_entire=vg00 -d /dev/rmt/1mn
* Creating local directories for configuration files and archive.

======= 10/10/02 09:54:44 PDT Started make_tape_recovery. (Thu Oct 10
09:54:44 PDT 2002)
@(#) Ignite-UX Revision B.3.7.96
@(#) net_recovery (opt) $Revision: 10.575.1.1 $

* Testing pax for needed patch
* Passed pax tests.
* Checking Versions of Ignite-UX filesets
ERROR: Failed to open tape device /dev/rmt/0mn:No such device or address
(errno = 6).
ERROR: Check tape device failed.

======= 10/10/02 09:54:49 PDT make_tape_recovery completed unsuccessfully
#

Why does it try omn not 1mn?
I tried use /dev/rmt/1m and /dev/rmt/1mn also tried to set the file /var/opt/ignite/recovery/default to have /dev/rmt/1m or /dev/rmt/1mn, or 1mn, or 1m in it. Nothing works :-< Am I the QA for this feature?
9 REPLIES 9
James R. Ferguson
Acclaimed Contributor
Solution

Re: make_tape_recovery not aloow use 1mn

Hi:

Your tape device option is wrong. Use '-a /dev/rmt/1mn'. The '-d' option is for the one-line description of the archive.

Regards!

...JRF...
Jeff Schussele
Honored Contributor

Re: make_tape_recovery not aloow use 1mn

Hi Wayne,

You need to use
-a /dev/rmt/1mn
-d is now "description" in make_tape_recovery.

This changed between make_recovery & make_tape_recovery.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Wayne Yu_1
Frequent Advisor

Re: make_tape_recovery not aloow use 1mn

Thanks so much! I read the man page so many times and always throught that was -d (the screen get reverse video on that letter, so that I could not read it right). I will turn off the reverse video on the terminal software!

It is a totally stupid question.
Jeff Schussele
Honored Contributor

Re: make_tape_recovery not aloow use 1mn

Hi (again) Wayne,

Don't be so hard on yourself, my friend.
There are NO stupid questions...just dumb answers. Something....ahem....I've never been known to do =~)

Cheers,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Michael Tully
Honored Contributor

Re: make_tape_recovery not aloow use 1mn

I'd like to see how many times, you've said "oops" Jeff.... ha ha :^))
Anyone for a Mutiny ?
Jeff Schussele
Honored Contributor

Re: make_tape_recovery not aloow use 1mn

Hang on Michael....I've got to untie my shoes to count! hee...hee...hee

Cheers,
Jeff (Who's as fallible as the next bloke)
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Wayne Yu_1
Frequent Advisor

Re: make_tape_recovery not aloow use 1mn

Thanks a lot folks! Just one little quick one, why the /var/opt/ignite/recovery/default file does not work? Was something that I did wrong as well?
Jeff Schussele
Honored Contributor

Re: make_tape_recovery not aloow use 1mn

Hi (again) Wayne,

Believe it may be as simple as a typo.
File should be:
/var/opt/ignite/recovery/defaults
plural default

Then the entry inside would be

RECOVERY_LOCATION=hostname:/dev/rmt/1mn

I can see where the man page messed you up as towards the top they call it default. But down in the guts they clearly call it defaults.

Oh well...beats no man page at all.

Rgds,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Wayne Yu_1
Frequent Advisor

Re: make_tape_recovery not aloow use 1mn

Thanks a lot!