Showing results for 
Search instead for 
Did you mean: 

pax: write : I/O error

Occasional Visitor

pax: write : I/O error


while trying to make a recovery tape I get the following error on my rp3440 hp-ux 11.v1 box with LTO4 tapedrive:


njord 116: make_tape_recovery -a /dev/rmt/lto4 -l -v -m tar -x inc_entire=vg00
       * Creating local directories for configuration files and archive.

=======  07/19/11 15:32:59 WETDST  Started make_tape_recovery. (Tue Jul 19
         15:32:59 WETDST 2011)
         @(#)Ignite-UX Revision C.7.6.100
         @(#)ignite/net_recovery (opt) Revision:
         /branches/IUX_RA0806/ignite/src@73644 Last Modified: 2008-04-15
         17:21:10 -0600 (Tue, 15 Apr 2008)

       * Testing for necessary pax patch.
       * Checking Versions of Ignite-UX filesets
       * Scanning system for IO devices...
       * Boot device is: 0/1/1/0.0.0
       * Creating System Configuration.
       * /opt/ignite/bin/save_config -f
         /var/opt/ignite/recovery/2011-07-19,15:32/system_cfg vg00
save_config: warning - /dev/vg00/lvol4 has an umounted HFS filesystem on it. Therefore, any file system content in /dev/vg00/lvol4 will not be backed up.
       * Backing Up Volume Group /dev/vg00
       * /usr/sbin/vgcfgbackup /dev/vg00
       * Creating Map Files for Volume Group /dev/vg00
       * /usr/sbin/vgexport -s -p -m /etc/lvmconf/vg00.mapfile /dev/vg00

       * Backing Up Volume Group /dev/vg03
       * /usr/sbin/vgcfgbackup /dev/vg03
       * Creating Map Files for Volume Group /dev/vg03
       * /usr/sbin/vgexport -s -p -m /etc/lvmconf/vg03.mapfile /dev/vg03

       * Backing Up Volume Group /dev/vg04
       * /usr/sbin/vgcfgbackup /dev/vg04
       * Creating Map Files for Volume Group /dev/vg04
       * /usr/sbin/vgexport -s -p -m /etc/lvmconf/vg04.mapfile /dev/vg04

       * Creating Control Configuration.
       * Creating Archive File List
       * Creating Archive Configuration

       * /opt/ignite/lbin/make_arch_config -c
         /var/opt/ignite/recovery/2011-07-19,15:32/archive_cfg -g
         /var/opt/ignite/recovery/2011-07-19,15:32/flist -n 2011-07-19,15:32 -r
         pa -b 64 -d Recovery\ Archive -t 1 -i 1 -m t
       * Saving the information about archive to
       * Creating The Tape Archive
       * /opt/ignite/data/scripts/make_sys_image -c n -d /dev/rmt/lto4 -t n -s
         local -n 2011-07-19,15:32 -m t -w
         /var/opt/ignite/recovery/2011-07-19,15:32/recovery.log -u -R -g
         /var/opt/ignite/recovery/2011-07-19,15:32/flist -a 4132980
       * Preparing to create a system archive.

       * Archiving contents of njord via tar image to local device /dev/rmt/lto4.
pax: write : I/O error
pax: A write error has occurred.
WARNING: The pax command returned a non-zero exit status (exit status 1).
ERROR:   The find_files command failed (exit status 141).

ERROR:   The make_sys_image command failed. The system recovery archive will
         not be created.

=======  07/19/11 15:34:12 WETDST  make_tape_recovery completed unsuccessfully
njord 117: 


Originally I tried to /dev/rmt/0mn but with the same result, lto4 is just a node


Testing my tapedrive :

     tar cvf /dev/rmt/lto4  /multidata/ForTest

works fine.


njord 94: swlist -l product|grep -i ignite
  Ignite-UX             C.7.6.100      HP-UX System Installation Services


njord 95: swlist -l product | grep -i pax
  PHCO_35998            1.0            pax(1) cumulative patch


I thought maybe the 'pax' should be updated but I can only find depot's for 11.23 and 11.v3..

any tips?


originally I tried to /dev/rmt/0mn but with the same result, lto4 is just a node


Steven E. Protter
Exalted Contributor

Re: pax: write : I/O error



There is a wrapper called pax_iux that could be involed with this problem.


First some questions:


Is this system unique, or is the problem something that can be duplicated on other systems?


What is the reason you are using -m tar directive? Legacy, because it was used before or some specific purpose.



Steven E Protter
Owner of ISN Corporation
Pete Randall
Outstanding Contributor

Re: pax: write : I/O error

Seems pretty straightforward to me - I/O error = bad tape or dirty drive.

Dennis Handly
Acclaimed Contributor

Re: pax: write : I/O error

>Testing my tape drive:  tar cvf /dev/rmt/lto4  /multidata/ForTest


You need to write to your tape.