Ignite-UX

/var/opt/ignite/recovery/archives Permission denied

 
Mousa55
Super Advisor

/var/opt/ignite/recovery/archives Permission denied

Hi,

 

i facing this error message when i try to make ignite backup from client

 

* Creating The Networking Archive

 

nfs mount: servera:/var/opt/ignite/recovery/archives/serverb: Permission denied
ERROR:   Unable to mount or write servera:/var/opt/ignite/recovery/archives/serverb
         On servera you may need to:
         mkdir -p /var/opt/ignite/recovery/archives/serverb
         chown bin:bin /var/opt/ignite/recovery/archives/serverb

         If the OS on servera is 11.31 or later, vi /etc/dfs/dfstab. The /etc/dfs/dfstab file on "servera" should contain the entry: "share -F nfs -o
         sec=sys,anon=2,rw=<client> /var/opt/ignite/recovery/archives/serverb". Where <client> is replaced by a fully qualified client name.
         After editing the /etc/dfs/dfstab file, run "shareall -F nfs"
         If you need to change the owner of the directory,
         you will also need to re-share the directory.

         Otherwise, vi /etc/exports. The /etc/exports file on "servera" should contain the entry: "/var/opt/ignite/recovery/archives/serverb-anon=2,access=serverb".
         After editing the /etc/exports file, run exportfs -av
         If you need to change the owner of the directory,
         you will also need to re-export the directory.

         See make_net_recovery(1M) for more information.
ERROR:   Failed to Create NFS mount Archive directory.

On client server

 

# more /etc/hosts

 

10.x.x.x            serverb
10.x.x.x            serverb-mgt

10.x.x.x            servera
127.0.0.1          localhost       loopback


On ignite server


# more /etc/dfs/dfstab

share -F nfs -o anon=2 /var/opt/ignite/clients
share -F nfs -o sec=sys,anon=2,rw=serverb /var/opt/ignite/recovery/archives/serverb

# more /etc/hosts


10.x.x.x    servera
10.x.x.x    servera-mgt
10.x.x.x    serverb
10.x.x.x    serverb-mgt
127.0.0.1  localhost       loopback

# cd  /var/opt/ignite/recovery/archives
# ll
drwxr-xr-x   2 bin        bin             96 Jul 18 09:08 serverb

 

Thanks

4 REPLIES 4
V. Nyga
Honored Contributor

Re: /var/opt/ignite/recovery/archives Permission denied

Hi,

your OS on servera is 11.31 or later?
Do you have run "shareall -F nfs" on ignite server?

V.
*** Say 'Thanks' with Kudos ***
Mousa55
Super Advisor

Re: /var/opt/ignite/recovery/archives Permission denied

Hi,

 

your OS on servera is 11.31 or later?

my OS is 11.31 on both ignite and client

 

Do you have run "shareall -F nfs" on ignite server?

 

yes i run this command but still the issue

 

i follow this steps to configure the ignite backup server

 

Ignite Server setup
**********************

4.Setup the Ignite servers default values

# /opt/ignite/lbin/setup_server -n

 

5.Enable tftp and bootpd
# vi /etc/inetd.conf
...
tftp        dgram  udp  wait   root /usr/lbin/tftpd    tftpd \
        /opt/ignite\
        /var/opt/ignite
bootps      dgram  udp  wait   root /usr/lbin/bootpd   bootpd -d 3
...

6.Reread inetd config
# inetd -c

 

7.Check the default values of the Ignite installation
# instl_adm
...
server="2xx.4x.1xx.1xx"
netmask[]="255.255.255.240"
route_gateway[0]="2xx.4x.1xx.1xx"
route_destination[0]="default"
sd_server="2xx.4x.1xx.1xx"
...

8.Configure the ignite parameters to be only a boot helper that points to the "real" Ignite-UX server
# cd /opt/ignite/boot
# instl_adm -d > instl_adm.config
# vi instl_adm.config

instl_adm.config:

# instl_adm defaults:
# NOTE: Manual additions between the lines containing "instl_adm defaults"
#       and "end instl_adm defaults" will not be preserved.
server="172.16.18.50"
netmask[]="255.255.255.0"
route_gateway[0]="172.16.18.1"
route_destination[0]="default"
# end instl_adm defaults.

Where:

172.16.18.50 is the IP of the Ignite-UX server
255.255.255.0 is the netmask of the subnet the boot helper is part of
172.16.18.1 is the gateway of the subnet the boot helper is part of
 

9.Install the new parameters
# instl_adm -f instl_adm.config

 

10.On the ignite server create and share the archive directory for the client you want to backup


# mkdir -p /var/opt/ignite/recovery/archives/hostname
# chown bin:bin /var/opt/ignite/recovery/archives/hostname

# vi /etc/dfs/dfstab
share -F nfs -o anon=2 /var/opt/ignite/clients
share -F nfs -o sec=sys,anon=2,rw=/var/opt/ignite/recovery/archive​s/<client>

# shareall

 

11. Add Ignite clinet to /etc/hosts


# vi /etc/hosts
10.x.x.x client.hostname


Client setup
**************


1. Add Ignite server to /etc/hosts
10.x.x.x ignitesrv

 

2.To upgrade the Ignite client version from Ignite server
# /usr/sbin/swinstall -x mount_all_filesystems=false -s ignitesrv:/var/opt/ignite/depots/recovery_cmds "*"

 

3.Run the make_net_recovery command from client
# /opt/ignite/bin/make_net_recovery -Av -s ignitesrv
OR
# /opt/ignite/bin/make_net_recovery -Av -s igniteserver.domain -x inc_entire=/dev/vg00

 

Please let me know if is there any problem to setup the server and client as per the above steps.

Thanks

Mousa55
Super Advisor

Re: /var/opt/ignite/recovery/archives Permission denied

Hi,

 

your OS on servera is 11.31 or later?

my OS is 11.31 on both ignite and client

 

Do you have run "shareall -F nfs" on ignite server?

 

yes i run this command but still the issue

 

i follow this steps to configure the ignite backup server

 

Ignite Server setup
**********************

4.Setup the Ignite servers default values

# /opt/ignite/lbin/setup_server -n

 

5.Enable tftp and bootpd
# vi /etc/inetd.conf
...
tftp        dgram  udp  wait   root /usr/lbin/tftpd    tftpd \
        /opt/ignite\
        /var/opt/ignite
bootps      dgram  udp  wait   root /usr/lbin/bootpd   bootpd -d 3
...

6.Reread inetd config
# inetd -c

 

7.Check the default values of the Ignite installation
# instl_adm
...
server="2xx.4x.1xx.1xx"
netmask[]="255.255.255.240"
route_gateway[0]="2xx.4x.1xx.1xx"
route_destination[0]="default"
sd_server="2xx.4x.1xx.1xx"
...

8.Configure the ignite parameters to be only a boot helper that points to the "real" Ignite-UX server
# cd /opt/ignite/boot
# instl_adm -d > instl_adm.config
# vi instl_adm.config

instl_adm.config:

# instl_adm defaults:
# NOTE: Manual additions between the lines containing "instl_adm defaults"
#       and "end instl_adm defaults" will not be preserved.
server="172.16.18.50"
netmask[]="255.255.255.0"
route_gateway[0]="172.16.18.1"
route_destination[0]="default"
# end instl_adm defaults.

Where:

172.16.18.50 is the IP of the Ignite-UX server
255.255.255.0 is the netmask of the subnet the boot helper is part of
172.16.18.1 is the gateway of the subnet the boot helper is part of
 

9.Install the new parameters
# instl_adm -f instl_adm.config

 

10.On the ignite server create and share the archive directory for the client you want to backup


# mkdir -p /var/opt/ignite/recovery/archives/hostname
# chown bin:bin /var/opt/ignite/recovery/archives/hostname

# vi /etc/dfs/dfstab
share -F nfs -o anon=2 /var/opt/ignite/clients
share -F nfs -o sec=sys,anon=2,rw=/var/opt/ignite/recovery/archive​s/<client>

# shareall

 

11. Add Ignite clinet to /etc/hosts


# vi /etc/hosts
10.x.x.x client.hostname


Client setup
**************


1. Add Ignite server to /etc/hosts
10.x.x.x ignitesrv

 

2.To upgrade the Ignite client version from Ignite server
# /usr/sbin/swinstall -x mount_all_filesystems=false -s ignitesrv:/var/opt/ignite/depots/recovery_cmds "*"

 

3.Run the make_net_recovery command from client
# /opt/ignite/bin/make_net_recovery -Av -s ignitesrv
OR
# /opt/ignite/bin/make_net_recovery -Av -s igniteserver.domain -x inc_entire=/dev/vg00

 

Please let me know if is there any problem to setup the server and client as per the above steps.

Thanks

Mousa55
Super Advisor

Re: /var/opt/ignite/recovery/archives Permission denied

Hi,

 

i still facing the "Permission denied" erro.

 

Thanks