vg00 only partially included

 
SOLVED
Go to solution
Kurt Beyers.
Honored Contributor

vg00 only partially included

Hello,

I've created an Ignite tape with the following command:

/opt/ignite/bin/make_tape_recovery -x inc_entire=vg00 -I -v -a /dev/rmt/2mn

The recovery.log (see attachment) said that not the entire vg00 is included in the Igonte tape.

And indeed, using this tape in a disaster recovery test, didn't retrieve a few essential logical volumes of the root volume group (they were then restored using a full backup with Data Protector). How did this come?

best regards,
Kurt
7 REPLIES 7
G. Vrijhoeven
Honored Contributor

Re: vg00 only partially included

Hi Kurt,

Check the OLD man page: ( make_recovery)

If make_recovery (with no options) is invoked, the archive will
include:

from vg00: /stand, /sbin, /dev, /etc, /tmp, /home

from vg01: parts of /opt and /var (see Core-OS list)
/usr/bin, /usr/lib
/usr/obam, /usr/sam,
/usr/share, /usr/ccs,
/usr/conf, /usr/lbin,
/usr/contrib, /usr/local,
/usr/newconfig


If make_recovery -A is invoked, the archive will include:

from vg00: Everything under the root volume group.

from vg01: Everything on the non-root volume group.
Everything contained within /osdepot will be
included in the recovery archive.

So if you specify the -A option the entire vg00 should be backuped.

Hope this will help.

Gideon

Gideon

Kurt Beyers.
Honored Contributor

Re: vg00 only partially included

Gideon,

the equivalent of the '-A' option in 'make_recovery' is '-x inc_entire=vg00' in the make_tape_recovery command.

regards,

Kurt
Massimo Bianchi
Honored Contributor

Re: vg00 only partially included

hi Kurt,
which lvols where not restored ?

Those that were NOT mounted or the others ?
I think that the partially inlcuded message is related to the fact the some lvols were NOT mounted at the time of the make_recovery, thus preventing the backup...

Massimo



Kurt Beyers.
Honored Contributor

Re: vg00 only partially included

Massimo,

I don't remember all of the non included LVOLS out of my head, but for instance:

-LVOL that contains the Data Protector database (DP daemons were stopped during the creation)
-/var was not restored completely
-/u01
...

and probably a few other. But these LVOL's were mounted during the Ignite creation.

Kurt
Bernhard Mueller
Honored Contributor

Re: vg00 only partially included

Kurt,

from the logfile it is clear that make_tape_recovery did not see any reason to do "-x inc_entire=vg00" ; the indicator 1 for vg00 to include / (1), /stand (1), /usr (1) is exaclty what you get if you do not use any include/exclude options.

for this to happen the most obvious reason would be that this option was not specified at all.

if you accidentially specify an non-existing VG e.g. "-x inc_entire=vg100" you *should* have got a warning from list_expander, which however is not found in your logfile.

if you accidentially specify an existing but not active vg, the -v option would list just the disks which belong to the vg and no filesystems/mountpoints. So it is clear all vgs were active.

The only case I know where the warning "vg will be only partially included" is definitely misleading, is when you do an include of an entire non-root vg where the first logical volume is used as swap.

Regards,
Bernhard

Helen French
Honored Contributor
Solution

Re: vg00 only partially included

The issue is you have unmounted file systems in vg00 and cuz of that, the recovery process will not backup vg00 fully. Try by either mounting all file systems or remove unwanted LVs from the VG.

Check this document too TKB #8606325251:
http://www2.itrc.hp.com/service/cki/docDisplay.do?docLocale=en_US&docId=200000070381182
Life is a promise, fulfill it!
Kurt Beyers.
Honored Contributor

Re: vg00 only partially included

Thanks Shiju,

There were indeed unmounted file systems in vg00 that caused the vg00 not to be included entirely on the Ignite tape.

I've removed these LVOL's (didn't contain valid data any more) and just created a new Ignite tape. Now vg00 is included completely on the Ignite tape (there were no type mistakes in my make_tape_recovery command).

Kurt