Insight Control for Linux
cancel
Showing results for 
Search instead for 
Did you mean: 

Debian Lenny 5.0 install HP Tools for lenny

Franz Pammer
Occasional Contributor

Debian Lenny 5.0 install HP Tools for lenny

Hello,

i will install the HP Tools for Debain Lenny ( lenny-deliverables-20081028.iso) on a BL460c G1 Server!

when i install the hp-health (apt-get install hp-health) the following erro occours

-------------------------------------
Richte hp-health ein (8.2.0-1~20081010) ...
Using Proliant High Performance
IPMI based System Health Monitor
Starting Proliant High Performance
IPMI based System Health Monitor (hpasmxld): [ FAILED ]

invoke-rc.d: initscript hp-health, action "start" failed.
dpkg: Fehler beim Bearbeiten von hp-health (--configure):
Unterprozess post-installation script gab den Fehlerwert 29 zurück
----------------------------------------

and on the Console the follwing error is listed

hpasmxld: Invalid Device: /dev/ipmi0

Ihave Installed the debian package "openhpi-plugin-oa-soap"

and i hvae configured the file /etc/openhpi/openhpi.conf
------------------
handler liboa_soap {
entity_root = "{SYSTEM_CHASSIS,8}"
OA_User_Name = "yyyy" # OA user name with admin privileges (required)
OA_Password = "xxxxx" # OA password for above user (required)
ACTIVE_OA = "enc01a" # Active OA hostname or IP address (required)
STANDBY_OA = "enc01b" # Standby OA hostname or IP address (optional)
}
----------------------
is ther anything other to configure/install?

3 REPLIES
Steven E. Protter
Exalted Contributor

Re: Debian Lenny 5.0 install HP Tools for lenny

Shalom,

These tools may not be compatible with your version of Debian.

The dependency database may be incorrect as well.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Daniel Frazier
Frequent Advisor

Re: Debian Lenny 5.0 install HP Tools for lenny

hey Franz,
It looks like your ipmi modules aren't getting loaded - perhaps there's a conflict? Can you change the first line of /etc/init.d/hp-health from:
#!/bin/sh
to:
#!/bin/sh -x

And then run /etc/init.d/hp-health start?

Also, the output of the following commands would be helpful:
$ dmesg | grep ipmi
$ find /proc/ipmi
$ lsmod
$ ls -l /dev/ipmi*

Franz Pammer
Occasional Contributor

Re: Debian Lenny 5.0 install HP Tools for lenny

i have manually loded the modules
and now it works

/etc/modules
ipmi_si
ipmi_devintf
ipmi_watchdog


thx