Insight Control for Linux
cancel
Showing results for 
Search instead for 
Did you mean: 

ICE-Linux 2.11 and bl460c G6 blades

Martin McNally
Occasional Visitor

ICE-Linux 2.11 and bl460c G6 blades

Hello all,

I manage an ICE-Linux 2.11 environment that includes 130+ bl460c G1 blades. We've recently took delivery of some G6 blades and I can't get them to discover. I know they have different nics in them than the G1's and I know they need an updated initrd.img file but don't know where to get it from.

Anyone else running G6 blades with ICE-Linux 2.11 ?

Thanks in anticipation
7 REPLIES
Rigoberto Corujo
Frequent Advisor

Re: ICE-Linux 2.11 and bl460c G6 blades

Hi Martin,

If you connect to one of the G6 servers via the iLO using a browser and open up a Remote Console window, does the server boot into the ICE-Linux RAM disk when you do the discovery? If it does, it should get to a point where you can press "Enter" to get a shell prompt. Once in the shell prompt you should be able to do an "ifconfig -a" to make sure that the network interface is up. If the server doesn't boot into the ICE-Linux RAM disk during a discovery (e.g. tries to boot to local disk or something) then you might need to check that the blade is configured to PXE boot from the correct NIC and DHCP is configured to give an IP address to that NIC. The updated initrd.img is only for Red Hat or SLES installations since the initrd.img that ships with those distributions may not support the NIC on the G6. I believe that section "6.3.2 Prerequisites for ProLiant G6 managed systems" of the User Guide lists the URL where you can download the initrd's from.

Rigoberto
Donna Firkser
Regular Advisor

Re: ICE-Linux 2.11 and bl460c G6 blades

We just entered a Customer Advisory where the RAM disk in IC-Linux V6.0 (or earlier) kernel panics with the latest iLO2 firmware version 2.0. If you recently took delivery of G6 blade servers, I'm thinking they may be running iLO2 firmware 2.0 and thus you're hitting this issue.

Can you please confirm the iLO2 firmware version?

The work around we're recommending is to upgrade to IC-Linux V6.1.

Thanks,
Donna
Martin McNally
Occasional Visitor

Re: ICE-Linux 2.11 and bl460c G6 blades

Thanks to everyone for replying so promptly. I think I have a combination of both problems mentioned. The ILO on the G6 blades is 2.0 so thay might be why the G6's panic. I'm on ICE-Linux 2.11 and upgrading to 6.1 isn't an option at the moment so I think I will try downgrading the firmware on a G6 and try it again. I know the default boot files with 2.11 have a problem with the newer nics in the G6's so can anyone recommend which boot files to try. The links to RH4.7 and RH5.2 kernels I was sent by the HP helpdesk just boot into an interactive Red Hat installation
Rigoberto Corujo
Frequent Advisor

Re: ICE-Linux 2.11 and bl460c G6 blades

Hi Martin,

Once you get your G6 blades discovered and you want to install Red Hat on them, you'll need to download the special initrd.img file as described in section 6.3.2 of the User Guide. The special initrd.img file has the driver for the NIC on the G6. Were you able to download the initrd from the URL listed in the User Guide?

Rigoberto
Donna Firkser
Regular Advisor

Re: ICE-Linux 2.11 and bl460c G6 blades

Do you have access to the ICE-Linux user's guide Version 2.10.01? The instructions and location of the modified initrds is in Section 6.3.2.

Thanks,
Donna
Martin McNally
Occasional Visitor

Re: ICE-Linux 2.11 and bl460c G6 blades

Hello all, I've managed to get a G6 blade to discover in ICE 2.11.

I had to downgrade the ILO from 2.00 to 1.82

Doing that was enough to get the blade to complete the discovery process and I'm still using the original initrd.img/kernel pair that comes with ICE 2.11

The next step was to kickstart build the blade as Red Hat 5.3 which knows about the updated nic which I have successfully done.

Thanks again for everyones help
Donna Firkser
Regular Advisor

Re: ICE-Linux 2.11 and bl460c G6 blades

Excellent news.

Thanks,
Donna