Insight Control for Linux
cancel
Showing results for 
Search instead for 
Did you mean: 

What is best setup for SNMP settings for Linux Agents

SOLVED
Go to solution
Dave.
Valued Contributor

What is best setup for SNMP settings for Linux Agents

What is the best setting for SNMP settings (in snmpd.conf) for ProLiants running Linux (Red Hat, SUSE or Debian etc).

I have read that it is only worth enabling SNMP authentication traps if you are monitoring for them otherwise it is using unnecessary bandwidth.
I also read that for the agents to work fully they need to be configured locally. I assume that means they need to send traps to localhost AND also be enabled for that community string.
Thus would this example make sense, it is correct, can it be shortened or is it missing anything?

dlmod cmaX /usr/lib/libcmaX.so
rocommunity CCCCC ????????
rocommunity CCCCC !!!!!!!!
rwcommunity AnyCommunityStringY0uL!ke localhost
trapsink AnyCommunityStringY0uL!ke localhost
trapsink ??????? CCCCC
trapsink !!!!!!! CCCCC
trapcommunity CCCCC
authtrapenable 0
syslocation "Sitename"
syscontact "Site Helpdesk"

where
CCCCC is Read Only Community
AnyCommunityStringY0uL!ke is a more complicated RW Community string
???????? is IP address of CMS
!!!!!!!! is IP address of 2nd Management Station
Regards, Dave
3 REPLIES
David Claypool
Honored Contributor
Solution

Re: What is best setup for SNMP settings for Linux Agents

That works with one exception: there's no purpose to sending a trap to localhost unless there's an application that is running there to receive it...
wahome
Occasional Visitor

Re: What is best setup for SNMP settings for Linux Agents

I have the same settings as Dave, but my linux server does not send traps to the hp sim server.

I cannot even connect to the linux server via the web browser.

I have installed hpasm and not hpsim. Finally, can I have both hpasm and hpsim installed on the same linux machine?
David Claypool
Honored Contributor

Re: What is best setup for SNMP settings for Linux Agents

Is it possible that SELinux or the firewall is preventing you?