Insight Remote Support
cancel
Showing results for 
Search instead for 
Did you mean: 

HP SIM/CRM 6.0 FTP Required?

Keith.Evans
Occasional Contributor

HP SIM/CRM 6.0 FTP Required?

I work as a security analyst focusing on server vulnerability management. One of our Windows Admins is installing a new HP SIM 6.0 server. While performing the vulnerability scan we noticed that the IIS FTP server was/is enabled. We don't allow FTP due to clear text authentication and data transfer.

Text of email sent from admin:
HP SIM 6.0 is requiring FTP Server installed as a prerequisite (from HP Insight Software Advisor). I am told this is for updates to agents.

From an HP Support Rep:
FTP is in fact used for Insight Remote Control Advanced Support Version Control Repository - Used for downloading HP Updates from HP Directly, and also to distribute the updates to the individual managed servers that are controlled by the SIM server.

1) I have to allow FTP communication from every managed server to the SIM server for updates?
2) I have to allow FTP communication from the SIM server to HP for updates?

This just seems awkward and bad security practice. Can someone enlighten me on alternative update methods (or provide URL references) or explain why FTP is required.

Please help. Thank you so much in advance.

5 REPLIES
Rob Buxton
Honored Contributor

Re: HP SIM/CRM 6.0 FTP Required?

I've never installed the FTP Server as part of a standard HPSIM installation. Just completed a new HPSIM 6.0 with the supporting tools and FTP was certainly not installed.
As part of that I've installed the Remote Support Software Manager and WEBES and that hasn't required FTP either.
So I'm as mystified as you.
Keith.Evans
Occasional Contributor

Re: HP SIM/CRM 6.0 FTP Required?

Thank you for your response. I just don't get it. I have a feeling it's something in the custom configuration of the product on installation that is triggering the requirement, but not being the admin to install and not having any hands on make it difficult.
Keith.Evans
Occasional Contributor

Re: HP SIM/CRM 6.0 FTP Required?

Here's a screen shot of the pre-req.

Re: HP SIM/CRM 6.0 FTP Required?

I beleive the Advisor checks for the requirments for all the suite components even if you are not installing them all. Insight Rapid Deployment requires FTP to installed to host a DSLib folder so when the bare metal servers that PXE boot can access file to run a script. However, if you are not using Insight Rapid Dployment and just care around HP SIM functionality, then you don't have to worry about installing the FTP component.
Keith.Evans
Occasional Contributor

Re: HP SIM/CRM 6.0 FTP Required?

Thank you.