Insight Remote Support
cancel
Showing results for 
Search instead for 
Did you mean: 

WEBES 5.6 no listening port 7906

Witron_1
Advisor

WEBES 5.6 no listening port 7906

I recently installed WEBES 5.6 through RSSWM on HPSIM 5.3.1.
I did that on several similar systems without issues.
Unfortunately I am not able to logn to the WEBES interface https://localhost:7906
I already tried to re-install WEBES several times without success.
I checked netstat -an and recognized, that no listening port 7906 is existing.
No other application or Anti Virus is blocking that port.
Any ideas why WEBES does not come up with TCP7906 once started up?

System is ProLiant running physical install of w2k3 x86 R2 with SP2


Thanks
10 REPLIES
Steve Begley
Trusted Contributor

Re: WEBES 5.6 no listening port 7906

Hi Witron,

It sounds as though the DESTA process hasn't started for some reason - without the DESTA process you will have no web access - a quick check would be to use a DOS window and type an sea cli command such as wsea stat - if that works then it's almost definately a DESTA problem.

To see tha status of the DESTA process - in a DOS window type desta status - this will show whether it's running or not.

If you want to try and start it manually - either use "net start desta_service" from DOS or start > all programs > Hewlett Packard Service Tools > WEBes > Start director.

I have found from experience though that if the director doesn't start it is normally down to some other problem.

Hope this helps - regards

Steve.B.


Tea break over - back on yer heads!
Witron_1
Advisor

Re: WEBES 5.6 no listening port 7906

Steve,

thaks for your fast reply.
I have started desta process and have verified it is running.
So WEBES Service (desta_service) is up'n'running fine, but I am still not able to logon to the web UI
I have no proxy settings enabled, java is also enabled and running
i also tried another broswer - still no access to the Web UI

strange thing, any other hints?
Thx
Witron_1
Advisor

Re: WEBES 5.6 no listening port 7906

I have another possible issue:

when executing "desta stop" it copmes up with following error, which I have not seen before:

C:\desta stop
Checking for DESTA director with PID 9548
The Director process is starting up.
Stopping the Director
Director did not respond to a shutdown.
Shutting down desta stop process.
Error 66: DESTAException.

Any ideas what error 66 means in this case?

Steve Begley
Trusted Contributor

Re: WEBES 5.6 no listening port 7906

Hi Witron,

I googled error 66 and if it's a Windoze error it seems to be to do with the registry - try the link below:

http://fixing-center.com/error-66.html

It seems to be a free fix....

I could however be completely wrong here....?

regards,

Steve.B.
Tea break over - back on yer heads!
JKytsi
Honored Contributor

Re: WEBES 5.6 no listening port 7906

check desta and webes logs. Do You see any out of memory errors there?
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi
Witron_1
Advisor

Re: WEBES 5.6 no listening port 7906

I chekced the logs, Desta log reports no errors, but webes log report an PSQL exception. Seems that the newly used PostgreSQL (this has changed from MSSQL2005 to PostgreSQL in WEBES version 5.6):


ERROR_RECOVERABLE: 2009-09-24 02:18:48.829 -0600
Thread: main

6183504 Retry attempt 3
org.postgresql.util.PSQLException: Connection refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(ConnectionFactoryImpl.java:123)
at org.postgresql.core.ConnectionFactory.openConnection(ConnectionFactory.java:66)
at org.postgresql.jdbc2.AbstractJdbc2Connection.(AbstractJdbc2Connection.java:124)
at org.postgresql.jdbc3.AbstractJdbc3Connection.(AbstractJdbc3Connection.java:30)
at org.postgresql.jdbc4.AbstractJdbc4Connection.(AbstractJdbc4Connection.java:29)
at org.postgresql.jdbc4.Jdbc4Connection.(Jdbc4Connection.java:24)
at org.postgresql.Driver.makeConnection(Driver.java:386)
at org.postgresql.Driver.connect(Driver.java:260)
at java.sql.DriverManager.getConnection(DriverManager.java:582)
at java.sql.DriverManager.getConnection(DriverManager.java:207)
at com.hp.svctools.hibernate.HibernateSessionFactory.createConnection_r(HibernateSessionFactory.java:387)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.hp.svctools.hibernate.Axtx.rTrans(Axtx.java:57)
at com.hp.svctools.hibernate.Dxtx.exec(Dxtx.java:68)
at com.hp.svctools.hibernate.HibernateSessionFactory.createConnection(HibernateSessionFactory.java:371)
at com.hp.svctools.hibernate.HibernateSessionFactory.createConnection(HibernateSessionFactory.java:366)
at com.hp.svctools.hibernate.HibernateSessionFactory.checkConnection(HibernateSessionFactory.java:579)
at com.hp.svctools.hibernate.HibernateSessionFactory.get(HibernateSessionFactory.java:118)
at com.compaq.svctools.desta.services.hsqldb.BuildDB.initAllSchemas(BuildDB.java:135)
at com.compaq.svctools.desta.services.hsqldb.BuildDB.execute(BuildDB.java:169)
at com.compaq.svctools.desta.services.hsqldb.BuildDB.resetAll(BuildDB.java:275)
at com.compaq.svctools.desta.services.hsqldb.BuildDB.main(BuildDB.java:223)
Caused by: java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:519)
at java.net.Socket.connect(Socket.java:469)
at java.net.Socket.(Socket.java:366)
at java.net.Socket.(Socket.java:180)
at org.postgresql.core.PGStream.(PGStream.java:62)
at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(ConnectionFactoryImpl.java:77)
... 24 more


Any ideas?
Witron_1
Advisor

Re: WEBES 5.6 no listening port 7906


Spoke to our HP ASCE, he told me HP has numerous issues with WEBES 5.6 and Postgre

they advised to uninstall WEBES in RSSWM, using the WEBES cleanup tool (found on WEBES website) afterwards, which will clean the registry and try a new install

If this does not sort this out, they advised me to collect all relevant logs for analyzing

Keep you informed
Witron_1
Advisor

Re: WEBES 5.6 no listening port 7906

HP ASCE was not able to help with provided tools
So I went through all logs and found a workaround to fix it:
Problem is, that Postgre SQL is not installed properly. you can check this as you will not find any postgres.exe processes running.
WEBES install log will report:

Proceeding with WEBES 5.6 Installation..."
"PostgreSQL Registry Key=""HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-8.3" /v Version
"PostgreSQL Version=8.3"
"PostgreSQL 8.3 is Found on this system. The PostgreSQL 8.3 Installation is skipped..."
"Postgre SQL 8.3 installed on this system was not installed during previous WEBES installations..."
"Postgre SQL 8.3 is already found installed on this Server. The existing Postgre SQL install has not been carried out by WEBES."
"WEBES 5.6 requires Postgre SQL 8.3 for its functioning. Please follow the below mentioned instructions to create the WEBES Databases and enable WEBES Functionality. "
"1. Edit the following line in the file in C:\Program Files\HP\CM\Installers\WEBES\CreateWEBESDBs.bat. set PGPASSWORD=Webe$rules8552 .Replace Webe$rules8552 with the super password used during Postgre SQL Installation. "
"2. Execute C:\Program Files\HP\CM\Installers\WEBES\CreateWEBESDBs.bat"
"3. net Start Desta_Service "
PostgreSQL Data Directory PATH Query=C:\WINDOWS\system32\reg.exe QUERY "HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-8.3" /v Version
"PostgreSQL Data Directory ="
PSQLCMD PATH Query=C:\WINDOWS\system32\reg.exe QUERY "HKEY_LOCAL_MACHINE\SOFTWARE\PostgreSQL\Installations\postgresql-8.3" /v "Base Directory"
"PSQLCMD PATH VALUE =C:\Program Files/PostgreSQL/8.3\bin\psql"
"Now running CreateWEBESDBs.bat for creating the WEBES databases..."
"The destadb database is not created"
"The ed database is not created"
"The me database is not created"
"The wbemdb database is not created"


The logs advises to follow steps 1 to 3. Well, the password is correct, so there is no need to change it. Once you will execute CREATEWEBESDBS.bat (as advised in the log) you will receive another error, indicating "-h" is not recognized as an internal command. Another logical error from HP as they have forgotten to provide the correct parameters.
So you have to execute CREATEWEBESDBS.bat like follows:

createWEBESDBs.bat "C:\Program Files/PostgreSQL/8.3\bin\psql"

Then the batch is executed, but comes back with the following errors:

C:\Program Files\HP\CM\Installers\WEBES>rem
C:\Program Files\HP\CM\Installers\WEBES>rem Now logging to Postgre SQL. And crea
ting the required databases...
C:\Program Files\HP\CM\Installers\WEBES>rem
C:\Program Files\HP\CM\Installers\WEBES>set PGPORT=7950
C:\Program Files\HP\CM\Installers\WEBES>set PGPASSWORD=Webe$rules8552
C:\Program Files\HP\CM\Installers\WEBES>"C:\Program Files/PostgreSQL/8.3\bin\psq
l" -h localhost -p 7950 -U postgres -c "CREATE ROLE ""WEBES"" WITH SUPERUSER LOG
IN PASSWORD 'Webe$rules8552' CREATEDB";
psql: could not connect to server: Connection refused (0x0000274D/10061)
Is the server running on host "localhost" and accepting
TCP/IP connections on port 7950?
C:\Program Files\HP\CM\Installers\WEBES>"C:\Program Files/PostgreSQL/8.3\bin\psq
l" -h localhost -p 7950 -U postgres -c "DROP DATABASE IF EXISTS destadb";
psql: could not connect to server: Connection refused (0x0000274D/10061)
Is the server running on host "localhost" and accepting
TCP/IP connections on port 7950?


And so on...

So when verifying within netstat, you will see no listening port 7950, so the above script cannot execute successfully and your setup will not work:

These steps will fix this issue finally:
1.execute POSTGRESQL.EXE within C:\Program Files\HP\CM\Installers\WEBES
2.POSTGRESQL.EXE will report a found installation configured with port 7950 , which will be updated
3.Provide the password "Webe$rules8552" as found in WEBES InstallLog and finish the installation.
4. check, if port 7950 is now LISTENING in netstat
5. If so, continue with
cmd>
cd "C:\Program Files\HP\CM\Installers\WEBES"
C:\Program Files\HP\CM\Installers\WEBES>createWEBESDBs.bat "C:\Program Files/PostgreSQL/8.3\bin\psql"
the batch file is now executing without errors
6. Reboot server and log on to WEBES UI
HPCS France
Advisor

Re: WEBES 5.6 no listening port 7906

Hello
I checked the workaround with Postgresql where I notifyed the 7950 port but I don't have this port listening after installation, so createWEV+BESDBs;bat ... failed too with the message "Connection refused ..."
Do you have any idea ? Thanks
JM
Lawrance Lee_1
Frequent Advisor

Re: WEBES 5.6 no listening port 7906

I had a super hard time installing WEBES 5.6 Update 2. Ultimately with the help of HP support, had to uninstall the PostGres 8.3 database and install PostGres 8.4.

HP Support provided a script to create the database tables on PostGres 8.4 and after that WEBES seems to be working.