Insight Remote Support
cancel
Showing results for 
Search instead for 
Did you mean: 

failed to send event from hp-ux 11.11 to rsp.

SOLVED
Go to solution
klemerS
Frequent Advisor

failed to send event from hp-ux 11.11 to rsp.

Hello.

We are trying to configure hp-ux 11.11 on rsp.
The problem is that we do not get any events to the rsp system.

checking:

cimprovider -s -l show the SFMproviderModule

cimprovider -m -l SFMproviderMoudle show the
emswrapperprovider

root@cocopapa: /opt/sfm/bin/evweb subscribe -L -b external

HPWEBES_rsp.pelephone.co.il_Filter_HP_AlertIndication HPWEBES_rsp.pelephone.co.i
l_Handler_HP_AlertIndication select * from HP_AlertIndication CIMXML h
ttps://rsp.pelephone.co.il:7906/Wbem/WbemIndication?MEId=8ab988a91fd09e52011fd14
430de32d2&MEName=cocopapa.nix.pelephone.co.il&ruleSet=HPUX_WBEM_V2_9-30-08%3AHPU
X_V2_9-30-08%3BNonStop%3AWBEM_NonStop


On the T.S. doc i can see more lines for hp-sim. should i see thoses lines ??

HPSIM_simserver_0 HPSIM_simserver select * from HP_DeviceIndication UNKNOWN

HPSIM_ simserver_1 HPSIM_ simserver select * from HP_ThresholdIndication UNKNOWN

HPSIM_TYPE_1_ simserver_0 HPSIM_TYPE_1_ simserver_client SELECT * FROM CIM_AlertIndication CIMXML https://simserver:50004/cimom/listen1






Any idea ???


Thanks in advance !!!!!
6 REPLIES
Olivier Masse
Honored Contributor
Solution

Re: failed to send event from hp-ux 11.11 to rsp.

The HPSIM lines are WBEM subscriptions made by SIM to be able to receive events generated on your server. I don't think they need to be there for RSP to work per se, but if SIM is not subscribed, you won't see the events as they happen in the SIM event log.

To subcribe, do it from the pulldown menu in SIM or type this on the CMS: "mxwbemsub -a -n [hostname]"

WEBES should trap the test events and forward them to the RemoteSupport client. I suggest you configure WEBES to send you an e-mail when it does, so at least you'll know they went through WEBES. You'll see the events in SIM with the mention "A Service event has been reported", which means that it has been forwarded to HP as ISEE used to do. But for actual reporting to work, your system needs to be entitled in the RSP entitlement list (i.e. it needs to be configured with a product number and serial number, and possibly a contract number)

Good luck
Armin Kunaschik
Esteemed Contributor

Re: failed to send event from hp-ux 11.11 to rsp.

Does the test event appear in SIM?
You might need to enable transport in the Entitlement section.
Is EMS monitoring enabled (necessary for 11.11)? Use /etc/opt/resmon/lbin/monconfig to find out.

What version of SFM do you run? My problems went away after installing the current SFM (04/2009)

The following test events seem to work with send_test_event in 11.11:

dm_memory, dm_core_hw, dm_chassis, lpmc_em, disk_em

My 2 cents,
Armin

PS: Please assign points!
And now for something completely different...
klemerS
Frequent Advisor

Re: failed to send event from hp-ux 11.11 to rsp.

Hello again.

I need some help here understanding what is going on.

I go through the sfm-rsp guide on system called "cocopapa". & everything is o.k. !!!!

Now I tried a different system ( rp3440 hp-ux 11.11) name "sdp"

I go again step by step, all commands on hp-ux & rsp success, but when I am running
/opt/sfm/bin/evweb subscribe -L -b external

I am getting only the hp-sim entry . its missing the HP_WEBES entry.

Connecting to webes https://simserver-ip:7906 - when i am looking on "sdp" details under "WBEM" i see "UNIX-cocopapa" the same as in "cocopapa" system. I change it to "OFF" & run the wbem subscription again. I got same results. The "WBEM" changed to "UNIX-cocopapa". ???????????????

What I am missing here???

Shalom.
Olivier Masse
Honored Contributor

Re: failed to send event from hp-ux 11.11 to rsp.

I shouldn't show up as a UNIX system but an "ManagedSystem-HPUX" system in WEBES.

Subscribing to WBEM events directly from SIM or using mxwbemsub only creates HPSIM_* subscriptions in evweb. WEBES does its subscriptions by itself by scanning systems it knows of, and it updates its list of possible target systems by synchronizing itself with SIM. At least, that's what I've been able to understand until now. :)

What can happen is that sometimes WEBES detects a system before it's actually configured properly and it doesn't detect it correctly. You'll end up with a system that has the wrong hostname, or the wrong managed protocol. The best thing to do when this happens is to delete the server from WEBES, then stop and restart the director. Let it stabilize (might take 10 or more minutes), and WEBES will rescan your system and if you're lucky, iy will be listed correctly.
klemerS
Frequent Advisor

Re: failed to send event from hp-ux 11.11 to rsp.

Thank you.

I didnt know that WEBES does its subscriptions by itself .

I will be in customer site on sunday.

I am going to try what you suggested.



regards.

Shalom.
klemerS
Frequent Advisor

Re: failed to send event from hp-ux 11.11 to rsp.


Hello.

Problem solved. I am not sure what did it .
but i did 4 steps.
1. add rsp to /etc/hosts , even i could reach it using dns.
2. i am using root account but decided to change 2 params in monconfig :
enableSubscriptionsForNonprivilegedUsers=true
enableNamespaceAuthorization=true
3. again Creating WBEM subscription via Configure or Repair Agents.
4. run the rsp entitelment check.

& evweb show the HPWEBES entry.

Thanks you all.

Shalom.