Insight Remote Support
cancel
Showing results for 
Search instead for 
Did you mean: 

sfmconfig -t -<test>

sfmconfig -t -<test>

I've installed RSP on about 10 servers so far. I have 21 more to go.

It was really a huge pain and took way longer than I can believe or care to admit!

Anyhow ...

sfmconfig -t -a sends 5 test events on all of them but one server. That one only gets 2 events.

Using the flags for individual tests,
-f and -i send events. -m, -p and -b never show up.

This is Integrity, not a VM.

Any ideas?
11 REPLIES
SANJAY MUNDHRA
Regular Advisor

Re: sfmconfig -t -<test>

Unfortunately installing RSP for HPUX is not as simple for the Alpha servers, I would suggest the following:

1) Also need to ensure that the WBEM subscriptions are OK

2) Can you check if the events are visible on the client using the command:
#evweb eventviewer -L

Also check for the Wbem services on the client are subscribed to CMS.

Check that the SFMProvider Module is running fine and subscribed to the providers:
# /opt/wbem/bin/cimprovider -l â s
# /opt/wbem/bin/cimprovider -l -m SFMProviderModule

Verify the WBEM subscription from the HPUX device use the following command:
# /opt/sfm/bin/evweb subscribe -L -b external

Cheers,
Sanjay

Re: sfmconfig -t -<test>

Thanks for the update.

The WBEM subscriptions look OK when I check with /opt/sfm/bin/evweb subscribe -L -b external.

The SFMProvider Module looks OK when I check with cimprovider -l -s and -l -m.

The events did not show up on the client with evweb eventviewer -L.

Shinji Teragaito_1
Respected Contributor

Re: sfmconfig -t -<test>

You didn't mention about the OS and SysFaultMgmt version. If you
want to send 5 test events through 'sfmconfig -t' at the SFM diag
mode, you should have SFM 11.23 June 2006 or later, 11.31
September 2007 or later. The following SFM support matrix may
help you understand the current SFM versions:

http://docs.hp.com/en/diag/sfm/sfm_table.htm

NOTE: you can check your diag mode with 'sfmconfig -w -q'. The
SFM diag mode has been the default mode since 11.23/11.31 March
2008.
# sfmconfig -w -q
EMS hardware monitors are disabled & SysFaultMgmt is monitoring devices.
#

Shinji

Re: sfmconfig -t -<test>

Thnaks for your ideas.

I opened a case with the HP support center.
They provided a script that collected a lot of information like swlists, logs, cimprovider and sfmconfig command output, etc.

The output was reviewed by WTEC whom didn't find anything wrong.

They have sent the case to the lab in India for investigation.

FYI, this was HP-UX 11.23. SFM version B.07.00.02.01.

Re: sfmconfig -t -<test>

The support center is still working on a solution.

On a whim I tried a new approach and may have stumbled on a solution.

First, let me say that swverify \* would run completely clean on theie system.

swremove OnlineDiag and SysFaultMgmt

swremoved every WBEM provider I saw in swlist.

shut down cimserver, and killed anything that showed up with ps -ef | grep cim

rm -r /var/opt/wbem /var/opt/sfm
rm -r /var/opt/sfmdb
rm -r /opt/wbem /opt/sfm opt/sfmdb and any /opt/*provider directrory I found.

swinstall -x reinstall=true
-x reinstall_files=true OnlineDiag.

It pulled in WBEMServices as a prereq and rebuilt the repository.

swinstall ProviderDefault vParProvider

swconfig -x reconfigure=true EventMonitoring

swinstall -x reinstall=true -x reinstall_files=true PHSS_39101

swinstall SysFaultMgmt

/opt/sfm/bin/evweb subscribe -L -b external (showed the 5 subscriptions as expected)

cimconfig -s enableSubscriptionsForNonprivilegedUsers=true -p

cimconfig -s enableNamespaceAuthorization=true -p

cimserver -s
cimserver

cimauth -a -u wbem -n root/cimv2 -R -W
cimauth -a -u wbem -n root/PG_InterOp -R -W
cimauth -a -u wbem -n root/PG_Internal -R -W
cimauth -a -u wbem -n root/cimv2/npar -R -W
cimauth -a -u wbem -n root/cimv2/vpar -R -W
cimauth -a -u wbem -n root/cimv2/hpvm -R -W

then I did the usual discovery process from SIM.

After all that,

sfmconfig -t -a showed 5 new events with evweb eventviewer -L
and I got all of the expected emails.

This was on a Unix Admin test system only my group uses, so I felt there was no real harm to be done by trying of all this there.

I usually consider the -x reinstall and -x reconfigure options as potentially harmful and rarely use them.

Anyhow, this worked for me and I thought I'd share it. Use at your own risk ...

Re: sfmconfig -t -<test>

Here's what the response center said:

Problem analysis:
Problem : Events are not received in SFM mode.
How to reproduce :
1) Install any 11.23 bits of Online and SFM( try 0812)
2) Send test events,  so that 4 osel files are created in /var/stm/sfm/oselogs/
3) Remove SFM.
4) Install SFM again.
5) Diagnostics will go into inconsistent state.
6) Event will not be received until.
 
Affected version: All 11i V2, All 11i V3 except 0903 release.
 
Workaround to the solution:
 a) Stop diagnostics
  # cimserver -s
  # /sbin/init.d/diagnostic stop
 b) Remove /opt/sfm/conf/fm_diaglogd_cfg.bin, /var/opt/sfm/conf/fm_diaglogd_cfg.bin.
 c) Start diagnostics
  # cimserver
  # /sbin/init.d/diagnostic start
 
Important Note: Two configuration files has to be kept and  both the files should be in SYNC. If not then again diagnostics will go for toss.
  1) /var/opt/sfm/conf/fm_diaglogd.cfg  for SFM
  2) /opt/sfm/conf/fm_diaglogd.cfg for OnlineDiag
jingping
Occasional Visitor

Re: sfmconfig -t -<test>

Type 4 events is generated on SIM/RSP server by WEBES after WEBSE received the events from the monitored system. So after one go through the fixes mentioned here, if the problem persist (No Type 4 events, but SIM received all other hardware events), check the WBEM setting under EventAnalizer on RSP (Window's BOX). The WEBES uses WBEM to get events from monitor independently from SIM server.

Re: sfmconfig -t -<test>

I am about to open a case with the same issue. I am getting 2 out of 5 events show up from the sfmconfg -t -a in the eventviewer. I was getting none at all and now I get 2 out of 5. This node appears correctly subscribed to WEBES and WBEM, too, but no sign of any emails from the SIM server.

I have approximately 45 servers to migrate off ISEE that range from 11.11, 11.23 to 11.31. I've been working on it for about two weeks now and it's incredibly frustrating. A lot of servers worked great, but then I've got a handful of server that don't work and they all have their own individual pieces that don't seem to work. It's a beat down to think that I've got to open cases on all of them and try to wrangle my way past first level support to get to someone that I can understand and can provide immediate assistance.

HP, this is a huge beatdown. It should have never been made this complex.

Re: sfmconfig -t -<test>

I completely agree with you! HP really missed the mark here. One of about a dozen or more reasons I'm working on convincing management to go blue.

Anyhow, the support center approach that I documented in a previous post worked. Since it is just deleting some files, you can script it and touch all the misbehaving servers pretty quick. I cut and pasted the answer from their post, and the formatting ended up ugly. But the info is good.

Regards,
Clint
Vinod Chitrali
Occasional Visitor

Re: sfmconfig -t -<test>

HI,

"The test events (-m, -p and -b from sfmconfig -t)never show up." One of the reason could be the disk on which /var directory is mounted is nearly full(80% full). Diagnostics products expect that, the disk should have more that 21% /var directory space free.

To resolve this issue please clean up your /var directory.

Please let me know if it helps.

-VInod

Re: sfmconfig -t -<test>

Hello Vinod,

your solution worked.

/var was at 91%. we extended /var so that we were at 66% and now the test events for processor (sfmconfig -t -p), memory (... -m) and backbone (... -b) worked - they did not before.

Thanks a lot !

Regards,

Karsten