Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

11iv2/RP2470/A6795A - HBAs not visible

 
SOLVED
Go to solution
Eric Garbos
Advisor

11iv2/RP2470/A6795A - HBAs not visible

I have an RP2470 system running HPUX 11.23 with the latest patch bundle (Dec05) and two recently installed A6795A fibre HBAs. The system does not appear to see the fibre cards whatsoever... nothing appears in ioscan, no /dev/td# or /dev/fc# files are created, etc.

I've double-checked the relevant FCMS patches I've seen in other threads are included in this (PHKL_30309/PHKL_31501). I've uninstalled and reinstalled the available driver (FibrChanl-00 v11.23.03). I've rebooted repeatedly. I've run "insf -e". Still, no cards.

I'm fairly certain the cards work, as they were taken out of another system that was previously fine. They should be compatible, as they're listed as available options for the RP2470 model.

Can anyone help suggest further troubleshooting steps I can try? At this point I'm beginning to suspect a HW issue in the host. Any and all help would be appreciated.
11 REPLIES 11
Sameer_Nirmal
Honored Contributor

Re: 11iv2/RP2470/A6795A - HBAs not visible

Hi,

Did you try using other PCI slots?

Do you see those card from BCH menu
BCH > IN > IO
Any error in MP > SL > E ?
Do you see anything "NO_HW" or "UNCLAIMED" anywhere in # ioscan -fn ?
dmesg?

Unless there are seen by ioscan under OS OE , the device files won't be created.
Eric Garbos
Advisor

Re: 11iv2/RP2470/A6795A - HBAs not visible

To be honest I'm not 100% certain what you mean RE: the BCH and MP commands... are these in the service processor? I'm not currently near the system and have been working this remotely, but if it comes down to it I may may a trip to the system to check such things, though I have less familiarity with the GSP/HW level than I do with the OS - so a bit more explanation would probably help me a lot!

The cards do not show up as "NO_HW" or "UNCLAIMED" in the ioscan - they simply do not show up at all. I'd paste the command output but I really don't think it helps indicate anything. :)
Eric Garbos
Advisor

Re: 11iv2/RP2470/A6795A - HBAs not visible

By the by... is it possible to move this thread to another forum section? I just realized I somehow posted my question under the Itanium section, but this is a PA-RISC system. (Sorry!)

Re: 11iv2/RP2470/A6795A - HBAs not visible

Eric,

Waht level is the PDC firmware on this server?

It needs to be at least 43.50 for the A6795A cards.

Support matrix is here:

http://docs.hp.com/en/FC_SMdec05/FC_SM.htm

HTH

Duncan

HTH

Duncan
Eric Garbos
Advisor

Re: 11iv2/RP2470/A6795A - HBAs not visible

This may be a phenomenally stupid question, but how can I verify the PDC FW revision on this host? I have access to the GSP, but it reports version C.02.14 (4/14/03), which I don't think is the same thing. I can't get into the ISL (one of the reasons I think the FW rev may indeed be an issue) to do anything there. I don't see any relevant PDC version info go by at boot time, either.

I attempted to load the correct PDC FW version via the available patches, but since this revision is supposedly a prerequisite for 11.23, they don't actually provide a patch that works with 11.23 - only 11.0 and 11.11. Is it sane to force the 11.11 one? Or because it's a prereq for 11.23 should I assume that it's already there and we have another issue?

(Starting to fee lost here...)
Slawomir Gora
Honored Contributor

Re: 11iv2/RP2470/A6795A - HBAs not visible

Hi,
you can check PDC version by cstm,mstm,stm utilty:
echo "selclass qualifier cpu;info;wait;infolog" | cstm | grep PDC

it works on HP-UX 11.0, 11.11 - but I don't know if it works on 11i v2

you can also check PDC version during boot process - is is Firmware Version:

************ EARLY BOOT VFP *************
End of early boot detected
*****************************************

Firmware Version 39.46



Slawomir Gora
Honored Contributor
Solution

Re: 11iv2/RP2470/A6795A - HBAs not visible

Hi,

at this link you have Firmware for A500 (rp2470) 43:50 and all instructions how to check version and update firmware.

This patch PF_CHAW4350 is not OS-Installable

http://www4.itrc.hp.com/service/patch/patchDetail.do?BC=patch.breadcrumb.main|patch.breadcrumb.search|&patchid=PF_CHAW4350&context=firmware:cpu


Sameer_Nirmal
Honored Contributor

Re: 11iv2/RP2470/A6795A - HBAs not visible

Hi,

As per my understanding , the PDC firmware provides boot-up support for this FC HBA. That is why it mentioned in the support matrix. Moreover it is always recommended to have firmware at latest level. You can determine the PDC formware version using methodes given above and upgrade it if required.

As I said before , you need to check if the card apprears at BCH menu.

You should be able to use the HBAs with the current enviornment.

By the way,
What you see LEDs on the cards?
On which PCI slots the cards are installed?
Eric Garbos
Advisor

Re: 11iv2/RP2470/A6795A - HBAs not visible

# echo "selclass qualifier cpu;info;wait;infolog" | cstm | grep PDC
PDC Firmware Revision: 43.24 IODC Revision: 0
----------------- Processor 0 HPMC Information - PDC Version: 43.24 ------
PDC Firmware Revision: 43.24 IODC Revision: 0
----------------- Processor 1 HPMC Information - PDC Version: 43.24 ------

Very nice, that command goes in the ol' notebook. I'll pursue the non-OS patch installation process today and see what I can get.

Also, in response to the question, the cards are installed in PCI slots 1&2, the same as in other similar servers where they work, though I think those are running other OS revisions (could even be updated FW, I don't know). I don't see any lights after the system is booted (not sure if they might flash as they're probed during bootup), which may mean they're bad or just not getting properly initialized, I think.
Eric Garbos
Advisor

Re: 11iv2/RP2470/A6795A - HBAs not visible

"you can also check PDC version during boot process - is is Firmware Version:
************ EARLY BOOT VFP *************
End of early boot detected
*****************************************
Firmware Version 39.46"

This was not showing previously. Nor was the "10 second" message available to break into the boot process. This all was getting masked by errors with the cards installed. After attaching a tape drive (and load the stape module that was disabled) for the firmware update, we ended up having to remove the offending HBAs in order to boot from the tape and perform the update. From there on, things went swimmingly... host is now at FW 43.50, the cards no longer generate those errors during the boot sequence, the cards are initializing properly and showing link lights, and ioscan now correctly sees the cards with appropriate drivers.

Thanks so much to all who helped! This forum site has always been one of the best I've ever referred to, now I can also say one I've participated in. :)
Eric Garbos
Advisor

Re: 11iv2/RP2470/A6795A - HBAs not visible

OS and HBAs installed required updated firmware. Removed HBAs and updated firmware from tape. Reinstalled cards and everything is working nicely. Thanks again to all who helped by posting suggestions and reference links in this thread.