Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot get the EFI Menu

 

Cannot get the EFI Menu

Hi,

I am using a rx2660 HPUX. Machine was working fine with 11i v2. When trying to install v3 initially changed the boot device to Dev 0, later realized I should have used the EFI to use the CD to boot. After using the EFI, to boot from the CD, the console was blank. Did a hard reboot.

Now I am not able to get to the EFI menu at all. The Live Console is just blank.

Any pointers?
When doing it hard boot, it seems to read the CD for a short while, after that does not read the read or the Hard disk at all (the lights just dont blink on the CD or HD).

regards
Manminder
7 REPLIES 7
Steven E. Protter
Exalted Contributor

Re: Cannot get the EFI Menu

Shalom,

Try booting the box without a CD/DVD in the drive.

Since you have set the boot device as the DVD drive this will take you to the EFI menu when the boot fails. The way you went about this install was how you would go about installing Linux or Windows on a PC, its not how we do it with HP-UX

I also can surmise the problem with HP-UX 11.31 is that the systems firmware is not up to date enough for the OS. Check that before attempting to install again.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Cannot get the EFI Menu

Hi,

Thanks for your inputs but it did not work. Even though there is no CD, it did not go into the EFI. Also did not try to read the disks.
The disks had 11i v2 previously installed (i assume its still there).

So still no luck with the EFI menu.

Regards
Manminder
Fabio Ettore
Honored Contributor

Re: Cannot get the EFI Menu

Hi,

I hope you did a backup by Ignite-UX. So I would suggest you to recover 11.23 system from backup.

Best regards,
Fabio
WISH? IMPROVEMENT!

Re: Cannot get the EFI Menu

Hi,

I would like to just reinstall the OS, but I just dont get EFI menu.

Any inputs?

br
Manminder
mits
Respected Contributor

Re: Cannot get the EFI Menu

Do you mean the system will not launch EFI shell even though you select the EFI Shell menu from the boot menu? Or do you mean the system does not show any messages on the console even though you power cycle the system DC power? If you still be able to access MP console, the best is that you will capture the last FPL entries. If the system has launched EFI boot menu or EFI shell, the last FPL entry is EFI_POST_CODE.

Command:
MP> sl -f

FPL:
# Location|Alert| Encoded Field | Data Field | Keyword / Timestamp
-------------------------------------------------------------------------------
4733 SFW 4 0 0x0A0002B904E00000 0000000000000015 EFI_POST_CODE
4732 SFW 4 0 0x1600031804E00000 0000000000000030 EFI_SEC_INIT
4731 SFW 4 1 0x3400020B04E00000 0000000000000006 EFI_LAUNCH_BOOT_MANAGER
4730 SFW 4 0 0x0A0002B904E00000 0000000000000014 EFI_POST_CODE

If you are not able to access MP prompt, there is some cable connection problem or hardware problem. Or you may need to check the console terminal configuration.

Re: Cannot get the EFI Menu

Hi,

I can access the MP menu, but the Live Console does not show any messages.

when i run the sl -f I get the following:
------------------------------------------------------------------------------
1649 MP 0 2 0x5E800A7A00E01520 0000000000000003 MP_SELFTEST_RESULT
20 Mar 2008 08:15:22
1648 SFW 0 0 0x0400008600E00000 FFFFFFFFFF03FF83 IO_LBA_DISCOVERED
1647 SFW 0 0 0x0400008600E00000 FFFFFFFFFF02FF83 IO_LBA_DISCOVERED
1646 SFW 0 0 0x0400008600E00000 FFFFFFFFFF00FF83 IO_LBA_DISCOVERED
1645 SFW 0 1 0x2000008100E00000 0000000000000000 IO_DISCOVERY_START
1644 SFW 0 0 0x160015B200E00000 0000000011474617 BOOT_TIME_EVENT
1643 SFW 0 0 0x03001CB700E00000 0000000000000111 BOOT_NO_NEW_ROM
1642 SFW 0 0 0x000012DD00E00000 0000000000000000 MEM_EARLY_CONFIG_EXIT
1641 SFW 0 0 0x000000EF00E00000 0000000000000000 MEM_TEST_READ
1640 SFW 0 0 0x000000F100E00000 0000000000000000 MEM_TEST_READ_WRITE
1639 SFW 0 0 0x000000F600E00000 0000000000000000 MEM_TEST_WRITE
1638 SFW 0 0 0x000000B800E00000 0000000000000000 MEM_ECC_TEST

br
Manminder
Fabio Ettore
Honored Contributor

Re: Cannot get the EFI Menu

Hi,

I would suggest opening a HW call by HP and ask for a check of Integrity Server.

Best regards,
Fabio
WISH? IMPROVEMENT!