Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Core Cell replacement in rx8620

 
SOLVED
Go to solution
VP_3
Occasional Contributor

Core Cell replacement in rx8620


Hi,

I'm trying to find a way to replace rx8620 core 4x1.5 Ghz cellboard with a new one, 4x1.5 Ghz. Partition consists of two identical cellboards, slots 0 and 2. Firmware level is the same on every cellboard. Everything is working fine.

Now, I want to replace those cellboards and retain the existing partition.
1) Replace (not core) cell is easy -
parmodify -p 0 -d 2 -h 192.. -g password
parmodify -p 0 -a 2:base:y:ri: -h 192.. -g password
2) Core cell replacement is a complicated thing, as Core cell contains Boot menu and paths . When I tried to replace core cell (0) , first I saved (nvrboot.efi) Windows boot options to \efi\microsoft\winnt50\Boot0020

I turned off power , exchange cells , reboot
and all boot menu and paths gone.
Next step was to recreate boot menu and boot options, but strange enough, EFI shell "map" reported, that device table is empty. I repeated "search all" with no result.
EFI showed no blk or fs devices.

Any ideas, what to check?
Is there another way to replace core cell ?

Thanks, VP



2 REPLIES 2
kris rombauts
Honored Contributor
Solution

Re: Core Cell replacement in rx8620

Hi VP,

did you tried the reconnect -r command at EFI shell level ?

Could you specify what your boot controller is, is it the build in SCSI controller or is it a PCI RAID card (SmartArray)?
Also if you load a CD/DVD with a partition that is recognizeable by EFI, does it become visible at all ?


If that does not help, check the FPL and SEL logs and closely watch the boot sequence via the MP VFP and CO commands to see what happens and if no errors are logged.

Also remember (for later) to run the acpiconfig windows command again, you probably have seen a error message about this after replacing the cell and recreating the partition or do a 'default' at EFI and then run 'acpiconfig windows' again.



HTH

Kris





VP_3
Occasional Contributor

Re: Core Cell replacement in rx8620

Thanks, Kris

I did replace old cellboard,
than powered partition
and ran
acpiconfig windows ( reset)
After that EFI > reconnect -r
EFI> map -r
and all partition became visible.
Than I restored paths with nvrboot.efi.
Thank You for Help.