cancel
Showing results for 
Search instead for 
Did you mean: 

EFI troubles

 
SOLVED
Go to solution
Ignite_2
Frequent Advisor

EFI troubles

Hello,

I have to install new server, but when checking devices in EFI, using 'map -r' I see only:

EFI Shell UEFI version 2.00 [14.62]
Device mapping table
blk0 : Acpi(HWP0002,PNP0A03,0)/Pci(2|1)/Usb(0, 0)
blk1 : Acpi(HPQ0002,PNP0A08,400)/Pci(0|0)/Pci(0|0)/Scsi(Pun0,Lun0)

There are missing fs0, fs1... I've tried to find them, but EFI doesn't recognize 'search' command.

Can you please advise?

Thanks.
7 REPLIES 7
Torsten.
Acclaimed Contributor
Solution

Re: EFI troubles

You did not tell so many details, but it looks like your disk(s) are blank.

Maybe you have a RAID controller and need to configure this.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Ignite_2
Frequent Advisor

Re: EFI troubles

Sorry for missing details. We have received 2x rx2600 and technician has setup MP connection. Now I need to install HP-UX from ignite.

On one server I have following output:

Shell> map -r
Device mapping table
fs0 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C50005BF50A1,Lun0)/HD(Part1,Sig4A25D234-6BDE-11DE-8000-D6217B60E588)
fs1 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C50005BF50A1,Lun0)/HD(Part3,Sig4A25D284-6BDE-11DE-8000-D6217B60E588)
blk0 : Acpi(HWP0002,PNP0A03,0)/Pci(2|1)/Usb(0, 0)
blk1 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C50005BF3D45,Lun0)
blk2 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C50005BF50A1,Lun0)
blk3 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C50005BF50A1,Lun0)/HD(Part1,Sig4A25D234-6BDE-11DE-8000-D6217B60E588)
blk4 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C50005BF50A1,Lun0)/HD(Part2,Sig4A25D270-6BDE-11DE-8000-D6217B60E588)
blk5 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr5000C50005BF50A1,Lun0)/HD(Part3,Sig4A25D284-6BDE-11DE-8000-D6217B60E588)

On second following:

Shell> map -r
Device mapping table
blk0 : Acpi(HWP0002,PNP0A03,0)/Pci(2|1)/Usb(0, 0)
blk1 : Acpi(HPQ0002,PNP0A08,400)/Pci(0|0)/Pci(0|0)/Scsi(Pun0,Lun0)

Do I have to add manually missing devices?
Torsten.
Acclaimed Contributor

Re: EFI troubles

Please post output of

Shell> devices

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Ignite_2
Frequent Advisor

Re: EFI troubles

Shell> devices
C T D
T Y C I
R P F A
L E G G #P #D #C Device Name
== = = = == == == =============================================================
10 R - - - 1 7 Acpi(HWP0002,PNP0A03,0)
11 R - - - 1 3 Acpi(HWP0002,PNP0A03,200)
12 R - - - 1 1 Acpi(HPQ0002,PNP0A08,300)
13 R - - - 1 2 Acpi(HPQ0002,PNP0A08,400)
14 R - - - 1 - Acpi(HWP0002,PNP0A03,600)
15 R - - - 1 1 Acpi(HPQ0002,PNP0A08,700)
1A D - - 1 - - Acpi(HWP0002,PNP0A03,0)/Pci(1|0)
1B D - - 1 - - Acpi(HWP0002,PNP0A03,0)/Pci(1|1)
1C B - - 1 1 1 Acpi(HWP0002,PNP0A03,0)/Pci(1|2)
1D B - - 1 2 2 Usb Open Host Controller
1E B - - 1 2 1 Usb Open Host Controller
1F D - - 1 - - Acpi(HWP0002,PNP0A03,0)/Pci(2|2)
20 B - - 1 5 2 Acpi(HWP0002,PNP0A03,0)/Pci(3|0)
22 D X X 1 2 - LSI Logic SAS Controller
23 B X X 1 1 1 Acpi(HWP0002,PNP0A03,200)/Pci(2|0)
24 B X X 1 1 1 Acpi(HWP0002,PNP0A03,200)/Pci(2|1)
25 D - - 1 - - Acpi(HPQ0002,PNP0A08,300)/Pci(0|0)
27 D - - 1 - - Acpi(HPQ0002,PNP0A08,400)/Pci(0|0)
28 B - - 1 1 1 Smart Array P400 Controller
29 D - - 1 - - Acpi(HPQ0002,PNP0A08,700)/Pci(0|0)
3B D - - 2 - - Primary Standard Error Device
3C D - - 2 - - Primary Console Input Device
3D D - - 2 - - Primary Console Output Device
42 B - - 1 1 1 16550 Serial UART
43 B - - 1 5 3 VT-100+ Serial Console
44 B X - 1 3 1 Generic Usb Keyboard
45 D - - 1 - - Acpi(HWP0002,PNP0A03,0)/Pci(2|0)/Usb(0, 1)
46 D - - 1 3 - Usb Bot Mass Storage
65 D X X 1 3 - Broadcom NetXtreme Gigabit Ethernet (BCM5704)
66 D X X 1 3 - Broadcom NetXtreme Gigabit Ethernet (BCM5704)
67 D - - 1 1 - Acpi(HPQ0002,PNP0A08,400)/Pci(0|0)/Pci(0|0)/Scsi(Pun0,Lun0)
Torsten.
Acclaimed Contributor

Re: EFI troubles

You have a smart array controller installed:

Smart Array P400 Controller

During boot, press

ESC 8 (serial connection)

or

F8 (VGA)

to configure via ORCA.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Ignite_2
Frequent Advisor

Re: EFI troubles

Thanks... It seems now I'm in configuration menu. Don't you know about some guide, how to proceed here? I have attached what I see now.

From here I can make internal disks visible for EFI?
Torsten.
Acclaimed Contributor

Re: EFI troubles

see

http://docs.hp.com/en/J6369-90075/ch03s03.html

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!