Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Entering EFI shell.

 
V.S.Abhijith.
Occasional Advisor

Entering EFI shell.

Hi ,

I would like to know how I can enter efi shell directly , ie by passing Efi Boot Manager.If this is not possible how I can force boot process on an itanium system to go to efi shell without user intervention.

Thanks ,
- Abhijit.
4 REPLIES 4
Steven E. Protter
Exalted Contributor

Re: Entering EFI shell.

Shalom,

To get EFI, destroy the operating system. If it can't boot, it will go to EFI.

As far as further automation than that, IA-64 Itanium servers were not designed for automated EFI operations. They are designed to use EFI to manually configure the system.

http://www.docs.hp.com/en/B2355-60130/hpux.efi.1M.html

http://docs.hp.com/en/2394/unitedlinuxSupportNote032803.pdf

http://docs.hp.com/en/5187-2286/5187-2286.pdf

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Steven Schweda
Honored Contributor

Re: Entering EFI shell.

On my zx2000, I could do it by going into
Boot Option Maintenance Menu
Change Boot Order
and moving
EFI Shell [Built-in]
to the top of the list.


> To get EFI, destroy the operating system.

That seems a bit harsh. And unnecessary.

EFI Boot Manager ver 1.10 [14.61] Firmware ver 2.31 [4411]

Please select a boot option

EFI Shell [Built-in]
OpenVMS on DKA0: PKA0.0
HP-UX Primary Boot: 0/3/1/1.0x0.0x0
network boot
cdrom
Boot Option Maintenance Menu
System Configuration Menu


Use ^ and v to change option(s). Use Enter to select an option

(But I prefer:

OpenVMS on DKA0: PKA0.0
HP-UX Primary Boot: 0/3/1/1.0x0.0x0
EFI Shell [Built-in]
[...])
Jozef_Novak
Respected Contributor

Re: Entering EFI shell.

Hello,

you can disable autoboot in the operating system. The boot process should end up in the EFI shell then.

J.
V.S.Abhijith.
Occasional Advisor

Re: Entering EFI shell.

Thanks for your reply. Disabling Autoboot helped.