Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

HPUX 11.23 (Mar 2006) or OpenVMS 8.2.1 on rx1600 ?

 
Arthur Barrett_4
Occasional Contributor

HPUX 11.23 (Mar 2006) or OpenVMS 8.2.1 on rx1600 ?

Hi all!

Hoping someone can shed some light n some odd installation problems with HPUX and OpenVMS on an rx1600.

I can install RHEL 4, and HPUX 11.23 (Mar 2004) fine on this box, but whenever I try to install a more recent HPUX 11.23 (eg: Mar 2006, or even Sep 2004) the disk(s) are not recognised.

The rx1600 has 1Gb ram, Management processor and the latest firmware I can find:
System Firmware: 2.18 [4511]
BMC Version: 3.48
MP Version: E.03.15

I have tried a variety of internal SCSI U320 disks, including 2x73Gb 15KRPM and 1x36Gb 10KRPM but they all exhibit the same behaviour.

The only thing I've been able to think of is perhaps the internal controller is not supported for recent HPUX - but that seems a little odd. The internal SCSI controller firmware and EFI driver are only updatable with the system firmware - which is currently:
ROM Firmware Version: 1.03.35.65
EFI Driver Version: 1.04.02.00

I see various mentions of ROM Firmware Version: 1.03.35.69 and EFI Driver Version: 1.05.01.00, but I have not been able to find these for except for the "external" A7173A controller. These EFI driver and ROM firmware do not seem to be included in any system firmware for the rx1600.

Is it simply that the rx1600 cannot be upgraded to recent HPUX or OpenVMS? Or am I simply missing some recent update?

I also tried installing Mar 2004 HPUX 11.23 then "upgrading" to the Mar 2006 release - but that hangs/panics on reboot because it can't mount the root partition (presumably because it can't find the disk).

The system firmware recognises the presence of the SCSI disks at all times....

Any help appreciated!

1 REPLY 1
Arthur Barrett_4
Occasional Contributor

Re: HPUX 11.23 (Mar 2006) or OpenVMS 8.2.1 on rx1600 ?

Well as unlikely as I thought it was from the symptoms - this ended up being a hardware problem.

Taking a really really close look at the internal wiring, I noticed that the connector from the motherboard to the SCSI pluggable daughterboard at the front of the rx1600 was not 100% square. Getting my fingers in there was tricky but when I was able to apply enough pressure - sure enough it moved a fraction and was now "square".

Rebooting I immediately noticed that the reported speed of the disks at boot time had changed from:
Scsi(Pun0,Lun0) HP 73.4GST373453LC HPC7 ( 40 MBytes/sec)
Scsi(Pun1,Lun0) HP 73.4GST373453LC HPC7 ( 40 MBytes/sec)

to:
Scsi(Pun0,Lun0) HP 73.4GST373453LC HPC7 ( 80 MBytes/sec)
Scsi(Pun1,Lun0) HP 73.4GST373453LC HPC7 ( 80 MBytes/sec)


And booting off the March 2006 HPUX 11.23 DVD immediatly discovered the disk hardware.

Presumably something in the driver between June 2004 and Sep 2004 did change and no longer was tolerant of this drop in IO speed. The software problem did lead to the discovery of the hardware problem though, wheras otherwise we may have just complained about the IO speed...

I hope this information helps someone else in the future - I sure spent enough time going around in circles about it!