Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

MP Console not responding

 
SOLVED
Go to solution
Jayan Nair
Frequent Advisor

MP Console not responding

Hi,

I have HP Itanium rx2620 with OS 11.23.

I can not use console display from the MP. It looks like session is hung.
I have attached screen shot of MP>co

I can open a session using KVM switch, but there i am getting

"X-Server cannot be started on display. For details look in the file, Dt login.errorLoffile( default:/var/dt/Xerrors)
**********************************************************

Suspending Desktop login
Desktop login will resume shortely after your logout."

The MP menu is functioning fine.
I have tried ctr L and ctr z but no response at MP console

Thanks
Jayan


19 REPLIES 19
Gokul Chandola
Trusted Contributor

Re: MP Console not responding

Hi,

Use telnet to MP or LAN ip of server, if you are getting success then good.
Otherwiase you have to restart Hard Reboot.

Regards,
Gokul Chandola
There is always some scope for improvment.
Jayan Nair
Frequent Advisor

Re: MP Console not responding

I have followed instructions from the thread
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1249358
, but it doesn't help me.

Thanks
Jayan
Jayan Nair
Frequent Advisor

Re: MP Console not responding

Hi Gokul Thanks for the replay

I am not able to assign MP ip so i cant telnet to MP.
Telnet is disabled so I can't login to LAN.
I have hard rebooted also, but same status.
Have attached MP LAN status

Jayan
SKR_1
Trusted Contributor
Solution

Re: MP Console not responding

Your server is up right now or not. If yes and MP console is not working you may need to take the reboot of the server.

And if your server is down or got hand in between booting process then go to MP> CM> RS. Reset the partition and check.

If no luck after this, register an hardware case with HP.

Thanks

SKR
Jayan Nair
Frequent Advisor

Re: MP Console not responding

Hi
Server is up. I have rebooted again, but same status.


Thanks
Jayan
Ninad_1
Honored Contributor

Re: MP Console not responding

Hi,

From the output of lc at the CM prompt - it shows DHCP enabled.
If you want to give static ip address, subnet mask and default gateway to your MP console then can you try disabling the DHCP and then see if it allows you to assign an ip address.
Please check with your Network admin for the details of the ip,subnetmask and default gateway.

Regards,
Ninad
Jayan Nair
Frequent Advisor

Re: MP Console not responding

Thanks Ninad,
I Assigned Mp IP.
But not able to connect MP by telnet.

Ninad_1
Honored Contributor

Re: MP Console not responding

Hi Jayan,

Let us first try to understand the problem.
Please confirm on the below points
1. Your server is up and running - so there is no problem on that front.
2. You want to be able to telnet the MP console and this is what you are not able to do.

Is there any other problem that we are missing out ?

You not being able to telnet to MP console IP address - there could be several reasons.
First let us understand from where you are trying to telnet.
Is the machine from which you are trying to telnet on the same subnet as the MP console IP address ?
If yes
Does telnet to some other machine work ?
Is telnet disabled ?
If no - (machine from which you are issuing the telnet tp MP console, and the MP console IP address are not in same subnet)
Is the subnet mask and default gateway on the MP console and the machine correctly configured ?

Are you able to ping the MP console IP address from your machine ?

Regards,
Ninad
Jayan Nair
Frequent Advisor

Re: MP Console not responding

Hi Ninad,
Server is up.
Remote MP login only through telnet.
Telnet is disabled to LAN ip.
Can able to ping to LAN ip, but can not connect to using SSH.
I am trying to telnet from my laptop, at network level routing has done different network is not a problem ( I can connect to other servers of different network).
Not able to ping to MP IP( I can ping MP ip of others HP machine of same network).
I have connected to MP console using usb serial cable
MP menu is working fine.
at console prompt it is stucked.
screent shoot attached.
I have opened a session using KVM switch but there not able to login and the message is
"X-Server cannot be started on display. For details look in the file, Dt login.errorLoffile( default:/var/dt/Xerrors)
**********************************************************

Suspending Desktop login
Desktop login will resume shortely after your logout."

Thanks
Jayan
SKR_1
Trusted Contributor

Re: MP Console not responding

Have you assigned the subnet and gateway also?

Are you able to telnet server primary main IP?

Thanks

SKR
Jayan Nair
Frequent Advisor

Re: MP Console not responding

Hi
subnet, g/w is ok
But cann't telnet MP IP
ssh to LAN IP
Aneesh Mohan
Honored Contributor

Re: MP Console not responding

Hi Jayan,

I suspect the display output configuration for your system console is in VGA port,if you want to acces HPUX through the MP console using the enabled protocol like ssh/telnet then it should be in serial port.

You may need to re-define the devices that display output from the system console.

Please have the following link ,it will explain you clearly.

http://docs.hp.com/en/AD117-9003A/apcs04.html


Aneesh
Gokul Chandola
Trusted Contributor

Re: MP Console not responding

Hi
***subnet, g/w is ok
But cann't telnet MP IP
ssh to LAN IP***

This mean you are able to telnet ip.
Ok
Now you want to Display on monitor. Yes you are not getting.
Due to illegal shutdown this happen.

From telnet

#cd /sbin/init.d
# ./dtlogin.rc start

Now you restart your machine,
you will get normal bootup not Text mode.

If you lan IP are ok. Otherwise you will not get Display.

ifconfig lan0 up (if not working lan0)

For ip assigning...

#ifconfig lan0 192.168.1.X(or you machine ip) netmask 255.255.255.0(subnetmask)


Regards,
Gokul Chandola
There is always some scope for improvment.
Gokul Chandola
Trusted Contributor

Re: MP Console not responding

Hi,
not hard reboot.

#shutdown -hy

If problem solve Points are welcome.

Regards,
Gokul Chandola
There is always some scope for improvment.
Ninad_1
Honored Contributor

Re: MP Console not responding

Hi,

Please go thru the document
HP Integrity and HP 9000: iLO MP Operations Guide for rx2620
http://docs.hp.com/en/5991-6006/index.html

I assume you have connected the MP console lan cable to your LAN switch correctly and the VLAN configuration if any on the LAN swicth is correct.

One thing I did not understand is you said that telnet is disabled, whereas you also said that you are able to telnet to console of other servers.

Regards,
Ninad
Ninad_1
Honored Contributor

Re: MP Console not responding

Hi,

From the link I provided to you, it seems that you need the iLO MP Advanced Pack License to be able to use ssh.

Thus if as you say telnet is disabled, and you have to use ssh, then you would need this license.

But as I have put, I still did not understand where is telnet disabled ? if you are able to telnet other consoles and server ip addresses.

Regards,
Ninad
Jayan Nair
Frequent Advisor

Re: MP Console not responding

Hi Anish,
Could you please be more specific how to do it.

Ninand
telnet is enabled only for remote MP login.
For LAN ip telnet is disabled.

Thanks
Jayan
Aneesh Mohan
Honored Contributor

Re: MP Console not responding

Hi jayan,

1) Acees the MP console window and keep it open (as u said u can acces through ssh or also u can direct connect to the serial port with the laptop)

2) Reboot the server ( from normal telnet window to the server )
#shutdown -ry 0

3)While rebooting interrupt autoboot using the MP console.

4) Using the Boot Menu ,select Console configuration

5) Use this option to define the devices that display output from the system console. This list normally includes the VGA monitor and a serial port for directing output to a terminal emulation package.

6) Select ILO MP Serial Console
Acpi(HWP0002,700)/Pci(1|0)/Uart(9600 N81)/VenMsg(Vt100+)

7) When changing serial devices, changes must be made to Output, Input, and Error menus for proper operation.
8) Save and reset the system

Regds,
Aneesh

Re: MP Console not responding

You cant telnet to MP to access the co since your output already set to VGA. So follow Aneesh Mohan steps, you should be able to access through serial cable.

As for X-Server error, try to check setting under /etc/dt/config/Xserver and remove '#' if exist. Then go to /sbin/init.d, stop and start the dtlogin, ./dtlogin.rc stop and ./dtlogin.rc start. If still fail, try to check your dns and hostname, make sure there are correct.