Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

New RX7640, boot install

 
wurzul
Frequent Advisor

New RX7640, boot install

I am trying to get a newly installed RX7640 to boot from Ethernet using EFI:

EFI Boot Maintenance Manager ver 2.00 [14.62]

Boot From a File. Select a Volume

Removable Media Boot [Acpi(HWP0002,PNP0A03,100)/Pci(3|1)/Scsi(Pu
Load File [Acpi(HWP0002,PNP0A03,101)/Pci(1|0)/Pci(6|0)/Mac(00248
Load File [Acpi(HWP0002,PNP0A03,101)/Pci(1|0)/Pci(6|1)/Mac(00248
Load File [EFI Shell [Built-in]]
Exit

How can I tell which physical port on the rear of the server I need to plug my cable into?

doing an 'info io' from efi I get

I/O MODULE INFORMATION

I/O Starting
Cell Cab/Bay/ PCI Seg/ Current
Cab/ Chassis/ Bus/Dev Current Peak I/O
Cell Slot Slot (hex) Bus Mode Bandwidth Slot State
---- ---- -------- -------- ---------- --------- ------------
1 0/1 0/0/1/C1 01/00/01 PCI-X 66 533 MB/s Active
1 0/1 0/0/1/1 01/8C/01 PCI-X 133 1.06 GB/s Active
1 0/1 0/0/1/2 01/A9/01 PCI-X 133 1.06 GB/s Active
1 0/1 0/0/1/3 01/C6/00 PCIe x8 2.13 GB/s Unpopulated
1 0/1 0/0/1/4 01/E3/00 PCIe x8 2.13 GB/s Unpopulated
1 0/1 0/0/1/5 01/70/00 PCIe x8 2.13 GB/s Unpopulated
1 0/1 0/0/1/6 01/54/00 PCIe x8 2.13 GB/s Unpopulated
1 0/1 0/0/1/7 01/38/01 PCI-X 133 1.06 GB/s Unpopulated
1 0/1 0/0/1/8 01/1C/01 PCI-X 133 533 MB/s Active

0 0/0 0/0/0/C0 00/00/01 PCI-X 133 533 MB/s Unpopulated
0 0/0 0/0/0/1 00/8C/01 PCI-X 133 1.06 GB/s Active
0 0/0 0/0/0/2 00/A9/01 PCI-X 133 1.06 GB/s Active
0 0/0 0/0/0/3 00/C6/00 PCIe x8 2.13 GB/s Unpopulated
0 0/0 0/0/0/4 00/E3/00 PCIe x8 2.13 GB/s Unpopulated
0 0/0 0/0/0/5 00/70/00 PCIe x8 2.13 GB/s Unpopulated
0 0/0 0/0/0/6 00/54/00 PCIe x8 2.13 GB/s Unpopulated
0 0/0 0/0/0/7 00/38/01 PCI-X 133 1.06 GB/s Unpopulated
0 0/0 0/0/0/8 00/1C/01 PCI 66 533 MB/s Active

hope this make sense

Please request any more info if you need it.

Many thanks


5 REPLIES 5
Turgay Cavdar
Honored Contributor

Re: New RX7640, boot install

Hi,
What i write below is adaptation from rx8640, i believe it is also valid for rx7640. Lets say that you connect a cable to cell 1 slot3. Look at ACPI part when you say "lanboot select" at the efi, 10C is your card to boot...

Cell PCI-Slot ACPI Path
"0" 1 Acpi(8) 0/0/8/1
2 Acpi(A) 0/0/10/1
3 Acpi(C) 0/0/12/1
4 Acpi(E) 0/0/14/1
5 Acpi(6) 0/0/6/1
6 Acpi(4) 0/0/4/1
7 Acpi(2) 0/0/2/1
8 Acpi(1) 0/0/1/1

Cell PCI-Slot ACPI Path
"1" 1 Acpi(108) 1/0/8/1
2 Acpi(10A) 1/0/10/1
3 Acpi(10C) 1/0/12/1
4 Acpi(10E) 1/0/14/1
5 Acpi(106) 1/0/6/1
6 Acpi(104) 1/0/4/1
7 Acpi(102) 1/0/2/1
8 Acpi(101) 1/0/1/1
Steven E. Protter
Exalted Contributor

Re: New RX7640, boot install

Shalom,

At this point you can wire any of the lan ports on the system.

if this is on the same lan as an Ignite server, you can even boot to a recovery shell, without benefit of a local disk.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
wurzul
Frequent Advisor

Re: New RX7640, boot install

OK Thanks but I'm still confused.

Where do I look for the 10c in the below EFI output?

Load File [Acpi(HWP0002,PNP0A03,101)/Pci(1|0)/Pci(6|0)/Mac(00248

Turgay Cavdar
Honored Contributor

Re: New RX7640, boot install

What ypu wrote is: Load File [Acpi(HWP0002,PNP0A03,101)/Pci(1|0)/Pci(6|0). After PNP there is comma then "101" which means in my previous table:slot8 of cell1.
wurzul
Frequent Advisor

Re: New RX7640, boot install

Excellent, that worked a treat.

Points all round!

Many Thanks to all who replied !