Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Not Found in EFI

 
Youngmin
Advisor

Not Found in EFI

Hi, guys

I had service Linux on IA-64
(Redhat AS 2.1)

I just got message in EFI after reboot
that is "Redhat server... NOT Found"

I tried to any menu in EFI Shell.
load DVD/Disket but I got that error message.

Also, I tried to select another menu in Boot Option Maintenance Menu.

but I got same messages in anytime
"....image NOT Found"

event I googled but I didn't any solution about EFI

What should I do?
actually, I have another clone.
Is there any solution using this clone?
(there are Oracle RAC machine)

Please Your Reply..Thanks
2 REPLIES 2
Stefan Stechemesser
Honored Contributor

Re: Not Found in EFI

The message simply means that the bootfile (normaly elilo.efi) specified in this bootoption is no longer available (or the path to it has changed).
You can view youre bootoption by entering the EFI Shell and enter

bcfg boot dump

you can see a list of available EFI filesystems with the command

map

Sometimes you have to specify
reconnect -r
map -r

if, f.e. your EFI bootpartition is on a FC lun or a Smartarray lun.

You can manually boot linux by going to the EFI filesystem

(f.e. enter "fs1:" to change to filesystem fs1)

and look if there is a \efi\redhat\elilo.efi
(use the EFI commands similar to MSDOS (cd, dir))

if yes, then try booting manually by simply entering "elilo"

If all this works fine, then you can manually create a working boot entry with either the boot options maintenance menu or else manually with the commandline tool bcfg
("help bcfg" in EFI shell).

best regards

Stefan
Youngmin
Advisor

Re: Not Found in EFI

Thanks, your reply

i'm sorry.
I tried to that.
i tried to view boot list then
i selected all of them.

but all of boot list failed.

I always met same messages

"NOT FOUND"

actually i'm considering crashed EFI filesystem because apeared error message
during boot
It is
"Warning: ReadBlocks: Adapter #0 LDrv #0: Logical Read FAILed: Status=0x1"

so i am finding information relative with recovery EFI too.

Could you tell me any solution.

thank you for reply..