Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem contactig MP boards

 
Turro
Occasional Contributor

Problem contactig MP boards

Hi,
We have a cluster of 100 HP rx2006, and we have some trouble using their management boards : They stop responding to telnet and http access randomly.
The firmware version we are using currently is E.02.23 ... Is anybody encountering the same problem ?

PS: the boards are connected to a dedicated VLAN.
6 REPLIES 6
kris rombauts
Honored Contributor

Re: Problem contactig MP boards

Hello Turro,

you could first try to update some of those RX2600 to the latest version maybe and then monitor if they still face the same problem.

Do you have any other systems (i mean non RX2600 MP cards) in that same VLAN that also use telnet or http and how do those behave ? The problem is maybe not due to the MP cards at all if they all show somehow the same issue.

What do you do to fix this ? reset the MP ?


Here is the latest E.02.26:

http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=88839&locale=en_US&taskId=135&prodSeriesId=88837&prodTypeId=15351&swEnvOID=54

HTH

Kris
Turro
Occasional Contributor

Re: Problem contactig MP boards

I upgraded to E.02.26 today, but i cannot notice any improvement :
Suppose i reset all the MP boards, and then telnet them every 2 minutes.
Everything is ok for about 30 minutes, but after those 30 minutes, the boards stop responding to telnet accesses.
Eventually some board will comme back randomly, and then go down again (telnet-wise).
When a MP board doesn't answer to telnet, it still answer to pings, but if i try to ping something FROM the MP board (using the serial console, CM->XD->L ...) i get a FAIL and NO packet go out of the MP board (i checked the packet counters on the switch they are attached to).
Any help ?
Is there any documentation available for those MP boards ? There are several parameters (timeouts) i could tune if i had a precise description of their signification (the 'inline' help is not very clear).

Thank Your for your help

Nicolas

Re: Problem contactig MP boards

Hi Nicolas,

Can you provide some more information on how your network is set up?

1)What sort of switches (model and vendor) are attached to the MP ports?
2)How many switches? Are you getting similar problems on multiple switches? Any systems connected without switches (e.g. via hubs)if so, are they experiencing similar problems?
3)Does the MPs RESET command (XD R) command clear up the issue (at least temporarily) on a hung MP port?
4)At the time of the MP hang what is the output of the LS command? The SA command?
5)When the MP is hung, is there any problem with any other MP functionality (e.g. local console access, SWC access, CM access, etc.)?
6)Any unusual System Event Log or Forward Progress Log events associated with the hung MPs?
7)What sort of telnet client and/or HTTP: client are you using to ping the MPs?
8)Have you been experiencing this problem since initial installation of the systems? If not, what (if anything) may have changed just prior to the first instance of this problem?

Eric

Re: Problem contactig MP boards

Hi Nicholas,

Some other places to try to figure out what is happening:

When the telnet console is hung what output do you get from these commands:

1) IF : Displays network interface information.
2) LS : Display LAN connected console status.
3) DI : DIsconnect remote/modem or LAN console and then tries to connect with telnet again do they get connected again.
4) DL : Disable Lan console access and.
EL : Enable Lan console access.

When you are able to connect using telnet.
5) Do you have SSL enabled on these system?

Eric
Turro
Occasional Contributor

Re: Problem contactig MP boards

Hi Eric :

1) All the MP boards are attached to HP procurve 2524 J4813A (in 100MBits/Full autonegociated, 10/Half doesn't get better results. The 2524 all have a Gigabit uplink to a HP procurve 4104gl with Gigabit modules. The monitoring host is attached to one of the Gigabit switch's port (but whith a 100 Mbit interface). I cannot see any errors on the involved ports.

2) We have 5 switches dedicated for the MP boards, all behave the same way.
I don't have any hubs on hand.

3) The XD R command DOES clear up the issue for 30 minutes

4) LS and SA are 'normal' while the MP Board doesn't respond :

[mg1] MP:CM> ls


LS

Current LAN Configuration:
MAC Address : 0x00306e3929e8
IP Address : 10.1.200.1
MP Host Name : mg1
Subnet Mask : 255.255.255.0
Gateway Address : 10.1.200.110
Link State : Auto Negotiate
Web Console Port Number : 2030

LAN status: UP and RUNNING
[mg1] MP:CM> SA


SA

This command allows you to enable/disable access to the MP.

Current Set Access Configuration:
R - Remote/Modem Port : OS SESSION
T - LAN Telnet Port : Enabled
W - LAN Web Port : Enabled


5 ) everything seems to work ok except LAN access

6) Nope

7) various : telnet command (Linux), Perl telnet implementation, wget... all behave the same.

8) I am not sure, maybe things got worse after E.02.10 -> E.02.23 firmware upgrade.


---

1) if ? could not find this one..
2) same as 4) above
3) tried this, but no change
4) tried this, but no change
5) SSL is not enabled.

Hope you can find anything, be cause we are really stuck with those 100 bi-itaniums :-(

Nicolas

Re: Problem contactig MP boards

Hi Nicolas,

Is there anyway to contact you directly?? Is there an eMail address or phone number you can be contacted at??

I can be contacted at ericwats@hotmail.com.

Eric