Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem during MP Firmware upgrade (downgrade in fact)

 
Turro
Occasional Contributor

Problem during MP Firmware upgrade (downgrade in fact)


Hi,

I tried to downgrade the MP firmware of one of my rx2600 MP board from E.02.26 to E.02.10 and things got bad :

During the process, the board 'lost' ftp conectivity (this was the reason i wanted to perform the upgrade) :
---------------------------------
New Firmware Upgrade Parameters:
* I - Source IP : 10.1.200.110
* P - File Path : /Updates/MP-E.02.10
* L - Login : anonymous
* W - Password : anonymous

Enter Parameter(s) to revise, Y to confirm, or [Q] to Quit: y
y


-> MP firmware upgrade in progress....

-> Retrieving upgrade file using FTP.

-> Retrieved an upgrade file successfully.
Programming ROM. Percent Complete: 100.

-> Retrieving upgrade file using FTP.


-> Could not find upgrade file set on source system.


-> MP firmware upgrade was not successful.
-> Check parameters and try again.

-----------------------------
So some file were flashed, but some others did not.
At this point, i could not gain net connectivity anymore, so i reseted the MP board and it 'booted' in E.02.10

Everything seems to work, but i cannot upgrade the firmware anymore ! The ftp process hangs after/during the first file :

-------------------------------------

MP Firmware Upgrade Parameters:
Source IP: 10.1.200.110
File Path: /Updates/MP-E.02.26
Login: anonymous / MP@hp.com

Confirm? (Y/[N]): y
y


-> MP firmware upgrade in progress....
-----------------------------------------

Using network traces, i can see that the file mp_upg.cnf file has been downloaded (its 201 bytes sent thru FTP-DATA), but then, the process hangs : a ftpd process serving this file remains on the server, and the MP board doesn't proceed to the next file.

Is there something i can do ? Or my MP board will remain in E.02.10 forever ?

Nicolas
2 REPLIES 2
flink
Occasional Visitor

Re: Problem during MP Firmware upgrade (downgrade in fact)

UP

Same problem..
Marco Hogeveen_1
Trusted Contributor

Re: Problem during MP Firmware upgrade (downgrade in fact)

Hi Nicolas,

I've experienced the same problem in the past and it was caused by a timeout setting on the ftp server for anonymous access.
If that doesn't fix it you can try to reset the MP or remove power from the server for at least 30 seconds to clear it.
When you managed to upgrade to E.02.26 there are alternate ways to upgrade the MP firmware.
In the old days you could only do it from an ftp server. But nowadays you can run an EFI file or create a bootable CD-Rom from an ISO image.
HP recently release E.03.13 MP Firmware which solved many issues and changed the web-based look and feel to the ILO of Proliant servers.

However you cannot upgrade in step from E.02.10 to E.03.13, you need to go to E.02.26 first and then to E.02.29.

If your system is still covered by some kidn of support contract or factory warranty you could ask HP to replace the MP card.

Hope it works, otherwise just let me know.

Marco.