Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

SLES 10 SP1 Smart Setup CD on rx2600

 
imf_admin
Occasional Advisor

SLES 10 SP1 Smart Setup CD on rx2600

Hello HP hardware experts!

I want to install Suse Linux Ent. Server SP1 on a rx2600 Itanium machine. I downloaded the latest release of the Smart Setup CD (SmartSetup-4.9.6.iso) to start the installation. When I boot the machine with this CD I get the error that the hardware is not supported. I tried to solve this problem by downloading a older version of the CD (SmartSetup-4.8.4.iso) which
I found under the support and driver section for the rx2600 on the HP webpage. But this CD produces the same error on the server. I want to mention that the firmware of the server is a rather old one (2.01). Do I have to upgrade the firmware first to get one of the Linux Setup CD's running? I read another thread in this forum that I first need to go to version 2.10 because no direct upgrade to the latest version is possible. The oldest firmware I can find on the HP page (ISO-image version) is version 2.31. EFI images are more or less useless for me because I cannot access the DVD-Rom.
I tried a few times with the reconnect -r and map -r commands to get the drive working but had no success. Only thing that worked was adding a boot entry to boot from a CD. Any ideas how to overcome those problems?

Thanks for your answers!

Bye, imf_admin.
15 REPLIES 15
Phil uk
Honored Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Hi,

You could possibly try as an alternative the EFI images and use a Memory stick instead of the ISO images,


MP (Management) firmware here
(NOTE THAT THIS IS THE FTP VERSION):
Read the release notes for the upgrade paths - You indeed cannot do one big jump.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=2512013&swItem=ux-32412-1&prodNameId=1828449&swEnvOID=54&swLang=13&taskId=135&mode=4&idx=0

CAUTIONS:
1 - If the currently installed firmware is older than E.02.10 then updating to MP firmware revision E.02.29 requires updating to E.02.10 first.
2 - Upgrades to MP firmware beyond E.02.26 will require updating to MP firmware revision E.02.26 first.

Sys,BMC firmware etc- older versions listed further down page:
(read the release notes for the upgrade paths as applicable)

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=447335&swItem=ux-46489-1&prodNameId=88839&swEnvOID=54&swLang=13&taskId=135&mode=5

Your version of SmartSetup looks correct-perhaps updating the firmware will help resolve the problem.

Regards,
Phil
Phil uk
Honored Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Sorry,

I missed off the E.02.26 MP link which you may need as a "stepping stone" upgrade.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=2512013&prodNameId=1828449&swEnvOID=54&swLang=13&taskId=135&swItem=ux-32407-1&mode=3

As a tip, have a look at the release notes and revision history tabs - they sometimes have links to the older versions of firmware.

Cheers,
Phil
Torsten.
Acclaimed Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Please post also

EFI> info all

so we can have a look and check.
I have already seen problems with the servers model name producing strange behaviour.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
imf_admin
Occasional Advisor

Re: SLES 10 SP1 Smart Setup CD on rx2600

I typed in:

EFI> info all -b

and I get after the date line:

Manufacturer: hp
Product Name: server rx2600
Product Number: A6870AR
Serial Number: DE40700075

It's only the first part of the whole output because I don't have any network connection to the machine. Is it possible in the EFI shell to save the informations to a file? There is a HP-UX system installed on the machine but when I boot this system up it gets stuck when searching for a NIS server. How can I abort the search for the NIS server? I tried already all the LAN connections on the back of the machine to get the network working to connect the machine with the NIS. But it didn't work. The LAN LED stays in off status and the system LED blinks in a orange color. Without net access and only the EFI shell it is very hard to collect some infos from the machine.

Thanks for your help.

Bye, imf_admin
Torsten.
Acclaimed Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Re. EFI infos.

1) capture the output within your terminal emulation (save a file on your PC)
or
2) insert an USB stick, change fsx: to this device and run

fs1:> info all > output.txt

re. NIS:

NIS is configured in

/etc/rc.config.d/namesvrs

You could try to abort the boot, go to single user mode, vgchange -a y vg00, mount -a and edit this file:

Without NIS the settings are

NIS_MASTER_SERVER=0
NIS_SLAVE_SERVER=0
NIS_CLIENT=0
NISPLUS_SERVER=0
NISPLUS_CLIENT=0


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dennis Handly
Acclaimed Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

You might be able to abort the NIS server search by using control-|.

>Is it possible in the EFI shell to save the info to a file?

If you can get it to be saved in a file and you can ever get it booted, you can look at the files on EFI by:
# /usr/sbin/efi_ls -d /dev/rdsk/c3t0d0s1
FileName Last Modified Size
EFI/ 9/22/2005 0
STARTUP.NSH 9/22/2005 296

And then efi_cp.
Dennis Handly
Acclaimed Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

>ME: You might be able to abort the NIS server search by using control-|.

Oops, sorry, that info was for HP-UX.
imf_admin
Occasional Advisor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Hi,

you can find the output of the command

EFI>info all > output.txt

in the attached output.txt. Because there are a few firmwares mentioned in the output I am not sure which one to upgrade first. Is there a recommended strategy to get all the firmwares updated?
I have to mention that I am not very experienced in the maintenance of prof. server machines like this one. So i don't understand what is meant by going to single user mode for example. I have some linux practice but I am completely new to HP-UX. I hope that the infos from the output.txt are helpfull. Thanks for the answers.

Bye, imf_admin
Sameer_Nirmal
Honored Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

It looks like SLES 10 and 10 SP1 is not supported on rx2600. So the error "hardware is not supported" seems to legitimate. I referred following HP and Novell website links which confirms about it.

http://h18004.www1.hp.com/products/quickspecs/12650_div/12650_div.html

http://developer.novell.com/yessearch/Search.jsp
imf_admin
Occasional Advisor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Hi,

the support matrix on the HP page shows compatibility with SLES 9 SP4. I tested both of the Smart Setup CD's. The latest for SLES 10 SP1 and a earlier version for the SLES 9 SP4. Both give the same error that my hardware is not supported. A SLES 9 SP4 installation is also an option for me.

Bye, imf_admin.
Sameer_Nirmal
Honored Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

SLES 9 SP4 requires the system firmware at 02.31 as per the certification information available at
http://developer.novell.com/yes/95487.htm

Looking at the current firmware levels, you need to follow the sequence of the FW upgrades
1. Upgrade the System/BMC firmware to 02.21.
The current MP FW E.02.23 is qualified with it.
2. Update the MP FW to E.02.26
3. Update the System/BMC/MP to 02.31/E.03.30

imf_admin
Occasional Advisor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Thanks for your tips Sameer.

I upgraded the System/BMC firmware to 02.21. I also managed it to reconnect the server to the NIS so that I can boot up the installed HP-UX. But now I am stuck at upgrading the Management Processor Card Firmware to version E.02.26. I downloaded the zip file with the firmware from the revision history and tried to telnet to the Management Processor but I had no success. I used the command telnet ip_adress but the connection was refused. At the moment I use the gigabit lan adapter. Do I have to use one of the other lan ports to telnet to the MP? I read in the documentation that I first have to configure the lan of the MP through a console serial console port connection. There is no way to configure the MP or telnet service with SAM?

Thanks for the help.

Bye, imf_admin.
YAQUB_1
Respected Contributor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Hi,

>>> There is no way to configure the MP or telnet service with SAM?
==> MP/GSP/iLO controls power, reset, and Transfer of Control (TOC) capabilities; provides console access; displays and records system events; and displays detailed information about internal subsystems.

SAM is using only OS level command, anyway U can check the below URL site:-
http://docs.hp.com/en/AB464-9003C/ch03s07.html

Hope U got Ur answer...assign points, if Ur problem will be solved.....

Thanks--Yaqub
I am a Customer Advocate!!!
imf_admin
Occasional Advisor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Hello again,

I was able to update all the necessary firmwares of the rx2600 server in the last few weeks. Your tips helped me a lot to do this job and I want to thank you all. With the latest firmwares installed both Smart Setup CD's don't work. BUT installing SLES 10 SP1 directly from the Suse Setup CD's worked perfect, even the rx2600 is not officially supported by this system. So the problem is solved!

Bye imf_admin
imf_admin
Occasional Advisor

Re: SLES 10 SP1 Smart Setup CD on rx2600

Read the thread to find the solution for this problem.