Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

W2K3 SP2 approved for Integrity? (Oracle 9i BSOD at boot)

 
SOLVED
Go to solution
BarnabyArnott
Frequent Advisor

W2K3 SP2 approved for Integrity? (Oracle 9i BSOD at boot)

Has HP approved install of 64-bit Win2K3 SP2 on an Integrity RX4640?

Both RX4640 nodes of an Oracle 9i cluster suffered repeated blue screens during boot recently. The workaround was to remove one of the two fibre channel cables from the FC1050 HBAs on each server.
There are at least two pre SP2 hotfixes for Windows Server 2003 that fix a bugcheck 0x3B SYSTEM_SERVICE_FAILURE. The memory dump implicates ocfs.sys (Oracle Cluster File System) which is up to date.

In the meantime, I've assembled a list of available updates - BIOS/firmware, SP5.1, and Emulex firmware - that will be installed next time the servers are made available for maintenance.
SecurePath v4.0cSP2 is installed, but spmgr queries report an error. I will verify this again after the patching. Since the solution was to disable multipath connection from the server, the supposition is this element is the root cause. Otherwise, the Oracle cluster configuration may be suspect.

Regards, Barnaby Arnott
5 REPLIES 5
Joshua Small_2
Valued Contributor

Re: W2K3 SP2 approved for Integrity? (Oracle 9i BSOD at boot)

Are you potentially suffering this issue?

http://support.microsoft.com/kb/935919
BarnabyArnott
Frequent Advisor

Re: W2K3 SP2 approved for Integrity? (Oracle 9i BSOD at boot)

Unfortunately, no - we have Emulex HBAs, not QLs.
The probable preSP2 hotfix I identified is:
http://support.microsoft.com/kb/914215 - Error message that is similar to the following when a volume is dismounted on a Windows Server 2003-based computer: "STOP 0x0000003B SYSTEM_SERVICE_EXCEPTION"
but the hotfix package is not even available through the premier support site. So I need to apply the whole 64-bit SP2. I'm hoping HP can let me know if this is approved?
Cheers, Barnaby
kris rombauts
Honored Contributor
Solution

Re: W2K3 SP2 approved for Integrity? (Oracle 9i BSOD at boot)

Yes SP2 is supported on Integrity, below are even the POST SP2 hotfixes that you can install if you wanted , see Utility- Quick Fix Engineering (QFE) section:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=346361&prodTypeId=15351&prodSeriesId=88837&swLang=13&taskId=135&swEnvOID=1060#780

The release notes mention the KB ID's which are inside the UPDATE packages.

The 914215 does not seem to apply to 64 bit Itanium Windows version, at least it is not mentioned if you look at the url you postedhttp://support.microsoft.com/kb/914215

HTH

Kris
BarnabyArnott
Frequent Advisor

Re: W2K3 SP2 approved for Integrity? (Oracle 9i BSOD at boot)

Guess I should have dug into the release notes - I knew there were restrictions on patching 64-bit servers; seems in this case SP5.1 is required first. Thanks for that!

You're right - the KB is for x64 but not IA64. Good eye! (Not that I always trust MS to get their docs right ;)

Hopefully this recent crash will enforce the need for maintenance...

Cheers, Barnaby
BarnabyArnott
Frequent Advisor

Re: W2K3 SP2 approved for Integrity? (Oracle 9i BSOD at boot)

Question answered, and then some. Many thanks.