Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

X-Windows issues with RHEL4 on rx2600

 

X-Windows issues with RHEL4 on rx2600

Good day, all....

We have several rx2600's. Most of them are running RHEL AS 3 with absolutely no issues, X-display (console with HP tft flat panel) works just fine.

I spent a good amount of time last night installing RHEL AS 4 - and while I was able to get the OS installed OK (via SERIAL PORT), I am unable to get it to properly display anything on the console screen.

It appears to me that this is an issue with the xorg X-windows environment, specially the settings in the generated /etc/xorg.conf file.

I tried a bunch of different settings and changes in that file- and was able to get a variety of results (some color, one time actually got the cursor), but not a single combination I have tried seems to work.

This is frustrating, since RHEL 3 AS had absolutely no issues detecting and setting up the X parameters correctly.

Yes, I tried copying the contents of the XF86 config from one of the RHEL3 servers and editing the xorg.conf file on the new box with same- no dice.

Any suggestions? Note, I am NOT having problems with the EFI and the console device settings-- it *is* attempting to sent output to the screen- it's just not configured properly with the magic incantation of device/screen/monitor settings in xorg.conf.

Help?
4 REPLIES 4
Ivan Ferreira
Honored Contributor

Re: X-Windows issues with RHEL4 on rx2600

Try with the following command:

system-config-display --reconfig --set-driver=vesa

Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?

Re: X-Windows issues with RHEL4 on rx2600

Um..... nope. Console display is dark/black.

I am this --> <--- close to wiping this out and going back to RHEL3.

Any other ideas?

Re: X-Windows issues with RHEL4 on rx2600

Go figure.

"system-config-display" run by itself finally displayed something, but I have no idea why. I had tried that before a few dozen times. Perhaps it has to do with the VESA setup I had before (which did not work), and it complained that it couldn't handle the X-Server, and started a new one.

It *appears* to be working now, but I fear I could not reproduce the steps on another server if I tried.

Regardless, the new xorg stuff incorporated into RHEL4 on these servers (2600's) is problematic, to say the least.......

Re: X-Windows issues with RHEL4 on rx2600

I think I figured it out.

The core of the problem is an assumption built into xorg, not previously assumed in XF86.

Specifically, if you edit out the
" Load "dri" "
line that's in xorg.conf, it seems OK.

This has more to do with the stupid rack-mounted HP TFT LCD display than the rx2600........