Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

can't boot Linux

 
SOLVED
Go to solution

can't boot Linux

Hi!
I have an Itanium Server with the Operating Systems Windows 2003 Server, HP-UX and Linux on it. Each operating System is installed on a different SCSI disk.
Now when I try to start Linux e get the following output:

loading ext3 module
mounting /proc filesystem
creating block devices
creating root device
mounting root filesystem
VFS: can't find ext3 filesystem on dev sd(8,19)
mount: error 22 mounting ext3
pivotroot:pivot_root(/sysroot,/sysroot/initrd)failed:2
umount /initrd/proc failed:2
freeing unuesd kernel memory:464kb freed
Kernel panic: no init found. Try passing init= option to kernel.

When I remove the disk on which HP-UX is installed and then boot Linux everything works fine and Linux boots.

So I tried to edit the fstab. The entry for the root system after the installation looked like this:
Label=/ / ext3 defaults 11

I removed the label and made the entry look like this:

/dev/sdb3 / ext defaults 11

But nothing changed in the behavior at system startup.

So I played around a little bit and it seems like he tries to boot the Linux kernel from the HP-UX disk.
I tried to make a new boot option in the EFI boot option menue. I selectetd the correct disk and created the new entry. But I had no success.

I still just can boot Linux while teh HP-UX disk is removed.
So if anyone has a suggestion how to solve my problem, my ears are wide open.

Thank you in advance!



5 REPLIES 5
Slawomir Gora
Honored Contributor

Re: can't boot Linux

Hi,

I think you have problem with your disk name
and your idea with editing fstab was good.
Try to boot from rescue CD and check your disks.
cat /etc/partitions - maby it will help you.

How many disk do you have in server and in which slot linux is instaled ?

Re: can't boot Linux

If install linux first and after that install new disk and HP-UX you must check SCSI id's. Change HP-UX disk SCSI id, it must be after you Linux disk SCSI id.

Regards
Ilkka

Re: can't boot Linux

Hi!
I've got 3 Discs in my Server.
here the detailed Information:
HP-UX:
ACPI (HWP0002,100)/PCI(1:0)/SCSI(PUN1,LUN0)/HD(Part1,SIGB60733E8-A817-11D8-8002-DBoot02

Linux:
HD (Part1,SIGGE14C78-EF67-4018-A82E-273ADE52D5C5)/EFI\redhat\elilo.efi
Boot003

Windows:
HD(Part1,SIGCB59D974-9400-11D8-922C-00000000000)/EFI\Microsoft\WINNT50\ia64drBoot001
Windows

The Disks are in the following slots:
Windows:0
HP-UX:1
Linux:2

the command cat/etc/partitions brought nothing. Coldn't find the file partitions.

Another question: How can I check the scsi Id's, and is it really a good idiea to change them. I guess if I do that probably nothing works at all.

Thank you for your help

kind regards!
Gerben Roest
Occasional Advisor
Solution

Re: can't boot Linux

If you have Linux think it's on /dev/sdb, you have to put the Linux disk as the second disk
.
The Linux disk IS the second disk when the HPUX disk is off, so that's probably why that works.

Maybe you can change /dev/sdb into /dev/sdc? You have to do that in the Linux boot option, probably there it says "root=/dev/sdb" with your root partition.

Re: can't boot Linux

Hello!
I solved the Problem! I just changed the elilo.conf and the /etc/fstab files. I changed the lines root = /dev/sdb{n} and /dev/sdb{n} / ext3 ....
to root = /dev/sdc{n} and /dev/sdc{n} / ext3 ....

Now everything works fine!

Thank you all for your help!

Kind regards