Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

disable hyperthreading at UEFI

 
SOLVED
Go to solution
bigdaddy68
Advisor

disable hyperthreading at UEFI

Hi,

Is there a way to disable hyperthreading from UEFI on rx2800 ?

I am being ask to try and make Debian 6.0 Linux run on an Integrity rx2800.

I went into UEFI shell and I ran "bootia64" and I got the Debian installer to run.

I then set console=ttyS0 however I am getting a hang now.. and wanted to try a few things at UEFI to see if I can get it to go..

thx
bigdaddy68
BigDaddy68
2 REPLIES 2
Torsten.
Acclaimed Contributor
Solution

Re: disable hyperthreading at UEFI

Use this:

Shell> help cpuconfig
Deconfigure or reconfigure cpus

CPUCONFIG [module [on|off]]
CPUCONFIG [threads [on|off]]
CPUCONFIG [pstates [on|off]]

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
rick jones
Honored Contributor

Re: disable hyperthreading at UEFI

While I cannot say I know what your perceived hang might be, if it involves the age-old issue about where the console is directed, I doubt that disabling HT will make much of a difference. Certainly it should not hurt.
there is no rest for the wicked yet the virtuous have no pillows