Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

hp-ux server not booting (rx4640)

 
gab_in
Regular Advisor

hp-ux server not booting (rx4640)

Hi,

We have rebooted one hp-ux server and after that it is not booting and giving the below message.

-Loading.: HP-UX Primary Boot: 0/1/1/0.0x1.0x0
Load of HP-UX Primary Boot: 0/1/1/0.0x1.0x0 failed: Not Found
Press any key to continue

-Loading.: EFI Shell [Built-in]
EFI Shell version 1.10 [14.62]
Device mapping table
blk0 : Acpi(HWP0002,0)/Pci(3|0)/Ata(Primary,Master)
blk1 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun0,Lun0)
blk2 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)
Shell>

Can you pleas help ?

Thanks
Gabar
8 REPLIES 8
Torsten.
Acclaimed Contributor

Re: hp-ux server not booting (rx4640)

Please run from EFI shell and post:

# reconnect -r
# map -r
# devices

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
gab_in
Regular Advisor

Re: hp-ux server not booting (rx4640)

thanks for the response. please find below the output
Shell>
Scsi(Pun0,Lun0) HP 146 GMAW3147NC HPC1 (320 MBytes/sec)
Scsi(Pun1,Lun0) HP 146 GMAW3147NC HPC1 (320 MBytes/sec)
ReconnectController(0,0,0) : Status = Success

Shell> map -r
Device mapping table
blk0 : Acpi(HWP0002,0)/Pci(3|0)/Ata(Primary,Master)
blk1 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun0,Lun0)
blk2 : Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun1,Lun0)

Shell>

Shell> devices
C T D
T Y C I
R P F A
L E G G #P #D #C Device Name
== = = = == == == =============================================================
0B R - - - 1 7 Acpi(HWP0002,0)
0C R - - - 1 4 Acpi(HWP0002,100)
0D R - - - 1 - Acpi(HWP0002,200)
0E R - - - 1 - Acpi(HWP0002,400)
0F R - - - 1 - Acpi(HWP0002,500)
10 R - - - 1 - Acpi(HWP0002,600)
18 B - - 1 1 1 Acpi(HWP0002,100)/Pci(2|0)
19 B - - 1 1 1 Acpi(HWP0002,100)/Pci(2|1)
2D D - - 1 - - Primary Standard Error Device
2E D - - 1 - - Primary Console Input Device
2F D - - 1 - - Primary Console Output Device
7A B - - 1 1 1 Acpi(HWP0002,0)/Pci(1|1)
7B B - - 1 1 1 16550 Serial UART Driver
7C B - - 1 5 3 VT-100+ Serial Console
7D D - - 1 - - Acpi(HWP0002,0)/Pci(1|0)
7E D - - 1 2 - Usb Open Host Controller
7F D - - 1 2 - Usb Open Host Controller
80 D - - 1 - - Acpi(HWP0002,0)/Pci(2|2)
81 B X X 1 1 1 PCI IDE/ATAPI Controller
82 D - - 1 2 - Acpi(HWP0002,0)/Pci(4|0)
83 D X X 1 1 - DV-28E-N
84 B X X 1 1 2 LSI Logic Ultra320 SCSI Controller
85 D X X 1 1 - LSI Logic Ultra320 SCSI Controller
86 D - - 1 3 - Acpi(HWP0002,100)/Pci(2|0)/Mac(0017A451190C)
87 D - - 1 3 - Acpi(HWP0002,100)/Pci(2|1)/Mac(0017A451190D)
88 D X X 1 1 - HP 146 GMAW3147NC HPC1
89 D X X 1 1 - HP 146 GMAW3147NC HPC1

Shell>
Torsten.
Acclaimed Contributor

Re: hp-ux server not booting (rx4640)

Not sure yet what is wrong.

Your system (11.31?) has 2 disks, but it does not find a readable filesystem.

Have a look into the console log if you can find some old messages

MP:> cl

Do you have a backup? You will probably need it.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Sandy Chen
Honored Contributor

Re: hp-ux server not booting (rx4640)

Hi,

You rebooted the server for what reason?

Regards,
Sandy
I never think of the future. It comes soon enough.
YAQUB_1
Respected Contributor

Re: hp-ux server not booting (rx4640)

Hi HU,

I think so Ur system is two HDD, hope it has mirror. Can U try to alternative path boot in Ur system.

Thanks--Yaqub
HP Support!!!
Dobromir
Occasional Advisor

Re: hp-ux server not booting (rx4640)

Hi HU,

obviously the EFI Bootcode points to incorrect block of the disk, so the boot services terminates.
My advise is to detect whether the HP-UX or the EFI's NVRAM image is wrong.
How to do it:
1. After server restart using EFI enter in "boot option maintenance menu"
2. select "add boot option"
3. select partition written like "IA64 EFI [Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun0,Lun0)....]
4. message like "select file or change directory" will appear
5. using narrow keys select directory and enter inside
6. there you'll see file called HPUX.efi - select it and hit Enter. Maybe i'm wrong on the location, but using the menu's try to find HPUX.efi
7. you'll be asked for confirmation to save the new option to NVRAM - accept it
than navigate to the starting EFI menu where boot devices are listed and there will be option HPUX or similar - just hit enter on it.
That's the alternative path - adding the boot option of HP-UX again.

if the OS still not loads = HP-UX partition have problems

regards
dobromir
gab_in
Regular Advisor

Re: hp-ux server not booting (rx4640)

thanks all for the response. I have reinstalled the OS.
Tonya Underwood
Regular Advisor

Re: hp-ux server not booting (rx4640)

DOBROMIR

Your explanation was excellent.

I had EFI corruption and fixed by yours.

Would you mind emailing? You seem to know a lot and unsure how I got into this issue.

EFI corruption it seems on my end.

tonya.underwood@hp.com