Integrity Servers
cancel
Showing results for 
Search instead for 
Did you mean: 

"Launching /stand/vmunix" freezes

 
SOLVED
Go to solution
Miguel Silva Rentes
Regular Advisor

"Launching /stand/vmunix" freezes

Hi everyone,

 

I have several HP-UX machines on my workplace and one of them is not booting anymore. I'm trying to get to single user mode but the machine doesn't pass through this point:

 

HPUX> hpux -is /stand/vmunix
> System Memory = 4075 MB
loading section 0
.......................................................... (complete)
loading section 1
.............. (complete)
loading symbol table
loading System Directory (boot.sys) to MFS
....
loading MFSFILES directory (/stand/bootfs) to MFS
....................
Launching /stand/vmunix
SIZE: Text:29280K + Data:7015K + BSS:5240K = Total:41537K

 

I'm using MP card to issue a reset command and then choose single user mode. I can see from VFP that everything is ok (all green lights).  What could be the cause for this problem?

 

Please help.

 

This machine has these characteristics:

 

CPU info:
   Number of CPUs = 2
   Clock speed = 1666 MHz
   Bus speed   = 666 MT/s
   CPUID registers
      vendor information =       "GenuineIntel"
      processor serial number =  0x0000000000000000
      processor version info =   0x0000000020010104
         architecture revision:       0
         processor model:             1   Processor name is not available
         processor revision:          1   
         largest CPUID reg:           4
      processor capabilities =   0x0000000000000005
                      implements long branch:  1
        implements 16-byte atomic operations:  1
   Bus features
      implemented =  0xbdf0000020000000
      selected    =  0x0000000000000000

Cache info:
   L1 Instruction: size =   16 KB, associativity = 4
   L1 Data:        size =   16 KB, associativity = 4
   L2 Instruction: size = 1024 KB, associativity = 8
   L2 Data:        size =  256 KB, associativity = 8
   L3 Unified:     size = 9216 KB, associativity = 9

Memory = 4075 MB (3.979492 GB)

Firmware info:
   Firmware revision = 04.11
   FP SWA driver revision: 1.18
   IPMI is supported on this system.
   ERROR: Unable to obtain manageability firmware revision info.

Platform info:
   model string =          "ia64 hp server rx2660"
(...)


OS info:
   sysname  = HP-UX
   release  = B.11.23
   version  = U (unlimited-user license)
   machine  = ia64
   idnumber = 2931219609
   vmunix _release_version:               
@(#) $Revision: vmunix:    B11.23_LR FLAVOR=perf Fri Aug 29 22:35:38 PDT 2003 $

13 REPLIES 13
Uday_S_Ankolekar
Honored Contributor

Re: "Launching /stand/vmunix" freezes

From  ISL prompt try rebooting from previous kernel

To boot normally from the previous kernel, type:
"hpux (;0)/stand/vmunix.prev" and [return].

To boot in "single user" mode from the previous kernel, type:
"hpux -is (;0)/stand/vmunix.prev" and [return].

Good Luck..
Miguel Silva Rentes
Regular Advisor

Re: "Launching /stand/vmunix" freezes

No luck.

 

HPUX> hpux -is (;0)/stand/vmunix.prev
Could not open file (;0)/stand/vmunix.prev to check for a directory
Could not open (;0)/stand/vmunix.prev

 

loading failed

 

or  if I do

 

HPUX> hpux -is /stand/vmunix.prev
Could not open file /stand/vmunix.prev to check for a directory
Could not open /stand/vmunix.prev

loading failed

 

Any help would be great, as I can't start HP-UX on this machine.

 

Regards

 

 

 

Torsten.
Acclaimed Contributor

Re: "Launching /stand/vmunix" freezes

This is an Itanium machine!


2 things to check:

1) go to EFI and do

Shell> conconfig

Which is the primary console???

If VGA, you cannot anything from MP!

2) from the boot loader do

HPUX> boot backup -is

or

HPUX> boot vmunix -is

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Miguel Silva Rentes
Regular Advisor

Re: "Launching /stand/vmunix" freezes

1) From EFI:

 

CONSOLE CONFIGURATION

  Index Primary Type    Device Path
  ----- ------- -----   ----------
    1      NC   Serial  Acpi(HWP0002,PNP0A03,0)/Pci(1|2)
    2      P    VGA     Acpi(HWP0002,PNP0A03,700)/Pci(1|0)
    3      NC   VGA     Acpi(HWP0002,PNP0A03,0)/Pci(3|0)

 

Do I have to change to Serial? I thought I could see everuthing from Console on MP, just like if I had a monitor connected to the server.

 

2) HPUX> boot backup -is
Boot path is now: backup/vmunix
> System Memory = 4075 MB
loading section 0
.......................................................... (complete)
loading section 1
.............. (complete)
loading symbol table
loading System Directory (boot.sys) to MFS
....
loading MFSFILES directory (backup/bootfs) to MFS
....................
Launching /stand/backup/vmunix
SIZE: Text:29235K + Data:7014K + BSS:5240K = Total:41490K

 

After 10 minutes it shows me no progress.

 

3) HPUX> boot vmunix -is
> System Memory = 4075 MB
loading section 0
.......................................................... (complete)
loading section 1
.............. (complete)
loading symbol table
loading System Directory (boot.sys) to MFS
....
loading MFSFILES directory (bootfs) to MFS
....................
Launching /stand/vmunix
SIZE: Text:29235K + Data:7014K + BSS:5240K = Total:41490K

The same result (no progress) if I run with "boot vmunix -is".

 

Regards

Torsten.
Acclaimed Contributor

Re: "Launching /stand/vmunix" freezes

The console is the problem.


While in boot up, the screen is mirrored to all output devices (VGA+serial), but when starting hp-ux the output is ONLY on the primary console.

This means VGA is the console at the moment, so you cannot see any output via MP!!!

In other words, your system currently boots up, but you cannot see this process, because your console is dead (not configured).


Set the serial to primary and it will work.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Miguel Silva Rentes
Regular Advisor
Solution

Re: "Launching /stand/vmunix" freezes

Problem solved. I changed the Console configuration to Serial and saw from MP (Console) that the server booted with a problem on one filesystem (it was full).

 

Thanks.

Re: "Launching /stand/vmunix" freezes

Hello,

 

Could you provide more details on how to "Set the serial to primary" so that I can also get past the "Launching /stand/vmunix" from an MP telnet session? (After the server boots up, I can reach it via ssh.)

 

If doing this, will I then be able to do a DVD cold-install from an MP Telnet session? When I tried,  I observed the installation going smoothly until the screen display asking the user to input the keyboard type. (I had to complete the installation in the office with the monitor hooked to the VGA port.)

 

Thanks,

   Paul

 

server               : rx2600
OS                     : HP-UX 11.31

EFI FW              : 01.22
System FW      : 02.31
BMC FW           : 01.53
iLO MP FW       : E.03.32

Torsten.
Acclaimed Contributor

Re: "Launching /stand/vmunix" freezes

From EFI do

 

EFI> conconfig

 

 

 

from help:

 

* To change primary operating system console
Shell> conconfig 2 primary

CONSOLE CONFIGURATION

      Index Status Type     Device Path
      ----- ------ ----     -----------
        1      NC  Serial   Acpi(PNP0501,0)
        2      P   Serial   Acpi(HWP0002,0)/Pci(1|1)
        3      S   VGA      Acpi(HWP0002,0)/Pci(4|0)


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   

Re: "Launching /stand/vmunix" freezes

Thank you for the details. I am new to EFI.

MazenH
Occasional Visitor

Re: "Launching /stand/vmunix" freezes

Hi!

 

I am facing the same problem.

 

I tried the conconfig 2 primary. And now all my display is on 'COM' port (serial)

 

I am working on RX1620 machine.

I need to make the display the same on both the MP LAN and the serial connection (as I am familiar to on the the RX and RP servers I worked on before, 4000 series)

 

But as I see, I only have to chose between one of them to show me the output of CO.

 

Is there any way I can have this on this machine?

 

Also, I have another weird problem: In my serial console connection, I cannot see the MP page, it's directly in the CO output, and when I try to CTRL+B, it doesn't do anything. I have tried it on a new board also, same thing!

However, I can connect normally via the DB25 (console/UPS/remote) serial port.

Any help in these issues would be appreciated. :)

 

Thank you! 

Torsten.
Acclaimed Contributor

Re: "Launching /stand/vmunix" freezes

The 25 pin serial connector with a "M" or "W" cable provides MP console, UPS and modem connectors.

This is what you need to use.

The 9pin serial connector below can provide console, but it is not a part of the MP - hence no MP access!

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
shaydon
Occasional Visitor

Re: "Launching /stand/vmunix" freezes

Thanks heaps for this - an oldie but a goodie, caught us out today :)

Krrish47
Occasional Visitor

Re: "Launching /stand/vmunix" freezes

well, when you are at below stage, just interrupt and type  "boot vmunix -vga"  .. no need to go through all menus

Press Any Key to interrupt Autoboot
\EFI\HPUX\AUTO ==> boot vmunix
Seconds left till autoboot - 9